Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Disconnection


22 Sep 2010   #1

Windows 7
 
 
Internet Disconnection

Hey this has been happening occasionally for me for a while and i thought it was about time to post on here and try and get it figured out..

What will happen is everything will be fine and connected then i will just disconnect and when i choose to troubleshoot the problem it comes up with "Local Area Connection" doesn't have a valid IP configuration and also beneath that has The Default gateway is not available.

This is completely random and happens a random amount of times a day sometimes it will happen a few times a day and other times wont happen for a few days but it seems to happen pretty consistently....

Now I have figured out a way to temporarily fix it by turning off my modem and unplugging my router for 10 secs + and then reconnecting and that usually fixes it for a day or so but eventually happens again.....

Could you possibly post a solution or something that will fix it for good.... I mean its not extremely annoying but can get on my nerves when i am doing something important than cuts out...
thanks in advance

My System SpecsSystem Spec
.

22 Sep 2010   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Most likely the router needs a firmware update in order to work with Windows 7. Either that or the network driver isn't up to date. I would try updating the routers firmware first.
My System SpecsSystem Spec
22 Sep 2010   #3

 
 

Quote   Quote: Originally Posted by chev65 View Post
Most likely the router needs a firmware update in order to work with Windows 7. Either that or the network driver isn't up to date. I would try updating the routers firmware first.
+1

Also, if your ISP has sent recent updates tou your router it can cause connectivity issues. Another way of solving this is to turn the router off, press in the reset button (located on the back of the router) for 5+ seconds then turn back on. This will force a hardware reset of the router which will cause it to run an internal diagnostic check then will connect and all will be fine.
Note   Note
It can take up to 2 minutes for connectivity to be fully restored

Hope this helps


OS
My System SpecsSystem Spec
.


23 Sep 2010   #4

Windows 7
 
 

So is that how to update the router firmware? because i dont think its the network adapters as they are all up to date.
My System SpecsSystem Spec
23 Sep 2010   #5

 
 

Quote   Quote: Originally Posted by MHWadester View Post
So is that how to update the router firmware? because i dont think its the network adapters as they are all up to date.
It's not how you'd update the router, it's 'sometimes' how the ISP does it. I would check your router documentation for how to perform a manual update.

What i'm suggesting will just reset the router which should then stop any issues. At least, until your ISP send more stuff up the line
My System SpecsSystem Spec
23 Sep 2010   #6

Windows 7
 
 

well i updated my routers firmware to latest version so i will see if that fixes it if not i will post back.....
My System SpecsSystem Spec
23 Sep 2010   #7

Windows 7 Ult, Windows 8.1 Pro,
 
 

Yes always try a reset first. Updating the router needs to be done from inside the routers set up page.

If you can post the model number and version of your router I can look up your firmware and show a link that shows how to update the firmware.
My System SpecsSystem Spec
02 Oct 2010   #8

Windows 7
 
 

well just thought i should let you guys know that it seems to be working fine now and have not been disconnected in the last few days after updating my firmware.... so thank you for your help.
My System SpecsSystem Spec
02 Oct 2010   #9

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by MHWadester View Post
well just thought i should let you guys know that it seems to be working fine now and have not been disconnected in the last few days after updating my firmware.... so thank you for your help.
This is one of the reasons I like to cover the basics first. Firmware updates fix these sorts of problems all the time so it's good you tried that first. Thanks for reporting back in MHWadester.
My System SpecsSystem Spec
Reply

 Internet Disconnection




Thread Tools



Similar help and support threads for2: Internet Disconnection
Thread Forum
Disconnection issues Network & Sharing
Internet Drops out after USB Connection or Disconnection Network & Sharing
Intermittent internet disconnection Network & Sharing
Internet disconnection for wireless device Network & Sharing
Internet Not Connecting After Disconnection Network & Sharing
Random periodical disconnection from internet. Network & Sharing
hdd disconnection Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:32 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33