Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: (Wirless) Says I'm connected, but I am not.


29 Nov 2010   #1

Win 7 x64
 
 
(Wirless) Says I'm connected, but I am not.

I have 2 HP laptops and one connects, but the other one does not. Both are running Windows 7-64. On the one that does not connect, the system tray says I am connected and when I go to the Network sharing center, it says I am connected. Then I disconnected from the wireless network and then connected. Everything seems to be connected (but I am not) I then did a ipconfig/ all and it shows my IP address as within the range of the router. I pinged google.com and the ping did connect. I then went into the adapter properties and changed the IP address from "automatically assigned" to a specific address and I changed the DNS servers to the OpenDNS servers. Nothing seems to work. By not working, when I open IE it goes to an error page. When I try to enter an IP address, I get the same thing. BTW, I tried using IE-64 and IE-x86 with the same results. Any ideas of what to try next?

My System SpecsSystem Spec
.

29 Nov 2010   #2

 

both laptops purchased around the same time? The working laptop is how old?
My System SpecsSystem Spec
29 Nov 2010   #3

Win 7 x64
 
 

Both are the same, purchased this september.
My System SpecsSystem Spec
.


29 Nov 2010   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Try running this batch file which will reset winsock, reset the TCP/IP stack and release renew your IP.

When it says connected but browsers won't work then it's usually a problem with winsock.


My System SpecsSystem Spec
30 Nov 2010   #5

Win 7 x64
 
 

This is very confusing. I applied the batch file, but it did not change anything. I had actually done the release and renew thing with ipconfig before. I also turned off the firewall and still no connection. I do have another router which I hooked up and was able to connect like the other one, but when I start IE, it gives the same error message. Anybody know what to try next, as I am baffled?
Edit: Forgot to add that I also used device manager to uninstall the NIC, then reboot, and re-install it. All without success.
My System SpecsSystem Spec
01 Dec 2010   #6

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by donnyb View Post
I have 2 HP laptops and one connects, but the other one does not. Both are running Windows 7-64. On the one that does not connect, the system tray says I am connected and when I go to the Network sharing center, it says I am connected. Then I disconnected from the wireless network and then connected. Everything seems to be connected (but I am not) I then did a ipconfig/ all and it shows my IP address as within the range of the router. I pinged google.com and the ping did connect. I then went into the adapter properties and changed the IP address from "automatically assigned" to a specific address and I changed the DNS servers to the OpenDNS servers. Nothing seems to work. By not working, when I open IE it goes to an error page. When I try to enter an IP address, I get the same thing. BTW, I tried using IE-64 and IE-x86 with the same results. Any ideas of what to try next?
The problem is highlighted in bold. You need to set the "router" to use DHCP and do not define the DNS in your IPv4 properties. Just leave the IPv4 properties window at default with DHCP enabled.

If you need to use a certain DNS then define the DNS server in the routers settings instead of IPv4 properties.

The batch file was to check for other problems, as a side effect it often fixes those problems if persent but in your case I believe that the problems are with the routers settings. If you can post your ipconfig /all it would also be helpful.
My System SpecsSystem Spec
01 Dec 2010   #7

Win 7 x64
 
 

I guess I wasn't clear about that. I did assign DNS and IP addresses and it did not work, but then I changed it back to the way it was. That is, I changed it back to get the IP address and DNS address automatically, which is the default.

I will try to get the ipconfig /all printout and post it later this evening.
My System SpecsSystem Spec
01 Dec 2010   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by donnyb View Post
I guess I wasn't clear about that. I did assign DNS and IP addresses and it did not work, but then I changed it back to the way it was. That is, I changed it back to get the IP address and DNS address automatically, which is the default.

I will try to get the ipconfig /all printout and post it later this evening.
Sounds good donnyb, the ipconfig should tell me more.
My System SpecsSystem Spec
01 Dec 2010   #9

Win 7 x64
 
 

I have attached the results.


Attached Files
File Type: txt iptxt.txt (2.9 KB, 22 views)
My System SpecsSystem Spec
02 Dec 2010   #10

Windows 7 Ult, Windows 8.1 Pro,
 
 

Your ipconfig looks normal to me so something must be blocking the connection, perhaps your A/V software is causing this problem it's hard to say for sure but if you have an A/V installed you may need to disable or uninstall it.

Other than that I would try doing a repair installation from the Windows CD because a bad OP system installation is possible and that should repair it.

Repair Install
My System SpecsSystem Spec
Reply

 (Wirless) Says I'm connected, but I am not.




Thread Tools



Similar help and support threads for2: (Wirless) Says I'm connected, but I am not.
Thread Forum
Belkin Wirless G Usb Network Adapter Network & Sharing
Solved I need wifi/wirless drivers for my laptop . Drivers
Have wired network, need to add wirless for eReader. Network & Sharing
Slow Wirless all the sudden Performance & Maintenance
Possible to use wirless (but wired) 360 controller in 7 Hardware & Devices
Wirless connection Network & Sharing
Cant get Wirless Device to work Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33