Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Laptop disconnects from Internet randomly

01 Dec 2010   #1
killadragon

Windows 7 Ultimate 32 bit
 
 
Laptop disconnects from Internet randomly

Hi,

I've been having this problem for the last couple of weeks now. I'm running Windows 7 and my laptop disconnects from the Internet every couple of hours but in the wireless network connection's window it says that I'm connected and a little yellow triangle with a black exclamation mark appears on the signal strength icon. In order to re-connect I have to right click my connection and hit disconnect, then click my connection and connect again. There are 3 other laptops connected to my home network and none of them face this problem so i don't think it's a router/isp problem.

sometimes a little red x would appear on the signal strength icon and my network adapter would disappear from the device manager and the only way to fix that is to shut the computer off and start it again, then the red x icon would disappear and i'd be able to connect for a couple of hours again until the little yellow triangle appears again, i've unchecked the save power box in the driver properties but still doesn't help, also all drivers are up to date.

any help would be much appreciated
thanks


My System SpecsSystem Spec
.
02 Dec 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by killadragon View Post
Hi,

I've been having this problem for the last couple of weeks now. I'm running Windows 7 and my laptop disconnects from the Internet every couple of hours but in the wireless network connection's window it says that I'm connected and a little yellow triangle with a black exclamation mark appears on the signal strength icon. In order to re-connect I have to right click my connection and hit disconnect, then click my connection and connect again. There are 3 other laptops connected to my home network and none of them face this problem so i don't think it's a router/isp problem.

sometimes a little red x would appear on the signal strength icon and my network adapter would disappear from the device manager and the only way to fix that is to shut the computer off and start it again, then the red x icon would disappear and i'd be able to connect for a couple of hours again until the little yellow triangle appears again, i've unchecked the save power box in the driver properties but still doesn't help, also all drivers are up to date.

any help would be much appreciated
thanks

Are you by chance using "homegroup" and are the other machines older OS'es?

win 7 uses IPv6 in homegroup. That really is only meant to be used with win 7 machine and not older machines or routers. they are meant to run workgroup and use IPv4.


Ken J
My System SpecsSystem Spec
02 Dec 2010   #3
killadragon

Windows 7 Ultimate 32 bit
 
 

hi, thanks for the reply

2 laptops are using windows 7 and the third one is using windows vista, and they have no problems when they connect to the internet, also i'm not using homegroup
My System SpecsSystem Spec
.

02 Dec 2010   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by killadragon View Post
Hi,

I've been having this problem for the last couple of weeks now. I'm running Windows 7 and my laptop disconnects from the Internet every couple of hours but in the wireless network connection's window it says that I'm connected and a little yellow triangle with a black exclamation mark appears on the signal strength icon. In order to re-connect I have to right click my connection and hit disconnect, then click my connection and connect again. There are 3 other laptops connected to my home network and none of them face this problem so i don't think it's a router/isp problem.

sometimes a little red x would appear on the signal strength icon and my network adapter would disappear from the device manager and the only way to fix that is to shut the computer off and start it again, then the red x icon would disappear and i'd be able to connect for a couple of hours again until the little yellow triangle appears again, i've unchecked the save power box in the driver properties but still doesn't help, also all drivers are up to date.

any help would be much appreciated
thanks
For this type of problem you should first check to make sure that you are using a clear channel for your wireless connection. Try the Xirrus wifi inspector which you can download in the link below.

It will show you which wifi channels are being used in your area so that you can choose an unused channel for your wireless connection. You can easily change the channel in your router's control panel.

Xirrus: The Leader in High Performance Wi-Fi - Advanced IT Wi-Fi Networking Tools
My System SpecsSystem Spec
02 Dec 2010   #5
brady

 

^^

lol, I was going to ask if they put a wireless telephone in the room with the router.
My System SpecsSystem Spec
02 Dec 2010   #6
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by brady View Post
^^

lol, I was going to ask if they put a wireless telephone in the room with the router.
Lets hope that isn't the case as the 2.4GHz frequency is already crowded enough, a phone station near the computer or router will wreck havoc for sure.
My System SpecsSystem Spec
02 Dec 2010   #7
killadragon

Windows 7 Ultimate 32 bit
 
 

before we go any further, i just had a question about the channels for my wifi connection, if the channels weren't clear, then wudn't the rest of the laptops on my network also be experiencing the same problem? i used xirrus and i'm running on channel 1, and there is 1 other network that is using channel 1 but the signal for that is really weak, here's an image of what i'm talking about


Attached Thumbnails
-untitled.png  
My System SpecsSystem Spec
02 Dec 2010   #8
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by killadragon View Post
before we go any further, i just had a question about the channels for my wifi connection, if the channels weren't clear, then wudn't the rest of the laptops on my network also be experiencing the same problem? i used xirrus and i'm running on channel 1, and there is 1 other network that is using channel 1 but the signal for that is really weak, here's an image of what i'm talking about
Not always, it depends on many factors. I can't see the weak signal channel 1 in your screen shot but it may be worth trying a different channel that isn't on the list of used channels. It certainly won't hurt anything to try a different channel.
My System SpecsSystem Spec
02 Dec 2010   #9
killadragon

Windows 7 Ultimate 32 bit
 
 

how would i go about doing that?
My System SpecsSystem Spec
02 Dec 2010   #10
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by killadragon View Post
how would i go about doing that?
Depending on your routers default gateway you would type the gateway of the router into the URL of your browser to access the routers set up page. I'm not sure what router you have?

Looking at your Xirrus info the default gateway is probably 192.168.1.1, while your in there it would be best to set the router to use WPA2 and AES encryption.

Giving you exact directions to find the place where you change channels is a bit different for all routers, you may need to look around a bit to find the place where you can change channels.

This can also be a problem with your wireless adaptors drivers.
My System SpecsSystem Spec
Reply

 Laptop disconnects from Internet randomly




Thread Tools




Similar help and support threads
Thread Forum
Computer Randomly Disconnects From The Internet For A Few Seconds.
I hope this is a place where i am suppose to post this. But I have been battling my ISP for 2 years now and just needed a second thought from an outside source. Sometimes randomly my computer will disconnect from the internet for like 3 seconds and reconnect. This give my computer enough time to...
Network & Sharing
Laptop and Xbox 360 disconnects randomly from wireless and ethernet
I have a HP G62-371DX Notebook that I have been using to access the internet. Lately I have been experiencing random disconnects that will last from maybe 30 seconds to 2 minutes. They will happen maybe every hour or two and are becoming really annoying. At first I was using the laptops wifi...
Network & Sharing
Win7 randomly disconnects from Internet
So, basically I'm posting for my GF who is all the way in Colorado. --------------- Win7 Pro. Randomly Disconnects from internet. Not the router. Is anything out of the ordinary with this ipconfig?
Network & Sharing
Wireless internet disconnects when laptop lid is closed
Hello! I've looked through all the Windows options and used Google several times, but I can't find a solution to this problem. I bought a new Sony Vaio VPCF11M1E, all drivers are up-to-date and the options are correct. I have the lid close action on "do nothing" and the box in the device...
Network & Sharing
Internet Explorer randomly disconnects
Sometimes my Internet Explorer will randomly disconnect from the internet. Sometimes it will disconnect when I have left the computer for 10 minutes. Sometimes it will disconnect right in the middle of surfing the internet. It is only Internet Explorer because my anti-virus and my stand alone...
Browsers & Mail
Internet Disconnects randomly
Im back, and i've had sleep! :eek: So i have checked everything I can about this issue. Internet disconnects a lot, I get the yellow "Searching for connection" icon down the bottom right on my network icon in the system toolbar. The Dsl light goes out on my modem, Siemens Speedstream 4200, and...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App