Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WiFi adapter not working at full speed


28 Dec 2010   #1

Windows 7 Ultimate x64
 
 
WiFi adapter not working at full speed

Hi guys, I have a problem with my wireless connection on my desktop PC. I have Windows 7 Ultimate installed and a 10/10Mcit connection. The problem is that the connection only works at about 20% of its capabilities (about 2Mbit).
I had a linksys internal WiFi card installed (with that connection worked at about 6Mbit) and I thought that was the problem since it didn't have Windows 7 support and I switched it with a Level 1 WiFi USB adapter. Now the connection only works at 2Mbit. I tried the usb at a different computer with the same signal strength and it works perfectly at 10Mbit, so im guessing its software related or something. Anyway, it's very frustrating. Any help would be appreciated.

Thank you,

Jure

My System SpecsSystem Spec
.

Reply

 WiFi adapter not working at full speed




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33