Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DOS networking (net use gives "error 5: access denied")

21 Jan 2011   #1

Win7 Enterprise 64bit
 
 
DOS networking (net use gives "error 5: access denied")

Let me say from the outset, this is probably not a Windows 7 question (at least, not per se).


I am trying to get a piece of equipment in a machine shop (anilam 5300mk) that has a network card built in, to see a shared folder on the network. I have spent DAYS on the phone with their tech support person, who seems to understand their equipment quite well, but not necessarily "modern" systems or networks.

This mill machine boots into a flavor of DOS, starts it's network drivers, then has a program (written for DOS) that runs the machine.

The network drivers all seem to be working. First, I made sure that the server is in the C:\Net\Hosts and C:\Net\Lmhosts files. Pinging the server is successful.


Now when I try the command:

Net Use G: \\frodo\Fryer user:Fryer /yes

I get a different error message - "Error 5: Access has been denied"

Which is better, but still not success.



Attached is the security log from the server (frodo). It shows that the Anilam (machine name is \\mill) *IS* trying to connect to the server, but is being rejected.

To test things, I created an account on a WinXP computer w/ the username of Fryer. I SUCCESSFULLY mapped the network drive \\frodo\Fryer (using the same password I've been using on the Anilam, of course). Which means the userid/password on the server is fine.



In this case, the server is a Win2008 server.
What am I missing?


Additional:
If I create a "fryer" account and a sharename on a WinXP box, the "Net use" command works.



Attached Files
File Type: txt Fryer.txt (3.7 KB, 156 views)
My System SpecsSystem Spec
.

21 Jan 2011   #2

windows 7 enterprise 32bit
 
 

hey cbarnes,

you probably need to disable the SMB signing of connections made to your w2k8 server.
dos doesn't support SMB...

I found this petri how article that may help..

How to Disable SMB 2.0 on Windows Vista/2008

let us know how you go.

ant
My System SpecsSystem Spec
03 Feb 2011   #3

Windows 7 Pro 32 bit
 
 
Drive Map from DOS to Windows 7

Hi,

I'm new to this forum and forums in general. I have very similar problem.

I have a DOS v6.22 box (client) running MS Client 3.0 LAN Manager connecting to Windows 7 Workstation (server) via the drive map command Net Use Z: \\Win7WS\ShareName command. I get the same error "Error 5: Access has been denied" as CNBarnes. I have successfully mapped this same DOS machine to a WinXP box. I have also mapped the XP machine to the Windows 7 share using the account/pass setup for the DOS machine. Per link provided by Anta I tried adding registry key Smb2 on Win 7 WS, setting it to a value of 0 then re-booting. Reportedly this disables SMB 2.0 which earlier OS's don't understand. Unfortunately it does not solve my issue.

Any help is appreciated
My System SpecsSystem Spec
.


Reply

 DOS networking (net use gives "error 5: access denied")




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:44 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33