Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: win7 detects my wireless card but won't use it...

20 Feb 2011   #1

Windows 7 Professional 64 Bit
win7 detects my wireless card but won't use it...

I'm having this odd problem where win7 autodetects my wireless network card just fine (Asus WL-160N). There are no proper win7 drivers as its an old card, it seems to use the same one as I got from the asus website.

However, when I try to run ANYTHING that needs a net connection, like my antivirus install program, it tells me that it cannot detect a network card. As a matter of fact, there is no wireless networking tab under networking, and there is not even wireless zero service running. On top of that, it does not even try to detect my router (Asus RT-NI6), again, because it thinks there is no card.

I found this thread but none of the people seem to have a similar problem. As the last post was so long ago, I thought I would make a new thread - sorry if its not in the right spot or if a newer thread exists. I found all of the suggestions did nothing. I don't know much about win7, having only had it a couple weeks. With no wireless its worse than useless to me.

I have installed the software that came with the card, and it does nothing. Even tried running it in XP and Vista mode (as admin user). I have only the basic install from the dvd, with no wired connection currently available. The only internet i have is on my XP system, that is too unstable (thats why I wanted to upgrade to win7). Obviously I'm missing something, but no clue.

If you need more information, I'm more than willing to provide. Any help is greatly appreciated.

Edit: the card and the router work fine in XP, no problems. Wireless zero in XP is an issue, so I have to use the control center program from asus.

My System SpecsSystem Spec
20 Feb 2011   #2

Windows 7 Ultimate x64 SP1

I'd just upgrade to a card that supports Windows 7 and be done with it.
My System SpecsSystem Spec

 win7 detects my wireless card but won't use it...

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
System doesn't detects video card after re-installing windows 7 x64.
Hello, guys! I am sorry if I posted this in a wrong section, this topic relates to graphic cards, drivers, system, windows updates, I guess. So, let me explain how did I get this problem. Recently (about a day ago) I decided to re-install my windows 7. My PC was full of crap, as I thought and I...
Graphic Cards
Win7 Detects i7 instead of i5
hi guys, i have just noticed that on my DELL work PC, win7 detects that i have an i7 3540M but i am pretty sure that it's an i5, always had... i had a look in the BIOS and it detects i7 at the moment, even just upgraded BIOS to the latest from Dell's website, really weird.. i am just worried...
Hardware & Devices
What is a good wireless network card for Win7?
Is i better to ger a PCI one these days or USB? Which one is likely to give the best reception? I had a Belkin 56g PCi card before, that was ok.
Hardware & Devices
how win7 detects a DSL router
when i goto network, it shows our company DSL there....... not only it show DSL router but it knows it IP address also............ i dont understand how can win7 detect the DSL router
Network & Sharing
Win7 only Detects XP PC in "Full Network Map"
I have an unusual problem that started as of last week. My 3-PC network consists of two Win7 Ultimate (fully updated) PCs and a single XP-SP3 (fully updated) PC. As of early last week, all PCs appeared correctly in the workgoup on both Win7 and XP PCs and shared resources successfully. I...
Network & Sharing
Help w7 detects ATI instead of Nvidia graphic card
Hi everybody! I registered in order to get some help with this since Im unable to solve this issue by myself So I installed w7 32bit a couple of days ago and I have tried to install the drivers for my NVIDIA 8600 GTS ever since without success. I downloaded several versions from nvidia and none...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:39.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App