Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network adapter not starting


01 Mar 2011   #1

Windows 7 Ultimate 64 bit
 
 
Network adapter not starting

Running Win 7 Ultimate 64 bit. I have an HP desktop with a Realtek PCIe GBE Family Controller. All was working fine until I got the automatic Win 7 critical update issued 2/15/2011. That is the only thing I can think of that changed. Now for the problem.

When my PC boots it appears that the NIC driver is not being started giving me no access to my Netgear WNDR3700 router and thus no internet connection. If I uninstall the Realtek Controller using device manager then restart the system it finds a new device, the Realtek controller, and installs it and I can then access router and the internet. When I shut it off the next time I start it up again I have no access to the router.

I did restore my system back to 2/14/2011 using the restore point created by the 2/15/2011 update and it worked fine until Windows automatically installed the critical update again. That is why I blame the update. Since then there have been two or three more critical updates but the problem persists. Also I can no longer go back to the 2/14/2011 restore as it seems the system only retains the latest restore points and 2/14/2011 is gone.

One other thing is there is another listing under Network Adapters in Device Manager. WAN Miniport (PPPOE) it has the little triangle with the exclamation point in it. I tried to reinstall it searching both my hard drive and the internet for a driver but it can't find one. Under Properties it also says, "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)" However this does not stop me from accessing my router using the method described above.

Any suggestions on how to fix this problem would be greatly appreciated. I'm tired of having to uninstall the NIC and then reboot in order to access my network and the internet.


My System SpecsSystem Spec
.

01 Mar 2011   #2

Windows 8 Core X64
 
 

Set Automatic Updates to notify but not install, then the next time the update is offered, unselect it then check the box that says not to offer it again.
My System SpecsSystem Spec
01 Mar 2011   #3

Windows 7 Ultimate 64 bit
 
 

Thanks for the response but I no longer have access to the restore point that works. It seems there have been so many updates issued recently that the one I need has dropped off the list. I have already done what you suggested but this is the first time I've encountered an update that caused a problem so lazily I just let the system do automatic updates. Also I'm not 100% sure it was the update but most of the evidence points to it.
My System SpecsSystem Spec
.


02 Mar 2011   #4

Windows 7 Ultimate 64 bit
 
 

Well the Windows 7 update received 3/1/2011 seems to have fixed the problem as since I allowed it to install I have not had a problem. Crossing my fingers.
My System SpecsSystem Spec
Reply

 Network adapter not starting




Thread Tools



Similar help and support threads for2: Network adapter not starting
Thread Forum
Errors with starting Virtual Wifi Miniport Adapter Network & Sharing
Problems with wireless network adapter and network connection driver Network & Sharing
Atheros AR5007 WiFi Adapter not starting Hardware & Devices
Wireless adapter stoping me from starting window Hardware & Devices
Network Adapter Not Shown in Network and Sharing Center Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:54 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33