Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Lost the ability to browse websites

02 Mar 2011   #1
Thomas R

Windows 7 Ultimate x64 SP1 Ver. 6.1.7601 (Build 7601)
Lost the ability to browse websites

I have a problem that drives me nuts: in my main account I lost the ability to browse any websites.
I can successfully ping to the Default Gateway and websites but when trying to open a website I always get the "Internet Explorer cannot display the webpage" message.
I also can ping the computer from the router or another computer.
Also Windows Update and Microsoft Security Essentials have no problems searching or downloading updates.
And in another account on the same Windows 7 installation I can browse websites without any issues.
I already tried to shut down the firewall but that didn't solve the problem.

Has anybody an idea what might cause this problem?

My System SpecsSystem Spec

02 Mar 2011   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Try two things to test
Reset Explorer
Tools>Internet Options>Advanced>Reset. This removes all addons, which you will have to replace later.
Try another browser.

Run a full anti virus scan
Download and run a full updated Malwarebytes scan.
My System SpecsSystem Spec
02 Mar 2011   #3
Microsoft MVP

Win7 & Win8 64bit

Hi Thomas R,

Check for your browser's Proxy settings. Remove it if there's any setting found.
How to Remove a Proxy Server |

Please let us know.
My System SpecsSystem Spec

02 Mar 2011   #4
Thomas R

Windows 7 Ultimate x64 SP1 Ver. 6.1.7601 (Build 7601)

I already found it.
It was the LAN settings of IE: Automatic search of setting was not checked.
My System SpecsSystem Spec
02 Mar 2011   #5
Microsoft MVP

Win7 & Win8 64bit

If above suggestions didn't work, pls. check the LAN or Wireless setting and make sure that 'Obtain DNS server address automatically' is checked off and that DHCP is enabled.
How to enable DHCP in Windows 7? | Windows 7 Themes
My System SpecsSystem Spec

 Lost the ability to browse websites

Thread Tools

Similar help and support threads
Thread Forum
Dell Laptop has lost ability clone screens with Soniq TV via HDMI.
I had previously cloned screens between the Dell Laptop and my Soniq TV via HDMI with no problem. Today the laptop no longer is able to do this. In the screen resolution menu there are only options to extend or put the screens on only the laptop or only the tv. In the Nvidia control panel there is...
General Discussion
I've lost the ability to create "NEW" folders
For some reason, I now cannot create any new folders. In Explorer (IE10), when a folder is open and I click on the "New Folder" button on the pane task bar at the top to create a new folder, nothing happens. It used to create an icon for an un-named new folder in the pane of the folder I was...
General Discussion
I've lost the ability to create folders in Windows 7
I can't create folders any longer, anywhere -- including on facebook, desktop, within existing folders. My only option is to create compressed folders. I have a Samsung laptop, Windows 7 Home Premium.
General Discussion
lost CD burning ability after Win 7 HP recovery
I bought Windows 7 Home Premium online and downloaded it when my Vista crashed and wouldn't reboot. They asked if I wished to purchase a hard disk back-up to the download and I opted to pay for them to send me the disk. I had no reason to try out the hard disk (which reads Windows 7 Home Premium 32...
Sound & Audio
Lost ability to download gagdets
Hello, Don't know how but it occurred two days ago. I lost a my Drive Meter. Have tried to upload it through gadgets and it continually shows the download box for an instant and then it disappears. Tried other gadgets with the same result. Any ideas? Thanks for any assistance. glennc
Connected to the internet but cant browse websites
I have an HP laptop and i can connect to the network both with wireless or wired, but i cant browse websites. I've tried connecting from several different locations and i get the same result. I took it to Best Buy and they said "its broke and they cant help me". Anyone have any suggestions for me?...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:22.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App