Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't access samba 2 share on Thomson TG784 router!


29 Mar 2011   #1

Windows 7 Enterprise 32 bit
 
 
Can't access samba 2 share on Thomson TG784 router!

Please help, I'm at a loss here. I'm trying to get Windows 7 to access a SMB share (Samba 2.something -- unfortunately, upgrading is not an option) attached (NAS-style) to my router, a Thomson TG784. My other computer, which runs XP, has no problems with this, and the two computers can access each other's shares. Windows 7 can ping the IP which holds the router's share, but won't recognise its network name. They are all in the same workgroup of course.

I've tried every trick I found on the net. Windows 7 is set to send LM & NTLM. Minimum session security settings for NTLM are turned off. I disabled IPv6 and IPv6 tunnels. I reset all IP settings again. I uninstalled my antivirus software. I turned off Windows Firewall. I checked the integrity of the files and stuff (no problems). I hacked into the router and fiddled with its Samba settings. I reset them again. I checked that the relevant services were all started. I connected Windows 7 computer via ethernet instead of wi-fi. I did the above in various combinations. All to no avail.

Trying to access the share directly by running \\192.168.1.253\Disk_a1 gives the message: The device or resource (192.168.1.253) is not set up to accept connections on port "The File and printer sharing (SMB)". Although it clearly IS.

I guess this may have something to do with it: I can't seem to get netbios via tcp/ip enabled. Of course it's checked in the config, but even after disabling ipv6 and all that, ipconfig /all still says "disabled", and nbtstat just exits with: Failed to access NetBT driver -- NetBT may not be loaded.

net view 192.168.1.253 gives me: System error 53 has occurred. The network path was not found. Of course, when run on the XP computer, it gives me a list of shares as expected.

This is the result of ipconfig /all, now that all IP settings are back to normal:

Code:
Windows IP Configuration

   Host Name . . . . . . . . . . . . : Gort
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : 00-16-CF-DD-25-48
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 PL Network Connection
   Physical Address. . . . . . . . . : 00-15-58-31-EB-D2
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Connection
   Physical Address. . . . . . . . . : 00-18-DE-73-A0-BE
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a532:10f1:16d8:358a%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.68(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : den 29 mars 2011 22:57:57
   Lease Expires . . . . . . . . . . : den 30 mars 2011 22:58:02
   Default Gateway . . . . . . . . . : 192.168.1.254
   DHCP Server . . . . . . . . . . . : 192.168.1.254
   DHCPv6 IAID . . . . . . . . . . . : 184555742
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-8E-FF-AC-00-15-58-31-EB-D2

   DNS Servers . . . . . . . . . . . : 192.168.1.254
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.lan:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:14dc:27f0:aa1f:dd02(Preferred)
   Link-local IPv6 Address . . . . . : fe80::14dc:27f0:aa1f:dd02%12(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled
Could somebody please help?

My System SpecsSystem Spec
.

Reply

 Can't access samba 2 share on Thomson TG784 router!




Thread Tools



Similar help and support threads for2: Can't access samba 2 share on Thomson TG784 router!
Thread Forum
Keep getting access denied when trying to connect to Samba share Network & Sharing
Samba Share Networkmounting as X,Y,Z works, \\Share\mount not Network & Sharing
Need Help with Wireless Router Thomson TG585 v7 Network & Sharing
Lost Username and PW thomson tg585 v7 router Network & Sharing
SAMBA share windows 7 and HP Unix Network & Sharing
Can't connect to samba share via name; ip works Network & Sharing
Can't connect to samba share Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33