Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Trust relationship failed?


15 Apr 2011   #1

Windows 7 Home Premium 64bit
 
 
Trust relationship failed?

Alright so I have a couple of Windows 7 machines on a domain, and I am trying to add users as local admins so that they can tinker with settings without bothering me or the other Network Admin every time they need to install a font or plugin. When I try to add their domain login to the administrators group on the local machine, I get an error.
"Trust relationship between this workstation and the primary domain failed."
Only option is to click Ok.
Not sure why this is happening, found a hotfix from Microsoft, but they claim it is experimental, and an "official update" should be along sometime in the future. Don't like the experimental hotfix approach, anyone know how to fix this, and what might be causing it in the first place?

My System SpecsSystem Spec
.

Reply

 Trust relationship failed?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33