Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange Remote Desktop problem


17 Apr 2011   #1

Windows 7 Premium 32bit
 
 
Strange Remote Desktop problem

I'm connecting to a Windows 7 machine using remote desktop. It worked before but for some reason now it's behaving strangely. I hit connect, and it successfully connects to the remote machine. I see the Welcome screen with the spinning wheel, and then just black. It's a black screen. Nothing happens. I can still see my mouse cursor and move it around. I can also send a CTRL+ALT+END command and I get the appropriate menu. The choices are Lock the computer, log off, change password, start task manager. None of the choices do anything. I also see the red button on the bottom right with choices, shutdown, sleep, or restart. Shutdown and restart both don't do anything. Any tips?


My System SpecsSystem Spec
.

17 Apr 2011   #2
Microsoft MVP

 

Have you tried Team Viewer? It is much more reliable, has better features, and it's free.
TeamViewer Download
My System SpecsSystem Spec
17 Apr 2011   #3

Windows 7 Premium 32bit
 
 

Thanks. However at this point I can't do anything as I don't have physical access to my computer. All I have is a remote desktop connection that's being less than helpful. Any idea what's going on? I obviously have a connection
My System SpecsSystem Spec
.


17 Apr 2011   #4

Windows 7 Pro x64
 
 

So you are in a remote location?

It may be a setting on the remote locations router that is blocking you from making a full connection.
The again it could be the PC you're trying to connect to that is down in some way. Is there anyone at the location of the PC you are trying to connect to that can restart the PC.
My System SpecsSystem Spec
17 Apr 2011   #5

Windows 7 Premium 32bit
 
 

Nope that's not it. I have a connection. I can stream from my pc and everything I just can't access it via remote desktop. But I could before... It's almost as if I'm locked out by a session already in place or something. Would that just give you a black screen? I'm not sure
My System SpecsSystem Spec
17 Apr 2011   #6

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

Could it be an Aero vs. Basic desktop scheme issue?

I connect to assorted family machines remotely (as the "guru" who helps out when they have problems), using RealVNC. One of those machines is a new Windows 7 machine that runs with an Aero desktop.

Well, when I connect remotely to that machine Windows 7 on that machine changes its desktop presentation scheme from "Aero" to "Basic", which is fine with me. However, this display transition process seems to block RealVNC's client (and mirror driver) running on that machine from presenting the remote desktop back to me on my machine. I can see things, but nothing works... although I can seemingly move the cursor around but can't actually click on anything and have it work.

What seems to be causing the problem is that popup message at the bottom of the screen, appearing over the taskbar, which advises that "a remote connection has forced changing from Aero to Basic scheme".

All I need to do is close that remote client window on my machine, and then re-connect to the remote machine again. This time, the remote desktop is apparently still/already in "basic" presentation mode and everything now once again works perfectly with RealVNC and the mirror driver. I once again have full and complete control over the remote desktop, just in "basic" mode. I can actually see that popup message at the bottom of the screen, and then it disappears as it should.

Might this information be relevant to your "Remote Desktop Connection" story? Again... Aero vs. Basic? Does the remote Windows 7 machine for you also change from Aero to Basic when you connect with Remote Desktop?
My System SpecsSystem Spec
07 May 2011   #7

Windows 7 Ultimate x64
 
 

I once solved the same problem by changing the NIC.
I had an Intel PRO/100, it was fine. I changed to Intel Desktop 1000 GT, the problem encountered.
I now changed back to Intel PRO/100. It works fine.
My System SpecsSystem Spec
Reply

 Strange Remote Desktop problem




Thread Tools



Similar help and support threads for2: Strange Remote Desktop problem
Thread Forum
Problem with Remote Desktop Network & Sharing
Remote Desktop Problem Network & Sharing
Problem: Remote Desktop through VPN Network & Sharing
Remote Desktop Problem Network & Sharing
Strange Remote Desktop Connection Behavior Network & Sharing
Strange display problem on desktop General Discussion
Remote Desktop Problem Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33