Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Strange High Ping in Win7

19 Apr 2011   #1

Windows 7 Ultimate x 64
 
 
Strange High Ping in Win7

Greets to all!

I have an odd high ping situation I can't figure out. I have two Windows boxes on the same home network. The older (5 yrs) box is running Win XP. The newer box is running Win 7 (64b) Enterprise. Lately I've been getting high 500ms + pings from everywhere on the Windows 7 box. I'm 20 miles outside Philadelphia, and getting 512ms pings from Speedtest.net The old XP box shows 18ms pings! Yet the thru-put is around the 10mbs I should be getting. 20mbs to NYC.

Comcast has come in and replaced the modem and cleaned up some of the connections, and still get the same 512ms ping to Phila in the Windows 7 box. I also notice a lot of "waiting for xzz.com..." when using Firefox or Chrome on the Windows 7 computer.

Interestingly, Pingtest.net shows the expected 18ms ping to Phila! Other speed test sites show the 500ms pings... so I don't think it is Speedtest.net.

Anybody have any ideas what might be causing this Win 7 box to show such high pings on Speedtest?

=Alan R.

My System SpecsSystem Spec
19 Apr 2011   #2
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Hello,

Do you have any Anti-Virus or Security software running? Try disabling it and see if it helps.

Also, click on Start and type msconfig press enter, locate the Start up Apps and in here, disable unnecessary Startup Apps.

Please post an update.
My System SpecsSystem Spec
19 Apr 2011   #3

Windows 7 Ultimate x 64
 
 
All Virus off

Yes - have done that. Totally disabled Bitdefender and Prevx - no change. Have tried TCP Optimizer - now restored to default settings - no effect - still big pings.

Next I'll try booting in Safe Mode w/network and see if I can get to Speedtest.net to run.

Any thoughts as to why I get a good ping with PingTest.net and a bad one with SpeedTest?

=Alan R
My System SpecsSystem Spec
.


19 Apr 2011   #4
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

You have mentioned a Modem, is there a router connected?

Is this a wired issue connection?
My System SpecsSystem Spec
19 Apr 2011   #5

Windows 7 Ultimate x 64
 
 

Yes - the cable modem goes to a Vonage phone interface and router, and then thru a Gigabyte switch to the Windows 7 box and the old XP box is on the same hookup. As I saidk the XP box gets the correct ping, but Windows 7 does not. Also, I have hooked the Windows 7 box directly to the cable modem, bypassing the router and switch, and still got the 500ms pings.

I just seems like some TCP/IP setting in Windows 7 is messing things up. Then there is the odd factor that the website Pingtest.com returns low pings to all sites, but when I go through Speedtest.net (and other speed test sites) I show the high pings. Very funky indeed!

=Alan R.
My System SpecsSystem Spec
20 Apr 2011   #6

Windows 7 Ultimate x 64
 
 
More Info

Have just booted Windows 7 into Safe Mode w/network, and ran the Speedtest.net test. As expected - the ping to Philadelphia is now 18 ms like it should be. Other thru-put went through the roof along with the better ping. I also went to the Wordpress-based site I'm working on and all the admin level page-changes, which are always draggy under full Windows 7 now snapped right in.

Now booted back to full Windows 7 Enterprise and the ping to Phila goes back to 512 ms.

So.

Some setting in Windows 7 is f***ing with my ping and web access.
I've rounded up (and executed) all the usual suspects, and still no fix...

Any new ideas greatly appreciated.

=Alan R.
My System SpecsSystem Spec
20 Apr 2011   #7
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Might want to try to scan for any Malware/Spyware, I use Malwarebytes, it won't hurt.

Also, go thru the Services running from msconfig, find out what the culprit might be.
If you are also running any P2P programs, disable the Services.

Also, do a Speedtest using diff Browsers (Chrome, IE, Firefox), what's the difference on the pings?
My System SpecsSystem Spec
Reply

 Strange High Ping in Win7





Thread Tools



Similar help and support threads for2: Strange High Ping in Win7
Thread Forum
Battlefield 2, Server ping 0. Kicked for "high average ping." Gaming
High download speed and signal, high ping in games, slow page loads Network & Sharing
High FPS = High Ping in games (solution anyone?) Network & Sharing
High ping in game, low ping in cmd Gaming
EXTREMELY High ping on Win7 Performance & Maintenance
Ping way too high Network & Sharing
High ping in Win7, related with FPS Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33