Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Internet connection on LAN

23 Apr 2011   #1

WIN 7 Ultimate x64
Internet connection on LAN

I am working on a new Win7 build and have not been able to get an internet connection on my (MSHOME) LAN.

I have a Belkin 4 port router and a DSL modem. Two XP Home computers on my LAN connect OK. The new Win7 has problems.

After assigning a static IP address of to the W7 computer I can share with the XP computers and sign in on the router. (I have not been able to get W7 to share in the DHCP pool. This inability to obtain a DHCP address also happened on a previous W7 build that I aborted due to mobo issues. Their too I had to assign a static IP address.)
AVG Internet Suite firewall network - 2.8 assigned as safe.

I get a network picture of the W7 computer connected to an unknown network (public) and a red X between the network and the internet.

I tried to rename the unknown network "MSHOME" but have been unable to do so. I did not attempt to make a W7 workgroup as I understand it would not work with this OS mixture.

I am just "spinning my wheels" now.
Time to ask for help----please.

My System SpecsSystem Spec
23 Apr 2011   #2


I would suggest that maybe you would be best to reset your Belkin router to "factory defaults" and start the setup again. I have had three Belkin routers and have had to do the reset on a couple of occasions because something in the setup wasnot quite correct. Once you get it setup correctly it should run using DHCP without problem.
My System SpecsSystem Spec
23 Apr 2011   #3

WIN 7 Ultimate x64

That was fast wilywombat. We must be close to the same time zone.

I bricked one mobo and a router with firmware updates. Firmware updates are now a "white knuckle affair" with me.

I hope I do not need a router firmware update to get Win7 computers
to use the DHCP pool.

I will try your suuggestion and report back.

Thanks for your prompt reply.

Regards Jim
My System SpecsSystem Spec

23 Apr 2011   #4

WIN 7 Ultimate x64


Did as you said.
It worked. Win7 computer now obtains Ip dynamically and has LAN and internet connections.
I was going about it too complicated.

Thanks wilywombat!!!!
My System SpecsSystem Spec
23 Apr 2011   #5


My pleasure, visit the forums when you can and pick up a few tips. I'm actually in Scotland...not far from you!!
Good Luck and glad to be of help.
My System SpecsSystem Spec

 Internet connection on LAN

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Try to update internet explorer 8, and lose internet connection
When i try to update internet explorer 8 i lose the internet connection. Windows 7, int exp 8 64 bit.
Browsers & Mail
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
LAN connection without internet stops wireless internet connection
Well I've fiddled around and searched to no avail ... I have some form of conflict between my main wireless network and a LAN I use for file transfer and streaming. The attached PDF file illustrates the setup. Basically, the wireless network is fine by itself. Music streams from the...
Network & Sharing
Fallback to second internet connection after internet access loss?
My computer has two network adapters connected to two different internet gateways. One is Ethernet and the other is WIFI. The Ethernet connection is first on the access order list (if you don't know what I'm talking about, see the image attached) and the WIFI is second. Today, the internet...
Network & Sharing
Internet connection error or internet Download Manager problem
I'm using IDM 5.19 build 3 in may DELL Studio 14 using Windows 7. Recently I cannot finish my downloads. When I start the queue the speed will be around 200kbps but after a few seconds the speed fluctuates and becomes slower. The speed becomes 5kbps or slower. Is this my internet connection or...
Wireless network connection lost internet connection
Hi everyone, I work in an office where we have a main desktop computer which is connected to the internet via a Time Warner modem. The modem is connected by cable to a netgear wireless router, and up until today there have been no problems connecting to the internet from the laptops that use the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:50.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App