Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Upgrade causing slow browsing, fine internet speed


11 May 2011   #1

Windows 7 Professional 32 Bit
 
 
Upgrade causing slow browsing, fine internet speed

Hi,
Recently I upgraded from Windows Vista home basic 32 bit to Windows 7 professional 32 bit.

Now however, my browsing speed is very slow and often doesnt work. It seems to especially have trouble with google related stuff (eg Gmail and google maps etc).
However when I finally get a page up, download speed for files are completely normal. Im currently using firefox 4, but I have already tried Chrome and Internet Explorer with no difference between the 3. Ive tried disabling/uninstalling firefox addons, Ive also tried with and with out an active firewall, and turning off my anti virus software. Ive also scanned my computer with my anti virus (Sophos) as well as Spybot Search and Destroy. None of this has helped either.

All other computers in my house hold are all browsing the net fine, including my laptop also using windows 7.

I have really run out of ideas, as my computer was browsing the net fine before upgrading.

Sorry if I have posted this in the wrong place or this has been resolved elsewhere, I am a neewbie to forums, and I couldnt see a similar thread.

Cheers

My System SpecsSystem Spec
.

11 May 2011   #2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Are you using the latest network drivers? Also, things like java and flash player and any other plugins you use need to be installed with a new install.

Try changing DNS servers to opendns or google.
My System SpecsSystem Spec
11 May 2011   #3

Windows 7 Professional 32 Bit
 
 

Yes, I have updated/ checked for updates for drivers. I have also re-installed most programs, I definately know I have installed java and flash player.

Thanks, Ill have a go at changing DNS servers, not that I know what im doing. Ill read up and have a go.
Cheers
My System SpecsSystem Spec
.


11 May 2011   #4

Windows 7 Professional 32 Bit
 
 

Ok, so Ive had a go at changing DNS, I tried using googles DNS, that didnt help. I went to the website for opendns, I dont really understand what was going on, do I have to subscribe or get the free one? which contains ads?
anyways I then logged into my own router and changed my computer to match it.

This has resolved my issue. Thank you so much for you help, its been bugging me out for days!
My System SpecsSystem Spec
11 May 2011   #5

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

opendns ip addresses are:

208.67.222.222
208.67.220.220

Just input these numbers in the preferred dns server and alternate dns server fields respectively.

Name:  Capture.PNG
Views: 4
Size:  40.1 KB


My System SpecsSystem Spec
11 May 2011   #6

Windows 7 Professional 32 Bit
 
 

i did try those numbers, randomly enough as they were on a tutorial somewhere on this site, however they didnt work either. But not to worry as I said, Ive got it working now anyways!
My System SpecsSystem Spec
13 May 2011   #7

Windows 7 Professional 32 Bit
 
 

ok, so typing in the DNS made it work for about 30 mins, and hasnt worked since. Since then I have tried Open DNS (including subscribing and also downloading their DNS updater). So once again Im out of ideas....
My System SpecsSystem Spec
13 May 2011   #8

W7 Professional x64
 
 

Did the issue happen immediately after the upgrade? How did you install the upgrade?
My System SpecsSystem Spec
13 May 2011   #9

Windows 7 Professional 32 Bit
 
 

Yer I havent had the internet working properly since the upgrade.
It was upgraded by downloading the iso file from microsoft. I needed to do a fresh install though, as my vista was only home basic.
My System SpecsSystem Spec
13 May 2011   #10

W7 Professional x64
 
 

So you did a clean installation?
My System SpecsSystem Spec
Reply

 Upgrade causing slow browsing, fine internet speed




Thread Tools



Similar help and support threads for2: Upgrade causing slow browsing, fine internet speed
Thread Forum
Internet is fine. I start browsing, it goes down. Network & Sharing
Solved Slow upload speed with 1 PC, others work fine Network & Sharing
My web browsing speed too slow. Browsers & Mail
Bitdefender slow down my internet browsing speed. Browsers & Mail
Browsers Slow, Torrent speed fine. Network & Sharing
Browsers Slow, Torrent speed fine Browsers & Mail
VERY Slow internet browsing speed. Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:41 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33