Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless Encryption Problem


14 May 2011   #1

Windows 7 Pro
 
 
Wireless Encryption Problem

Hi,

I've got a D-link DSL 2740b modem and router and I can only use wireless if with WEP encryption. WPA doesn't work.

The LAN connection is fine, and when I use WEP encryption on my wireless lAN it seems to work well. However, as soon as I opt for WPA or WPA2 I am unable to connect on my laptop. I'm using personal mode (PSK) so that isn't the problem.

Does anyone know some basic troubleshooting steps for this sort of problem?

Thanks

My System SpecsSystem Spec
.

16 May 2011   #2
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Hello,

What's the O/S and Wi-Fi Adapter's make and model in question?
My System SpecsSystem Spec
16 May 2011   #3

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Try using WPA-PSK and encryption type TKIP.

http://files.dlink.com.au/Products/D...ss_network.pdf
My System SpecsSystem Spec
.


16 May 2011   #4

Windows 7 Pro
 
 

Thanks for the replies

As noted in the original post, I am using a D-link DSL 2740b modem and wireless router. My O/S is windows 7 pro (64 bit). BTW you can normally see someone's OS by clicking my system specs.

I've tried TKIP and AES. Doesn't make any difference.

Any more tips??
My System SpecsSystem Spec
16 May 2011   #5

win7
 
 

Hi Kungal, I think what 2xg is trying to get at is what type of adaptor is in your computer not the DSL 2740b. Is it a laptop computer you are using or a desktop? If desktop, what make/model of wireless adaptor is in your system. The reason this is being asked is because if you have a laptop or adaptor that is "of an age" then it my not support the use of WPA. This is not likely but the info is required to help figure out your problem.
My System SpecsSystem Spec
17 May 2011   #6

Windows 7 Pro
 
 

Oh, looks like I misunderstood. Sorry.
I'm using a laptop and in device manager, under network adapters, two things are listed
Intel(R) WiFi Link 5300 AGN
Realtek PCIe GBE Family Controller
I've tried to updating the drivers through the device manager, but says both are up to date.
My System SpecsSystem Spec
17 May 2011   #7

win7
 
 

Your card is capable of WPA/ WPA2 so that is not a problem. I would try resetting your 2740B to factory defaults and start set it up again. If some stting has become corrupted then this should clear it. I have used mainly Belkin routers and had problems of a similar nature in the past.
My System SpecsSystem Spec
18 May 2011   #8

Windows 7 Pro
 
 

I've updated the firmware on my modem/router and the problem seems to be fixed. I'm not sure what was wrong or why the update fixed it. MAC address filtering is also working now ans it wasn't before. Feels like something was wrong with the modem even though it is fairly new.

Thanks for the replies all the same
My System SpecsSystem Spec
Reply

 Wireless Encryption Problem




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:16 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33