Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: internet but no network connection


02 Jun 2011   #1

windows 7 home premium 32bit
 
 
internet but no network connection

New guy here, new to networking as well. ive always been a router/access point type guy. So lets get down to buisness! i have win 7 home premium. its a sony vaio VGN-NW2665f. Now here is my issue that im about sick of. the tab down at the bottoms that gives you your network list is working fine! i have my network listed, it says connected (says my network, connected and all the bars are green) yet up top it says NOT CONNECTED networks are available. (just for the record im on the laptop right now typing this so obviously im online) basically win 7 does not recognize my network. therefore it is defaulting to public, i dont even get the icon with the bench to change it from pubic to home (as ive seen on so many forums) happens with the ethernet as well. being win home prem there is no group policy editor. IPv4 says internet IPv6 says no network, so far i have:
disabled/enabled drivers
uninstall driver/reinstall drivers
Changed advanced sharing settings
already did the regedit diabled thing,\
made sure all services are on that windows says to make sure of
turned off firewalls.

i was able tonight to print wirelessly from my vaio to my printer but still its a public network, let me add i have an XP desktop hardwired, i can ping it from the vaio laptop, the desktop can see the vaio, the vaio CAN NOT see the desktop. i will worry about all that later i just want to figure out how to turn it from public to home, check the pics if you need more info hit me up! next stop is a computer shop nothing against them but... im a DIY guy




Attached Thumbnails
internet but no network connection-network-map1.png   internet but no network connection-network4.png  
Attached Images
  
My System SpecsSystem Spec
.

02 Jun 2011   #2

windows 7 home premium 32bit
 
 

let me add, i have two routers, i reset both to factory defaults, both bought with in the last year, a belkin basic N and a netgear N. ive tried setting up the network with both routers but same effects on both.
My System SpecsSystem Spec
02 Jun 2011   #3

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Is the vaio getting ip address via dhcp? If yes, try setting a static ip manually with the router ip as the dafault gateway and primary dns.
My System SpecsSystem Spec
.


02 Jun 2011   #4

windows 7 home premium 32bit
 
 

yes its set to auto, when you say use the router ip, do you mean on IPv4 or IPv6? also (still new to networking so sesame street style LOL) you mean the ip for the router correct?
being a netgear, 192.168.2.1

let me add, when "blanked out" my routers (reset them to factory condition) i went in and also deleted all wireless networks, when i connected it did not give the option home/work/public/domain tried it on my other router, same, went to my apartment wifi, still no option... i know vista does this and my friends 7 does as well.. bought this second hand off a friend so still figuring it out and working out bugs.. was on verge of setting laptop to fact default but he never made a restore disk.. bummer
My System SpecsSystem Spec
02 Jun 2011   #5

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Yes, the ip address of the router. Make sure the manually set ip for the vaio is in the router's valid address range, in this case if the router is 192.168.2.1, then the valid range would be 192.168.2.2- 192.168.2.254.
My System SpecsSystem Spec
02 Jun 2011   #6

windows 7 home premium 32bit
 
 

well that "worked" still same thing, what about IPv6, what you told me to do worked on IPv4
My System SpecsSystem Spec
02 Jun 2011   #7

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Nobody heres using ipv6 (protocol for the future), I'm only talking about ipv4. And what do you mean "worked", can you change the network type or still no joy?
My System SpecsSystem Spec
02 Jun 2011   #8

windows 7 home premium 32bit
 
 

this is what im getting.. by the way i want to thank you for taking time to help me..
My System SpecsSystem Spec
02 Jun 2011   #9

windows 7 home premium 32bit
 
 

sorry here is the pic i ment to send


Attached Thumbnails
internet but no network connection-network5.png  
Attached Images
 
My System SpecsSystem Spec
02 Jun 2011   #10

Windows 7 Professional x64 SP1 ; Windows Server 2012 R2 Standard
 
 

Could you attach your Ipconfig please

Network Posting Tips - Don't worry about the Batch script at the end

Also the attached File on this post will tell you how to change the network to Home

Josh


Attached Files
File Type: zip Change to Home Network.zip (524.2 KB, 87 views)
My System SpecsSystem Spec
Reply

 internet but no network connection




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:21 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33