Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Can't browse samba share by ip but can by hostname

01 Jul 2011   #1

win7 64bit
 
 
Can't browse samba share by ip but can by hostname

I have a 11.04 ubuntu samba share that is serving files to my network (though I don't really think this is relevant). I have 2 Windows 7 64bit machines (1 laptop/1desktop) that can access these files fine, however I have 1 Windows 7 32bit that is unable to access the files. (I even think it may have been able to before.)

When I browse the network and go to SERVER it says:

"Windows cannot access \\SERVER.... the network path was not found"

HOWEVER when I navigate to \\192.168.1.151\ with explorer it works fine.

What I have tried:
* I have removed all wireless networks and reauthenticated.
* I have set all network configs to the most open possible: network browsing: ON, sharing: ON, homegroup: Off and password authenticate.
* Disabled Norton Internet Security firewall (also on the other two computers)

Again this server is perfectly accessible from all other computers (even a third laptop come to think of it), so it must be something stupid with this one laptop. This problem is driving me up the wall. Anyone have any ideas of what I can try?

jack

My System SpecsSystem Spec
01 Jul 2011   #2

Windows 7 Ultimate x64 SP1
 
 

Is the new computer part of the same workgroup as the other Windows 7 computers?
My System SpecsSystem Spec
01 Jul 2011   #3

win7 64bit
 
 

Yes it is. Workgroup = "WORKGROUP", as specified on all other comptuers and the smb.config file for the samba server. (It's not really new, but it did have a fresh install a month ago with minimal use.)
My System SpecsSystem Spec
.


01 Jul 2011   #4

Windows 7 Ultimate x64 SP1
 
 

My System SpecsSystem Spec
01 Jul 2011   #5

win7 64bit
 
 

I tried that but we weren't really having the same problem (I didn't have 200 of the network adapter he was referring to, I still removed all the network adapters and restarted to reinstall. Unfortunately it didnt help. I also tried:

* disabled and reenabled network browsing for the 'home' and 'public' profiles
* this: PeteNetLive - KB0000439 - Error - While Attempting to Access a Windows Share
*enable NetBIOS always on in the TCPIP settings
*restart the winbind/smbd/nmbd services on the samba box
*disable the firewall again
*reboot the router
*Enabling the 'router' service
*Making sure the following services were enabled
COM+ Event System (for WZC issues)
Computer Browser
DHCP Client
DNS Client
Network Connections
Network Location Awareness
Remote Procedure Call (RPC)
Server
TCP/IP Netbios helper
Wireless Zero Configuration (XP wireless configurations)
WLAN AutoConfig (Vista wireless configurations)
Workstation

I'm afraid that this will require a clean install. I did have a problem mixing up the location on two computers and had problems removing the old settings before a restart, I wonder if I messed up the registry. Either this, or maybe its another case of impossible-to-diagnose-windows-problem (linux may be a real pain to setup, but there's always an error log to find out what's going on).
My System SpecsSystem Spec
02 Jul 2011   #6

Windows 7 Ultimate x64 SP1
 
 

Have you checked the logs? There are Windows logs you can review.
My System SpecsSystem Spec
02 Jul 2011   #7

win7 64bit
 
 

Yes I should rephrase that last sentence. There are error logs, but if you can even find out where to look the errors are cryptic 'eventids' where you have to go searching on websites to find out what the heck they mean.

I think I must have more problems with this thing. It doesn't show that i'm connected in the wireless icon in the corner even though it is, it wants to be the master browser, so maybe that's messing things up. I've spent time on this problem than I should have I'm just going to wipe it clean and start over. Thanks for your help though.
My System SpecsSystem Spec
Reply

 Can't browse samba share by ip but can by hostname





Thread Tools



Similar help and support threads for2: Can't browse samba share by ip but can by hostname
Thread Forum
Solved samba share is not accessible from Windows 7 client... Network & Sharing
Samba Share Networkmounting as X,Y,Z works, \\Share\mount not Network & Sharing
Solved Can't connect to Samba share from Win 7 ultimate 64-bit Network & Sharing
Samba network share issue with Windows 7 Network & Sharing
SAMBA share windows 7 and HP Unix Network & Sharing
Can't connect to samba share via name; ip works Network & Sharing
Can't connect to samba share Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:34 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33