Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DHCP - WIN7 64Bit - Not Working

13 Aug 2011   #1

Windows 7 Ultimate x64
DHCP - WIN7 64Bit - Not Working


I just installed a new version of windows 7 64bit Ultimate. I am currently having an issue with obtaining a IP address using DHCP. I can connect using a Fixed IP address. Windows defaults to 169.X.X.X address and subnet mask of

Any Ideas Of what could be the issue.

Machine has all latest patches and is fully registered licience


My System SpecsSystem Spec
13 Aug 2011   #2

Windows 10 Pro X64

Have you tried Control Panel, Windows Firewall, Troubleshooting my network while using DHCP?

Is DHCP Client started in Services?
My System SpecsSystem Spec
13 Aug 2011   #3

Windows 7 Ultimate x64

DHCP has started on startup as per normal. Tried also reinstalling windows again thinking that windows might of corrupted during installation still a NO GO.

Fixed Ip is working great but would like to work on DHCP.

MOBO i am using is a Gigabyte 990FXA-UD5
Processor - AMD Phenom II 1090T
My System SpecsSystem Spec

14 Aug 2011   #4

Windows 10 Pro X64

That board uses Realtek 8111E chip (10/100/1000 Mbit) chip for network (Gigabit). I don't see anywhere that should cause a DHCP problem.

I did find this: Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers. I know it's for Vista but Windows 7 and Vista are very much alike. Check the "Let me fix it myself" section and see if adding a new DWORD value of DhcpConnEnableBcastFlagToggle fixes this for you. If not you can always delete it again (or leave it).

Also check to see if there is a firmware update for your router.

Can you borrow another router to try?
My System SpecsSystem Spec
17 Aug 2011   #5

Windows 7 Ultimate x64

All good thanks for your help guys.

Worked it out. It was really strange. I use a seperate switch to connect to as I have multiple devices connected to the one lan port. This was the issue.

So what i done was connect straight directly to the wall socket that leads to the router then connected fine on DHCP.

I then disconnected it and reconnected it to my switchbox and worked fine ever since. Got no idea why it couldnt find a IP the first time looks like i just needed it to connect directly to the wall socket for the first time
My System SpecsSystem Spec
05 Nov 2011   #6

Windows 7 Home Premium x64 SP1


I've got sampe problem, I have changed NIC as well and it din't help. It works fine with static IP, I have decided to use static IP, cause there is no other choise.
My System SpecsSystem Spec

 DHCP - WIN7 64Bit - Not Working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
win7 64bit and xp mode lan not working
Hi, I'v read dozens of topics on this and tried so many times but with no success. I have win7 pro 64bit, I'v installed xmode and want to setup network between the two (I need to use an old adsl modem to connect win7 to internet): - I'v installed loopback on win7, set fixed IP to,...
Com Surrogate Stopped Working. Win7 Home Premium 64bit
Problem signature: Problem Event Name: APPCRASH Application Name: DllHost.exe Application Version: 6.1.7600.16385 Application Timestamp: 4a5bc6b7 Fault Module Name: RPCRT4.dll Fault Module Version: 6.1.7601.17514 Fault Module Timestamp: 4ce7ba59 Exception Code: c0020043 Exception Offset:...
General Discussion
MathType add-in not working for 64bit MS Office 2010 64bit
Hi, Just got into the flavour of windows 7 for a couple of days and I'm lovin' it. Now, I installed Microsoft Office 2010 Professional Plus 64 bit on my system. Then I tried to use the Mathtype plugin 6.6a, but I cannot make it to work. What I've done so far: 1. Installed MS Office 2010...
Microsoft Office
DHCP not working after Windows 7 Upgrade
Hi, I have a machine that used to run Windows Vista Home Premium, and it is connected to a LinkSys router using DHCP. It worked fine. Also, I have a Windows 7 Ultimate laptop that connects to the same router using DHCP, it works fine too. Today I upgraded the Vista machine to Windows 7. After...
Network & Sharing
dns & dhcp not working in windows
after i upgraded vista to windows 7, i now have a problem that my internet is not working,i can ping external ips but no address resolution and if i made the connection to auto ip ...doesn't that's dhcp & dns are not working.when i check in the services.msc the dhcp and dns services are...
Network & Sharing
Win7 Won't Take Assigned DHCP IP
On my router, I have DHCP assign IPs to the various computers/devices on my network. For example, a laptop is, and my server is I've tried assigning to my Win7 box, but it keeps coming back with I recently reinstalled Windows7 (for a...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:22.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App