Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with "WAN Miniport" drivers


13 Aug 2011   #1

Win7 Home Premium 64bit
 
 

After two days of trying everything to get an internet connection back, i have given up and signed up here to get some help. You see, I keep getting a internet connection box pop up when I try and connect to the net (like a dial up connection) but I'm on broadband.

And when I go into Device Manager, and look for my network drivers, all I have in there is a "WAN Miniport" with a excalmation mark next to it. How can I get around this problem? It's driving me nuts! I'm running Windows 7 32 bit BTW.

Many thanks in advance : )


My System SpecsSystem Spec
.

13 Aug 2011   #2

Windows 7 Ultimate SP1 32 bit/Windows 8.1 64bit
 
 

Quote   Quote: Originally Posted by ValiantSaint View Post
After two days of trying everything to get an internet connection back, i have given up and signed up here to get some help. You see, I keep getting a internet connection box pop up when I try and connect to the net (like a dial up connection) but I'm on broadband.

And when I go into Device Manager, and look for my network drivers, all I have in there is a "WAN Miniport" with a excalmation mark next to it. How can I get around this problem? It's driving me nuts! I'm running Windows 7 32 bit BTW.

Many thanks in advance : )
Welcome to the forum, I'm sure that one of the experts will be able to get you online soon but in the meantime have you been into Internet Options and clicked the box to Never Dial A Connection, it's in the page Connections. What happens when you click on the button on the same page for Setup ?

While you wait for one of the experts have you had a look in the Tutorial section of the site to see if there's anything in there that can help.

Good luck and hang in there as I'm sure you'll get all the help you need.
My System SpecsSystem Spec
13 Aug 2011   #3

Win7 Home Premium 64bit
 
 

I did try checking "Never dial a connection" It's odd how this box just started appearing. It happened to appear after a thunderstorm. You don't think that the storm might have fried the NIC? (Surge?)

Thanks ; )
My System SpecsSystem Spec
.


14 Aug 2011   #4

Win7 Home Premium 64bit
 
 

Here's a few screen grabs of the problems I'm getting when trying to get a working connection:

Problems with "WAN Miniport" drivers-networking-screen-grab.jpg

Problems with "WAN Miniport" drivers-dm-screen-grab.jpg

I am also getting a "Code 39" error in Device Manager when looking at the stats of the "Wan Miniport" which tells me that the driver is DOA. If I go onto the Lenovo website, and search for the drivers to reinstall, they don't exist! Please help : (


My System SpecsSystem Spec
14 Aug 2011   #5

Windows 7 Ultimate X64 SP1
 
 

What is the make and model of the Modem?

Also... I'm assuming from the screenshots that it is a Modem and not a router? WAN Miniport is Windows name for a "broadband modem" which actually, DOES need to dial.

Your ISP should have provided you with either connection software, or a user name and password, did they?
My System SpecsSystem Spec
Reply

 Problems with "WAN Miniport" drivers




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:45 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33