Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network adapter driver problem

25 Jul 2009   #1
Neverin

Windows 7
 
 
Network adapter driver problem

Hello,
Im Neverin
And I have a problem with my laptop because I cant find the proper driver
for my network adapter. Im using Windows 7 as OS.
I dont know where the problem is in the software or in the hardware, but Im pretty sure that the network adapter worked on my previous OS - XP - with no problem . So I think the problem is the driver I have to find.
I tried to find the proper driver, but I didnt succed.
So I need professional help - help from you.
If anyone can help, I would be pleased.
I know the name of the unknown device is Ethernal Controller, but Im not sure if the network adapter is attached to my mainboard ( Sorry, I dont know the expression ). Anyone can tell how I can see that ?
And BTW my mainboards name is ASUSTeK Computer Inc. A4GA .
I would be glad If anyone could help.

Greetings from Croatia


My System SpecsSystem Spec
.
25 Jul 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Neverin View Post
Hello,
Im Neverin
And I have a problem with my laptop because I cant find the proper driver
for my network adapter. Im using Windows 7 as OS.
I dont know where the problem is in the software or in the hardware, but Im pretty sure that the network adapter worked on my previous OS - XP - with no problem . So I think the problem is the driver I have to find.
I tried to find the proper driver, but I didnt succed.
So I need professional help - help from you.
If anyone can help, I would be pleased.
I know the name of the unknown device is Ethernal Controller, but Im not sure if the network adapter is attached to my mainboard ( Sorry, I dont know the expression ). Anyone can tell how I can see that ?
And BTW my mainboards name is ASUSTeK Computer Inc. A4GA .
I would be glad If anyone could help.

Greetings from Croatia
Hi neverin and welcome to sevenforums

You obviously need a driver and if you go here ASUSTeK Computer Inc.-Support- they will walk you thru to find the correct drivers for your model. If that doesn't work let us know and we will be happy to help

Ken
My System SpecsSystem Spec
26 Jul 2009   #3
Neverin

Windows 7
 
 

Im really stuck right know because ;
I dont know what I have to choose : motherboard or networking adapter.

I cant find my motherboard there because I do not know the name of it .
Im using PcWizard 2009 to see my motherboards name and type and that dooesnt match with the ASUS list.
Maybe I doing something wrong.
My System SpecsSystem Spec
.

26 Jul 2009   #4
icoola77

Windows 7 Home Basic 64bit
 
 

Quote   Quote: Originally Posted by Neverin View Post
Hello,
Im Neverin
And I have a problem with my laptop because I cant find the proper driver
for my network adapter. Im using Windows 7 as OS.
I dont know where the problem is in the software or in the hardware, but Im pretty sure that the network adapter worked on my previous OS - XP - with no problem . So I think the problem is the driver I have to find.
I tried to find the proper driver, but I didnt succed.
So I need professional help - help from you.
If anyone can help, I would be pleased.
I know the name of the unknown device is Ethernal Controller, but Im not sure if the network adapter is attached to my mainboard ( Sorry, I dont know the expression ). Anyone can tell how I can see that ?
And BTW my mainboards name is ASUSTeK Computer Inc. A4GA .
I would be glad If anyone could help.

Greetings from Croatia


Ok so what i could gather from your post is that you have an ASUS A4Ga Notebook, and in Windows 7 you do not have a driver for your ethernet (LAN) adapter.
This adaprer used to work in Xp, but doesn't in Win 7, and you think that the driver is the problem. You are correct.

First thing I did was go to this page
ASUSTeK Computer Inc.-Support-

and then choose the appropriate options

-asus-drivers-search.jpg

and then i got this

-asus-a4ga-notebook-drivers.jpg

i chose to view drivers for xp, since i wanted to find out which lan chipset is used with your adapter, and because you said the adapter worked in xp.

I then downloaded the xp driver, and unpacked it, and looked inside the unpacked driver package, especially in the WinXp driver folder to see whether i could find any info on the chipset.

This is what i found :

-sis-driver-xp-readme.jpg

So assuming that im on the right track so far, and the chipset in question is SiS900,
I searched the internet for SiS website, to see whether they have a newer driver that you would be able to download and install in Windows 7.

http://www.sis.com/download/

-sis-driver-download-xp.jpg

-sis-drivers-download-vista.jpg


But here is the problem, as you can see in the 2 screenshots above, when i choose to download a SiS network driver for xp, there is an option to download a driver for the SiS900 chipset, but when i choose Vista as an OS that i want to download drivers for (there are no Win 7 drivers, Vista is the latest OS they have drivers for), there is no option for that chipset, only for SiS163U WLAN and SiS190LAN and SiS191 Gigabit LAN.


Then i googled for "sis 900 windows 7"
and found this link

SiS 900-Based PCI Fast Ethernet Adapter

Pay attention to the second post and last post on that page, and hopefully that will solve your problem.


My System SpecsSystem Spec
27 Jul 2009   #5
Neverin

Windows 7
 
 

I have read your post !
I did something else, and it took some time to do it and it seems it is was the hard way .
I reinstalled XP on my laptop and I have installed all the drivers, and I found a program that updates my drives , but it also it backups them . I did that and installed 7 again.
It was a little tricky because at the first it wouldnt accept it ( dont know why ) and then i had to delete the driver and restart the computer. After restarting it installed the network adapter driver automatically .
I did that before you posted . But Im going to thank you and test your sollution in the future. Now Im too afraid to do something because I think I will mess something up . I was on that site called " Microsoft catalog update " and I saw that there where the right drivers to do it. I will use it for other things.
I see there is no proper sollution to install that driver on 7 .
Thank you for helping me! All of you!
My System SpecsSystem Spec
Reply

 Network adapter driver problem




Thread Tools




Similar help and support threads
Thread Forum
Problem with network adapter driver.
Hello everyone, okay? I'm new here on the forum, so I'll introduce you. I'm 14, I live in Belo Horizonte, play dota for some time, and also quite like computing the influence of my brother who is technical. Anyway, my problem is the following: I formatted the computer a client of mine...
Drivers
problem with driver adapter for wireless network connection
My internet was working fine and I was connected to wifi, then it suddenly stopped working. I did all the troubleshoots and it discovered that there is a problem with the wireless network connection adapter. It shows that my wireless network is there and is on but won't connect to the adapter. I...
Network & Sharing
Problem with the driver for the wireless network connection adapter
Hello everyone. As you can see today when I got on my laptop I wasn't able to connect to the Internet and after attempting to troubleshoot I got this error message along with one saying a network cable is not properly plugged in or is broken. We recently switched Internet service providers and the...
Network & Sharing
"Problem with the driver for the Wireless Network Connection adapter"
Hi all, so I have gotten the above message when trying to connect to my wireless, and it's saying I have limited access to the connection. I know it's not a router/modem issue as all other computers in the house are connecting without trouble. This all happened after I attempted to uninstall...
Network & Sharing
Driver Problem with Network Adapter every time computer boots up
I have a Netgear WNA1100 Wireless-N 150 USB Adapter that seems to be connected to my secured network with limited access, meaning the internet won't work whenever the computer is booted up. It mainly shows the clear bars and the gold star. Whenever I'd try using the Windows 7 Network...
Drivers
Network Adapter Driver "Encountered Problem"
I seem to be the only one with this problem, if there is another thread for this sorry couldn't find it but my problem occurred a few days ago i got my graphics card/ installed it/ found out my psu is weak for it/ un-installed it/ put my computer back together and my internet connection has a red...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App