Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 x64 Wifi driving me crazy!


07 Sep 2011   #1

Windows 7 professional x64
 
 
Win7 x64 Wifi driving me crazy!

Please ohh tech savvy saviour, help me out.

I have now spent what's close to half a year, with varying degrees of luck, trying to get my wifi working on my Windows 7 x64 computer.
This includes buying two new wireless adapters (which totals the amount to 3) and a week ago, a new motherboard to see if that could sort the problem out.
Im snapping here!

None of the 3 adapters have been working properly at any point before buying the new motherboard. After that, I actually got the latest addition to function for a couple of days now - that is until I updated to Service Pack 1. nothing works!!
I tried uninstalling the service pack again... which did the trick.

So I can't update my windows if I want a functional computer!?
Ive found numerous people (around these boards as well) having problems with x64 and wifi but no solutions...

My system:
AsRock Z68 Pro3 with an i5 2500k 3.3 Ghtz processor
8 gb of ram
Asus Pce-n10 wireless adapter
(before that I bought the Linksys Wmp600n adapter which I couldn't get working as well)

Ive tried all latest drivers from manufacturer, even tried latest drivers from chipset manufacturers.

Any ideas anyone?


My System SpecsSystem Spec
.

07 Sep 2011   #2

Win7 Ult. 32bit
 
 

What exactly are the symptoms?
My System SpecsSystem Spec
07 Sep 2011   #3
ski

windows 7
 
 

You do not need to install SP1 if you've been installing all of the Windows 7 updates on a regular basis.
My System SpecsSystem Spec
.


15 Jul 2012   #4

Windows 7 Ultimate x64
 
 

Hi I have a similar setup:

OS
Windows 7 professional x64
CPU
Intel i5 2500k
Motherboard
ASRock Z68 Pro3
Memory
8 Gb ram

I have bought 2 wifi cards with pretty bad connection. One doesn't connect at all and the other connects with a weak signal and drops the signal a lot. I'm not sure if it's the motherboard or the OS All my other laptops, phones, etc work well

Any help please?
My System SpecsSystem Spec
Reply

 Win7 x64 Wifi driving me crazy!




Thread Tools



Similar help and support threads for2: Win7 x64 Wifi driving me crazy!
Thread Forum
DRIVER_IRQL_NOT_LESS_OR_EQUAL driving me crazy BSOD Help and Support
Solved WMP 12 problem thats driving me crazy Music, Pictures & Video
BSoD driving me crazy-please help BSOD Help and Support
Permissions is driving me crazy! System Security
WMP driving me crazy! Media Center
Two issues driving me crazy in Win7. General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33