Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless connections drop after ~10 seconds on USB adapter

16 Sep 2011   #1

Windows 7 x64 Ultimate
 
 
Wireless connections drop after ~10 seconds on USB adapter

I recently moved into a house where I am renting a room, and unfortunately there is no wired ethernet connection available. Seeing as I brought my desktop with me, I purchased a TP-LINK USB wireless adapter so that I could use the internet on my desktop. Unfortunately, I have been unable to set it up despite working on it all day and I was really hoping I could get some help.

The first thing I did was plug it in to my desktop and install the driver that was included on a CD in the package. I was unable to get a connection to the internet, every time I tried to connect to a network the connection would fail and I would then not be able to see any network until I physically removed the adapter and plugged it back in (I have tried several USB ports all with the same results).

I then uninstalled the drivers and downloaded the latest ones from TP-LINK's website. This did not help, and the issue persisted. I figured Hamachi or Tunngle might have been causing problems so I uninstalled those. The included utility does not work with Windows 7 x64, which I am running.

At this point, I found a newegg comment (I'm not sure how to directly link it, reviewers name was Ardy and it was 4 eggs) that explained how to go into the device manager and change the "Receive Buffer" and the "Transmit Buffer" values from 256 to 512 and the "Scan Valid Interval" value from 60 to 30. This helped, I am now able to maintain a connection for about 5-10 seconds, just enough time to load a couple webpages before I have to reset the adapter.

I also tried to disable IPv6 (based on this thread), but that had no effect so I have re-enabled it. I have also tried re-installing the drivers many times.

I believe this may not be an issue with the adapter itself, I tried it on my netbook (Asus Eee PC 1005ha, Windows 7 x32) and it was plug and play, great connectivity and I used it for quite a while.

The next step would probably be to reformat, but I figured I would ask here to see if I can avoid doing that. Thanks a lot in advance, sorry I wrote so much!

EDIT: After updating my bios, the problem appears to have been solved. I feel like an idiot for not trying that earlier.

My System SpecsSystem Spec
.

Reply

 Wireless connections drop after ~10 seconds on USB adapter




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:46 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33