Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Marvell Yukon Gigabit Ethernet freezeing every 15 mins

13 Nov 2009   #11

7600.20510 x86

If the latest driver didn't solve it, I'd start looking elsewhere at what the problem could be.

It could be some program you have to start with Windows, possibly from the motherboard manufacturer. It could be other software making internet connections that is running and not working so well.

Check the event logs for anything suspicious or related. Alleviate those problems and this might go away with them.

My System SpecsSystem Spec
13 Nov 2009   #12


Ups. I forgot to mention. This happens without any third party involved. No other SW was installed beside Win7 and of course Wireshark to do some packet traces. BTW: based on this and other quirks our company shelved Win7 (as they did with Vista before). Even no testing are ongoing in the labs anymore. Oh well may be SP1 will be reconsidered. If not - may be Win8 or 9 or... (hope M$ is still around then).
My System SpecsSystem Spec
13 Nov 2009   #13

7600.20510 x86

Quote   Quote: Originally Posted by andygr View Post
BTW: based on this and other quirks our company shelved Win7 (as they did with Vista before).
That's unfortunate because Win 7 offers much more performance, quality and reliability right now (and even when beta!) than XP does with SP3.
My System SpecsSystem Spec

14 Nov 2009   #14


the strange thing is when i installed and tried to surf on windows xp mode on windows 7, it works pretty well. Even my internet connection is gone on windows 7, it works like charm on windows xp mode. i hope MS will solve this problem or I will be have to go back to xp or vista
My System SpecsSystem Spec
29 Dec 2010   #15

Windows 7 - 64

I had the same problem. The solution that appears to work:

Under "Device Manager / Network adapters / Marvell . . . / Advanced" tab:
Energy Star: Disabled
Wake From Shutdown: Off
Wake-Up Capabilities: None

Any combination of the three might be the culprit. The leading culprit would be Energy Star. I can see where the OS would turn off the port after inactivity but fail to turn it on when activity resumes. Either Microsoft or Marvell didn't implement the feature correctly.
My System SpecsSystem Spec

 Marvell Yukon Gigabit Ethernet freezeing every 15 mins

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Marvell Yukon 88E8059 - Can't register resources
Hey guys. I have a big problem with my LAN controller..for some reason the driver for it has randomly stopped working. I've tried to reinstall the setup from Marvell's website a number of times, rebooted etc but it just won't bring it back. It's an onboard Ethernet controller on an ASUS...
Network & Sharing
Marvell Yukon 88E8056 PCI-E Gigabit Ethernet - ONBOARD Asus P6X58D P
Hey guys! I'd like to thank you first for all the help with my other problems with this piece of crap computer. But now I want to solve, or at least find out why this problems occur. So I have a Asus P6X58D Premium motherboard which I guess has a "Marvell Yukon 88E8056 PCI-E Gigabit...
Hardware & Devices
Marvell Yukon Driver
Hi, Just wondering who else has a Marvell Yukon network controller and are you happy with the new driver changes? Thanks,
Windows 7 & Marvell Yukon 88E8001
I am having a strange problem with the onboard Marvell Yukon 88E8001 network adapter running on Windows 7 64bit. For some reason it has suddenly stopped being able to connect to the routers DCHP and obtain an IP address, nothing has changed and it was working fine previous. When I type...
Network & Sharing
Marvell Yukon 88E8056 PCI
Hi Folks, I have a eathernet card as in the title, and it refuses to function with Windows 7 or Ubuntu 10.10, However the thing logs on to the internet just fine with an older Ubuntu 9.0 that I ran from a disk, and of course, it ran fine with the previous XP. I got the newest driver and installed...
Hardware & Devices
Marvell Yukon Controller cant connect
Hi, I just loaded Windows 7 Build 7600 and cant connect to network or internet through my on-board Marvell Yukon gigabit controller. I've updated my drivers to the latest i can find (v. and still nothing. Occasionally it will show I'm connected, but when I launch IE it drops connection....
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:55.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App