Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: On board Realtek Lan Card stops working after driver update on Win7

26 Sep 2011   #1
lhan516

Windows 7 Ultimate x64
 
 
On board Realtek Lan Card stops working after driver update on Win7

Guys, help. I updated the drivers of my on board Realtek Lan Card via windows Update, but after that, it is not functional anymore. There were no lights when I plugged in the cable. Cable is working fine, when I test it on my laptop.

When i check on Device manager, it says, device is working properly. Network icon on the taskbar just shows lan connection with a red X. Have tried reformatting the pc and also used the latest driver from Realtek website.

I'm using Windows 7 Ultimate x64.

Please help thanks!


My System SpecsSystem Spec
.

26 Sep 2011   #2
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Welcome to Windows Seven Forums.

First, go into Device Manager and roll back your LAN adapter driver to its previous one.

On board Realtek Lan Card stops working after driver update on Win7-rollback.jpg

Second, go to Windows Update and choose "Check for updates, but let me choose whether to download and install them"

On board Realtek Lan Card stops working after driver update on Win7-updateset.jpg

Alternatively, you can always right-click any update you don't want and choose Hide.


My System SpecsSystem Spec
26 Sep 2011   #3
lhan516

Windows 7 Ultimate x64
 
 

thanks for the reply.

I can't remember if I've already done this... I have tried so many things already but I'll give it a go.

Is there a possibility that a hardware could be broken if you have installed the wrong drivers?
My System SpecsSystem Spec
.


26 Sep 2011   #4
IluvWin7

Windows 7 Ultimate 32bit
 
 

Quote   Quote: Originally Posted by lhan516 View Post
thanks for the reply.

I can't remember if I've already done this... I have tried so many things already but I'll give it a go.

Is there a possibility that a hardware could be broken if you have installed the wrong drivers?
No way the hardware breaks after installing drivers.
Try cleaning and look for any physical damages. I have faced similar issues but always my
light was glowing always..
time to get a new network card I suppose
My System SpecsSystem Spec
26 Sep 2011   #5
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

The hardware cannot physically "break" if you install new drivers, but functionality and performance can be affected.

For example, computer manufacturers tend to use OEM (Original Equipment Manufacturers) versions of hardware and hardware drivers. Because OEM equipment is tied to the computer it was installed in, it is cheaper and therefore more profitable for the manufacturer.

However, you may find that OEM drivers are configured differently to retail drivers for retail hardware and updating can cause the problems you are experiencing.

You may find you need to uninstall any updated drivers, and then uninstall the LAN adapter in Device Manager. Restart your computer so that Windows detects your LAN adapter. If it does then it should function correctly without any further action on your part.
My System SpecsSystem Spec
27 Sep 2011   #6
lhan516

Windows 7 Ultimate x64
 
 

Thanks for all the reply! It helped me isolate further.

I found the culprit. It seems that the problem is from Windows update. I have tried again reformatting the PC and when I'm finished, all the links are up and blinking again. It had used the default Windows driver (Realtek R8168D/8111D NDIS 6.2) seen in Device manager . But when I tried to do a Windows update it had replaced the driver to Realtek PCIe GBE Family Controller. And again no lights and no access to network.

Weird thing is that I have tried uninstalling the drivers and used the default Windows but it didn't work. Still seeing the red X in the network icon in my taskbar and it says no network access. I also tried system restore but still the problem is the same.

Maybe I will be reformatting again later and will not do a windows update. Hopefully, I can find what update is causing this problem.

Thanks again everyone.
My System SpecsSystem Spec
28 Sep 2011   #7
Kingscorner

windows 7 Ultimate 32bit
 
 

I had a similar problem with it showing no lan cable attached. I tried everything incuding a complete re-install of windows. The solution to my problem was so simple I am kicking myself.
Close down the computer and take out the power cable. Leave it for 10 minutes without power and press the on switch(still unplugged to the mains) This drains the power from the machine.
Now switch on the power and turn pc back on and it should all be fine ( unless you have deleted too much already)
Hope this works for you.
My System SpecsSystem Spec
28 Sep 2011   #8
Sardonicus

Windows 7 Home Premium 64 bit
 
 

You may fare better downloading the drivers and installing them manually.
Realtek
My System SpecsSystem Spec
28 Sep 2011   #9
Kingscorner

windows 7 Ultimate 32bit
 
 

I had already re-installed drivers (5 times) I literally tried every conceivable fault ( except this one) Then I found:
onboard lan(Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC)?? - Network-General-Discussions - General-Networking

It worked for me, and as I said, I am kicking myself now that I did not find this sooner
My System SpecsSystem Spec
Reply

 On board Realtek Lan Card stops working after driver update on Win7




Thread Tools





Similar help and support threads
Thread Forum
Gigabyte Realtek HD audio mic port stops working
When trying to use my Bose Soundtrue headphones with inline mic and a Y splitter for sound and mic it stops working in windows 7. I thought it just wasn't compatible somehow but I did a driver upgrade and then all of a sudden it works swimmingly for a while. Then it stops. Reboot doesn't fix it....
Sound & Audio
Sapphire HD 3850 AGP Card driver not working in Win7
Hi, I have a Sapphire Radeon HD3850 AGP card in my system but windows will not install the driver from the latest release of the ATI Catalyst driver install. Instead it defaults to the Standard VGA From what i have read on these forums i may need to change some information the CH87739.inf...
Graphic Cards
on board (realtek) sound disabled with creative card disabled
I have an creative x-fi installed which I have disabled. The on board realtek (mb is an asus ph67) shows audio input to speakers in control panel but no sound at jacks (front or rear). Does the presence of the Creative SC disable the onboard audio?
Sound & Audio
The Realtek Audio Driver stops working,want to record Music
Hi,I have Windows 7 Home Premium SP1 and there seems to be a problem with my computer's sound recording system.I want to record music off of the Internet,I have Replay Music,recently the program was working,now it decides to quit.I have the Replay Music software program set at Audio Driver,I tried...
Sound & Audio
graphics card not supported in win7 needs update driver
hi i m using windows 7 ultimate 32 bit . bt my display driver not suppoted the aero effects. it says "The current video card may support Aero with a driver that is compliant with the Windows Display Driver Model (WDDM). Contact the manufacturer of your computer or video card for a...
Graphic Cards
Win7 - Realtek Driver update
Hello, I am puzzled why Win7 is refusing to install a newer Realtek driver version for my net card. Using the device manager's driver update I currently have version 7.2.1127.2008 installed the new driver is: 7.009.1105.2009 (inf info) translates into 7.9.1105.2009 (me thinks) pointing...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:22.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App