Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Local connection cannot get a valid ip config

28 Sep 2011   #21
richie1913

windows7 ultimate 32 bit
 
 

Have also tried a different dongle,still the same.
When i was in ubuntu i could see the unidentified network next to my other local network but it would not let me delete it.
Its not to bad anyway,at least everything is kind of working,just one of them things.


My System SpecsSystem Spec
.
28 Sep 2011   #22
rraod

MS Windows 7 Ultimate 64-bit SP1
 
 

Sometimes when the network adaptor is not connected properly to a network, it can not assign itself the IP addresses dished out by the DHCP server in the router or wireless access point. So it assigns itself some random IP addresses like 169.254.149.243.

Make sure your network adapter is connected properly to the router. Check the IP configuration of network card and make sure automatically obtain IP address and DNS addresses are selected. Close the IP configuration dialog box, reboot the system and do an IPCONFIG/ALL at command prompt. If you get the proper IPs for your network card, default gateway and DNS server, it is OK and you will get connected to Local network and internet.
My System SpecsSystem Spec
29 Sep 2011   #23
richie1913

windows7 ultimate 32 bit
 
 

The only address my integrated network card gets is 0.0.0.0
As far as i can tell,i must have a ghost network somewhere because when under ubuntu i have my ehernet/local on 0.0.0.0 and also a unidentified network on 0.0.0.0,my knowledge of linux is extremely limited and dont know how to delete that network,it doesn't show up under windows but i have did route delete 0.0.0.0 under command prompt(ran as admin) and i get ok when i have pressed enter but it always comes back after restart and doesn't fix the problem before restart.
My System SpecsSystem Spec
.

29 Sep 2011   #24
aem

Windows 7 Ultimate 64Bit
 
 

It would be easily if you sign up to an ISP and have them provide you a modem. After that you just get a router and use that to create your wireless network. That way you can connect to it wirelessly in the case of laptops. If you have PC you can use network cable directly attaching it to the ports on your router.
My System SpecsSystem Spec
29 Sep 2011   #25
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition
 
 

Quote   Quote: Originally Posted by richie1913 View Post
I dont think use a router for anything or do I?
usb dongle for the internet
xbox360 or laptop connected via ethernet cable directly from each other.
I've read through this entire thread and I think I understand your issue... You are giving too much of the wrong info...

Are you trying to share your Internet connection via the desktop with both the xbox and the laptop? If so, thats the issue... you can only share with one other device using ICS (Internet Connection Sharing). You need a router to share with more than 1 network device... but what type of Internet conection do you have?

I didnt notice anyone directly asking you, where do you get your Internet from? (WHO DO YOU PAY BILL TO?) Broadband, Cellular, ???
Also, please describe in detail how everything is wired up... What (which PC) is your modem plugged into? Then this dongle you describe... can you tell us more about this? Is there a brand/model?
My System SpecsSystem Spec
29 Sep 2011   #26
richie1913

windows7 ultimate 32 bit
 
 

I will explain as easily as i can,i over complicate things when i write it down.

After having this problem for about 4 months I decided to do a fresh install,after i reinstalled windows 7 i didn't install anything else,no dongle software nor was the dongle plugged in.I then plugged one end of the ethernet cable into my ethernet port,the other end went into my daughters laptop,I never use the 360 at the same time because i only have one ethernet porT.

As soon as i plug the laptop in,all i get is unidentified network/public,this then comes up with a 169. address with the laptop plugged in,If I have nothing plugged into ethernet port then i get the 0.0.0.0.Looks like this on speccy when nothing is plugged in the ethernet port when i check the network

Broadcom NetXtreme 57xx Gigabit Controller
IP Address 0.0.0.0
Subnet mask 0.0.0.0
Gateway server 0.0.0.0

The dongle gets this address but was not installed until i had tested the network without it.

P Address 92.41.218.31
Subnet mask 255.255.255.255
Gateway server 0.0.0.0
Preferred DNS server 217.171.132.1
Alternate DNS server 217.171.135.1
DHCP Disabled
External IP Address 92.41.218.31
Adapter Type PPP
NetBIOS over TCP/IP Unknown
NETBIOS Node Type Hybrid node

To get everything talking and working all i have to do is assign the network card an address by editing the ipv4 settings from automatic to use another address.The dongle is on the 3 network used it for 2 years now and always shared its connection to allow xbox live or my daughters laptops to use it as well,only one at a time though,the dongle is usb hdspa model: zte mf 112
I dont use modems or routers,it is just a ethernet cable directly from computer to computer.
My System SpecsSystem Spec
29 Sep 2011   #27
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition
 
 

YES... TMI!! (too much information)

So let me ask... and please just answer these q's...

You can connect the xbox to Internet just not the laptop?

Is the laptop already on when you plug it in, or?


Earlier I asked what type of Internet connection you have and into what machine is the modem or broadband modem plugged into?

I really want to help you... but help me help you...

Some additional info that may prove useful... Using ICS (Internet Connection Sharing)

PS - the "dongle" as you keep referring to it, is actually a 3G cellular modem... so thats how you connect to the Internet! http://www.3gmodem.com.hk/ZTE/MF112.html Now after seeing the image I know why you keep also referring to it as "3" or "3 network"!
My System SpecsSystem Spec
29 Sep 2011   #28
richie1913

windows7 ultimate 32 bit
 
 

What-ever i plug into my local adapter i get unidentified network,xbox 360 or the laptop they are never connected at the same time.

The laptop i have tried both ways turned on and off.

This happens without the dongle installed or plugged in.As I have said I have used it like this for a while now with no problems,these problems started after i plugged my old laptop with xp into my ethernet port,something got changed for it to work,but nothing has worked ever since(new laptop windows 7) unless i assign a manual address.
My System SpecsSystem Spec
29 Sep 2011   #29
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition
 
 

You need to follow the instructions in the link above to setup ICS on the Win7 machine you are plugging the 3G cellular modem into. That is the machine that will share the Internet with EITHER the xbox or the laptop. Without the 3G plugged in you wont have Internet on any machine!

So currently neither one (other PC or xbox) gets an IP or a connection to Internet... right???

Many of us are trying to assist you... some have already given up... I wont! But... be nice! Part of the issue is that you dont call things by the proper name and that causes confusion... which is why I corrected you on the name (dongle vs 3G cellular modem).

One more question... have you recently switched the cable you were using to connect these devices together with?
My System SpecsSystem Spec
29 Sep 2011   #30
richie1913

windows7 ultimate 32 bit
 
 

ICS Is set up correctly.

If we forgot about the dongle for a minute,this is a fresh install no dongle nothing,just my desktop computer,when i plug another windows 7 laptop into my local adapter with a ethernet cable it comes up with unidentified network it never used to do that with anything,they wont talk to each other unless a assign a ip address.No dongle involved,no ICS going on,just a fresh install with windows firewall with a laptop connected directly into my ethernet port.

Does that make things easier to check?

Cable has been changed to check for faults
My System SpecsSystem Spec
Reply

 Local connection cannot get a valid ip config




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Local connection cannot get a valid ip config
Hi Everyone, Currently unable to connect to my broadband for the last 2 weeks i have googled options, upgraded my drivers checked ethernet cable all ok i have used the following programs to try and resolve this issue but out of luck. FSS Internet service Tool Minitoolbox by Farbar...
Network & Sharing
""Local Area Connection" Doesn't have a valid ip config
This is the error I got, and I couldn't connect to the internet. ""Local Area Connection" Doesn't have a valid ip config. It also stated that I had an unknown network, and I couldn't get an IP from the DHCP Server for some reason. I currently have it fixed, somehow. And would really appreciate...
Network & Sharing
"Local Area Connection" doesn't have a valid IP config
I got that message when I did the basic troubleshoot for my connection. The internet was working earlier this morning, and has been working for the past few months, but when I got back home today it just, seemingly randomly, stopped for no reason. Yes, I know there have been lots of people...
Network & Sharing
Local area connection doesn't have a valid ip config error craziness
Hello all and ahead of time thanks for your help. I've searched google for around 10 hours for solutions and have tried to apply them. Ok first off my network card does say it's working properly when i go to device manager. This just suddenly happened when i woke up one day after turning off my...
Network & Sharing
Local Area Connection doesn't have a valid IP config
Hello, There have been already few threads open for this topic not only on this forum but on different ones around the world, however the problem is still not solved, thus I decided to open a new topic and solve this problem once and for all. Here is the problem: I cannot connect to my wired...
Network & Sharing
Local area does not have valid IP config
Computer with new clean install of W7 Home. Yesterday it was connecting to router via LAN (not wireless). Went to sleep last night and had to do hard restart to get it up today. Since then, it is not finding the router via error msg above. I went into Dev. Mgr and told modified Nertwork Adapters to...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:04.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App