Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: STILL cannot see Win7 from XP and XP from Win7

13 Oct 2011   #31
maxseven

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)
 
 

I was playing with this just now, the FindMasterBrowser.vbs I use to ID which PC it is. Note it may not return the name of your workgroup properly (mine is HOME and I fiddled with ThePattern4 to get it to work) and I REM'ed-out the deletes for the NBTList and NetViewList.txt files.

I think all PCs can run Visual Basic scripts but maybe not.

I'll see what I can find re: the NetBIOS problem.




Attached Files
File Type: vbs FindMasterBrowser.vbs (2.5 KB, 6 views)
My System SpecsSystem Spec
.
13 Oct 2011   #32
maxseven

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)
 
 

Quote   Quote: Originally Posted by rdettwyler View Post


I still cannot start AFD for Winsock, even after the restore. I don't know about Master Browser but will look into it.
Did you confirm from my earlier post that you have NetBIOS enabled? Take a look at this page:

Enable NetBIOS over TCP/IP on Windows Vista

I think it's on by default but maybe not...
My System SpecsSystem Spec
13 Oct 2011   #33
rdettwyler

Windows 7 Professional 32-bit
 
 

It has been enabled on the network adapter. But the service will not start because the AFD dependency won't start and I haven't found a way to start it, as it is not an independent service.
My System SpecsSystem Spec
.

13 Oct 2011   #34
maxseven

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)
 
 

Have you tried the steps in this thread:

Ancillary Function Driver for winsock failed to start
My System SpecsSystem Spec
13 Oct 2011   #35
rdettwyler

Windows 7 Professional 32-bit
 
 

Event Viewer
The NetBT service failed to start due to the following error:
The system cannot find the file specified.

Well, that explains a lot, doesn't it?
My System SpecsSystem Spec
13 Oct 2011   #36
rdettwyler

Windows 7 Professional 32-bit
 
 

So I got copies of netbt.sys and netbios.sys, copied to \Windows\System32 and tried to register them with regsvr32. I get this error:

The module "netbios.sys" was loaded but the entry-point DllRegisterServer was not found. Make sure that "netbios.sys" is a valid ....
My System SpecsSystem Spec
13 Oct 2011   #37
aem

Windows 7 Ultimate 64Bit
 
 

The more things you tried to get it to work by changing settings the more it won't work. Do you have the W7 CD with you? what you can do is do a system repair and see how you do. The system R is at the second prompt after you running the Cd. No files or Software will be deleted so don't worry.

Try that.
My System SpecsSystem Spec
14 Oct 2011   #38
rdettwyler

Windows 7 Professional 32-bit
 
 

I used my Win7 disc and Repaired the OS. Now the NetBios Helper is running. However, I see only my own Win7 PC again. So, I built another Win7 Professional on an old Dell 400SC server that was running XP Pro. It installed perfectly. It required no additional drivers of any sort. I established my Home network and immediately saw all of the computers running on my network, wired and wireless, the storage attached to the router, and even the iMAC. BUT the original Win7, which was just repaired, showed only itself and now the newly built Win7 Pro. It seems to me that I need to do a new install of Win7 Pro on the problematic PC.

I will be installing Win7 Pro 32-bit on two HP Vostro PCs, which are running XP Pro 32-bit. I am hopeful that they, too, will require no additional drivers. I'll let you know.

Thanks all for your responses.
My System SpecsSystem Spec
14 Oct 2011   #39
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition
 
 

Quote   Quote: Originally Posted by rdettwyler View Post
I used my Win7 disc and Repaired the OS. Now the NetBios Helper is running. However, I see only my own Win7 PC again. So, I built another Win7 Professional on an old Dell 400SC server that was running XP Pro. It installed perfectly. It required no additional drivers of any sort. I established my Home network and immediately saw all of the computers running on my network, wired and wireless, the storage attached to the router, and even the iMAC. BUT the original Win7, which was just repaired, showed only itself and now the newly built Win7 Pro. It seems to me that I need to do a new install of Win7 Pro on the problematic PC.

I will be installing Win7 Pro 32-bit on two HP Vostro PCs, which are running XP Pro 32-bit. I am hopeful that they, too, will require no additional drivers. I'll let you know.

Thanks all for your responses.
Just curious... do you have a spare NIC you could try in that PC? Perhaps you have a bad NIC or bad cable?
My System SpecsSystem Spec
Reply

 STILL cannot see Win7 from XP and XP from Win7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
How to recover Win7 Pro upgrade from Win7 Home Premium post HDD crash
Greetings - This is my first time here and am very thankful for this great collection of forums and this community. I am trying to recover from a VAIO laptop HDD crash to Win7 Professional upgrade. I had finished working, shutdown Win7 Pro. cleanly. Drove home, attempted to launch Windows...
General Discussion
clone multiboot two disc win7 xp install to win7 ssd plus disk XPx64
I have a multiboot win7 /xpx64 TWO DISK system, showing win7 as the C; drive and XPx64 as D: when examining via My Computer. Cloned the C: drive (win7) using Samsung tool to same size Samsung evo SSD. When put in computer the dual boot option gone. The SSD clone of win7 runs ok, but with that in...
Installation & Setup
Dual-Boot Win7/Win7 restore points - Any special considerations?
I see Win7/XP dual-boot can have restore points issues so have to ask about best practices for Win7/Win7. Since my drive is partitioned for Win7/Win7/Data is it simply a matter of setting restore points On/Off/Off while in respective OS's?
Backup and Restore
Win7 Ultimate Update Failed to Win7 Sp1 Error Code 80073701
Hello I'm Having Problem Updating My Windows 7 Ultimate into Windows 7 Ultimate SP1 I Tried Using System Update Readiness Tool for Windows 7 (KB947821) But an Error Pops Up Please HELPP!!:cry:
Windows Updates & Activation
dual boot win7 & winxp separate drives OR upgrade to win7 professional
I've researched for awhile now & can't seem to find which is the best way to add winxp functionality to my laptop. I have office xp professional, painter7 & photopaint8 software that worked fine on winxp 32 bit thru sp3. New laptop is win7 home premium 64bit. Two 500gb hard drives. Which is...
Software
Reinstall Win7 32bit to Win7 64bit /backup disc content
Hey, I purchased the Win 7 Pro Upgrade 32bit via digitalriver, but I've been doing some reseach and probably should have selected the 64bit version. - Any ideas how I can get the 64bit version? - For those who ordered the 32bit back-up disc kit for the extra $15 and have received it,...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App