Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New Acer PC Internet/DNS Problems


18 Oct 2011   #1

Windows 7 Home Premium
 
 
New Acer PC Internet/DNS Problems

I have an Acer Aspire desktop running Windows 7 Home Premium. Right out of the box, brand new machine, I am having major problems with internet connectivity.

IE 9 is the default browser, nothing else is installed yet. A few times entering an IP address will work, in particular the address for Google. So far, the only regular URLs that have worked are google.com, yahoo.com and detnews.com -- other usual suspects, like slate.com, washingtonpost.com, bing.com, microsoft.com, apple.com, wsj.com do nothing -- IE just spins. Typically the browser will display at the bar at the top of the window the heading from the website, such as "Business News & Financial News - The Wall Street Journal - Wsj.com" but nothing on the page ever loads.

The ethernet cable running through a Westell 327W works fine with a laptop running Windows 7 starter and on a desktop running Vista.

I've tried the following with no success --

--Shutdown and restart the modem
--Various commands involving netsh, such as netsh int ip reset c:\netsh.log.txt, netsh winsock reset, others found by googling
--ipconfig /flushdns followed up by ipconfig /renew
--uninstalling and reinstalling the network connection
--turning off the firewall
--turning off antivirus
--using Google's DNS per this page:
Using Google Public DNS
FYI, when I follow the debug instructions on google's page, everything works as they say it should but still virtually nothing resolves.
-- adding and deleting the MAC address to the Network Address under the Advanced tab for the controller properties

For what it's worth, I can't access the internet through the online function of Help. I was able to successfully tracert 8.8.8.8 from the command prompt -- it was a bit slow, but it did go through in 14 hops. Also, Network and Sharing Center shows that there is a Internet connection.

Any advice? This is driving me crazy.


My System SpecsSystem Spec
.

18 Oct 2011   #2

Win7 H.Prem. 32bit+SP1
 
 

When I got my laptop, the first thing I did was to see what encryption it was able to use. Connected it by cable to my Netgear Router, set the SSID and password using WPA. Opened the connected devices and added the Laptop name to it. My router also has Access Control and was added to it. I then disconnected the cable, rebooted the Laptop, inserted the password, job done.
As you have already a setting in the wireless adapter, delete it the do the following.
-
Step 1. Close all applications that use the network — browsers, e-mail, chat, video, weather, and any other app that might be automatically updated in the background.
Step 2. Click Start, type device manager in the Search box, then press Enter.
Step 3. Browse to the list of devices and click to expand the Network adapters section.
Step 4. Right-click on the first adapter under Network adapters and click Uninstall. Windows will ask whether you want to remove the associated device drivers; say no, you want to keep the device driver. Repeat for all network adapters on your system under Network adapters.
Step 5. Close Device Manager.
Step 6. Reboot.
When you reboot, Windows will think it’s found a new networking hardware and will set up fresh connections. By the end of the reboot, your Network should be back and running in streamlined, trouble-free form.
My System SpecsSystem Spec
19 Oct 2011   #3

Windows 7 Home Premium
 
 

Thanks for the reply, but unfortunately uninstalling and reinstalling the adapter didn't work.

I've gone so far as a complete restore to factory defaults, and gone through the same stuff listed in my first post, no luck.

I've noticed that the factory loaded home page, Acer | MSN comes up partially -- basically text versions of some but not all of the links. To add to the weirdness, I viewed the source of the page, and it appears that the source matches the source that I viewed on another PC -- in other words, all of the HTML for the page seems to be transmitted, but not displayed in the browser. Thinking another browser might work, I installed Firefox, but the same things seems to be happening -- only a few websites work, entering IP Address works more often.

Any other input would be greatly appreciated.
My System SpecsSystem Spec
.


19 Oct 2011   #4

Windows 7 Home Premium
 
 

I hope it's not a violation of forum etiquette to post another reply to my own post, but in case anyone's following this, here's another weird wrinkle:

Plugged a Belkin wireless adapter into the USB port of the Acer desktop with little expectations of success. But lo and behold, I had a wireless connection to the home network, and was able to view msn.com and wsj.com which had timed out when connected via ethernet.

So, I unplugged the wireless adapter, plugged in the ethernet again, rebooted and now, via ethernet, was able to load msn.com and wsj.com -- but no other website would load.

Before that, I reset my Westell router to the factory presets and set it back up again. I've had the same results using the default DNS entry in the router and entering the DNS info from this link on seven forums.

DNS Addressing - How to Change in Windows 7

What can be going on? To sum up again, I've reset the PC to the factory presets (reloaded Windows 7 etc.) reset the modem, tried running with both modem firewall off and Win Defender off, tried variations on ipconfig and netsh, tried using various alternate DNSes, deleted and reloaded the network adapter, replaced the ethernet cable, tried different router ports. I can tracert fine with the command prompt. I can connect via a network adapter. I can resolve a very limited set of addresses when connected via ethernet cable including addresses which appeared when connected via wireless. I can view the HTML source of a non-loading page, and it appears to be the same as the source which shows up on a different PC.

Any help would be great, or maybe special charms to ward off the Halloween voodoo.
My System SpecsSystem Spec
21 Oct 2011   #5

Windows 7 Home Premium
 
 

For anyone who has come across this by Googling, the issue has turned out to be a bad MTU size.

This page has the instructions I used to drop the MTU and now it works.

Change your MTU under Vista or Windows 7 richard-slater.co.uk

Why this was a problem for a brand new machine, and why the auto tune feature of Win 7 that I read about didn't seem to work, I don't know. I'm using a major DSL provider and the modem they ship that's still in wide use on a major manufacturer PC, so I'm not sure why this came up in the first place.
My System SpecsSystem Spec
Reply

 New Acer PC Internet/DNS Problems




Thread Tools



Similar help and support threads for2: New Acer PC Internet/DNS Problems
Thread Forum
Problems moving HDD to SSD in an Acer Laptop General Discussion
Acer D257 netbook problems Hardware & Devices
Acer Aspire 9810 TV Tuner W7 Problems Hardware & Devices
Problems Loading 7 x32 on Acer Aspire L100 Drivers
Acer Problems Software
Acer Aspire 6935G Problems General Discussion
Acer Aspire 6290 Audio Problems Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33