Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: netbook network connection missing from device manager

30 Oct 2011   #1
Os Osment

Windows Home Premium 32bit
 
 
netbook network connection missing from device manager

Hi everyone

I have an emachines em350, I installed win7 as a clean install onto a new hard drive.

It's al sweet except the sound and network adapters have not installed. In fact it seems that win7 is declaring they never existed in the first place.

I have retrieved the latest drivers, win7 spits them out stating that the devices are not present. I have tried the older versions using compatibility mode. I have tried install legacy hardware. I have tried to flush them out through command prompt.

Nothing.

The sound 'card' (which I believe to be onboard) is seen by device manager, but refuses to have anything*to do with drivers.

The LAN I also believe is part of the motherboard, but it just won't show at all.

For the love of all that is holy, please help me out if you can or I fear this netbook will be going out the window at a rate of knots.

Thanking you in advance


My System SpecsSystem Spec
.

30 Oct 2011   #2
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi Os Osment Welcome to the forums did you get the drivers from here eMachines Support - Downloads & Support Documents - Netbook / Netbook / 350 you may have to use the originallly installed drivers in compatibility mode to get the netbook to recognise these drivers correctly
My System SpecsSystem Spec
01 Nov 2011   #3
Os Osment

Windows Home Premium 32bit
 
 

Hi
Thanks for the quick response!

I have tried to install the win7 drivers and the xp drivers in compatability mode... also tried command line flushes and various other vaguely esoteric techniques suggested by my friend google.

No avail.

Just to make sure I downloaded the xp drivers, set them up to run as admin in xp compatability but the drivers just dump when it states 'installer can't find Atheros AR81 Family ehternet controller on your system'.

Everything else (USB, card reader, monitor out, the chip itself) that is attached to the motherboard has accepted drivers and works fine, but along with the LAN and wireless the sound also gibbs out when trying to install saying there is no such device.

I tried adding devices through legacy, nothing worked.

sigh.
My System SpecsSystem Spec
.


04 Nov 2011   #4
Os Osment

Windows Home Premium 32bit
 
 

Ok, got the correct LAn (Atheros) to show in the device manager, but it won't load itself.

Can't check the bios to see if the LAn is enabled because it's the utterly useless InsydeH2O that is so restricted it is in fact pointless.

I presume it is enabled though as I reflashed using the latest update from emachines...

I am wondering if I am looking at the wrong part of the mothboard here, could it be an issue with the drivers elewhere?
My System SpecsSystem Spec
04 Nov 2011   #5
Os Osment

Windows Home Premium 32bit
 
 

Any help or suggestions would be gratefully recieved.
My System SpecsSystem Spec
04 Nov 2011   #6
Os Osment

Windows Home Premium 32bit
 
 

Back to square one. It was the wrong LAN.

Ah well.

Guess it's a door stop.
My System SpecsSystem Spec
05 Nov 2011   #7
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by Os Osment View Post
Back to square one. It was the wrong LAN.

Ah well.

Guess it's a door stop.
Only just found this thread again ,sorry try downloading the "Hardware vendor detection utility" from the top of the page I link too in the previous post , This will then tell you the correct lan driver to install
My System SpecsSystem Spec
01 Dec 2011   #8
Os Osment

Windows Home Premium 32bit
 
 

A final update, thankyou for those that tried to help. The hardware finder thingy couldn't work because it just didn't see that they existed (one of the first things I tried)

I turned off the automatic installing of (cached) drivers, then uninstalled the motherboard drivers.
then I manually installed the drivers from the emachines website and let Windows choose what ever was left without a driver.

Then I legacy installed the multiport communications port and com ports 3 and 4.

result! Internet, but still no sound.

i think win7 installed drivers that would allow the board to function... but not really the right ones!

thanks all
My System SpecsSystem Spec
01 Dec 2011   #9
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

hi Os Osment , retry downloading and installing the win7 drivers for the sound from the website link you may have to try 2-3 times to install them !!
My System SpecsSystem Spec
Reply

 netbook network connection missing from device manager




Thread Tools





Similar help and support threads
Thread Forum
network adapter missing on device manager
i have use windoqw 7 bout 3 month, and now my desktop got a problem..i cant see my network adapter on my devicxe manager,so now i cant access internet.i already install the right driver for my network adAPter,but still my window 7 say that i not install my network adapter driver when i go to...
Network & Sharing
Local Area Connection and Network Adapters in Device Manger is Missing
I need help. My local area connection is missing even the network adapters in the device manager.. While using our desktop, i noticed that the electricity flickered( once) then my internet connection disappeared.. so i had to go to network and sharing center and manage my connections. i disable...
Network & Sharing
Device Manager says coprocessor is missing...
In my device manager, it says that my coprocessor was never installed. I looked in the processor drop down tree, and it said that both processors were working. I don't know what to do... or if it's harmful...:(
Drivers
network adapter missing from device manager
my power flickered off and on really quick and when my pc came back up, the internet would not work. after investigating i found out that the network adapter is missing from the device manager. i have tried to re-download drivers for my network adapter/mobo and this has not solved my problem. i...
Network & Sharing
Missing network adapter, but device manager OK
Hi all. A very weird problem just happens to my desktop, I hope anyone could help me to avoid a complete reinstall. It was working fine, I didn't install or change nothing (mostly is used as MediaCenter). It was working perfectly without any change for months. Then I shutdown one day as always,...
Network & Sharing
HP Pavilion dv3 - LAN device missing from device manager
This problem started between noon and 3:00 PM on Friday 2/18. My Realtek PCIe GBE Family Controller device, which allows me to connect to the Internet via Ethernet cable, stopped appearing in the Device Manager window. Furthermore, the only place where my computer can find the device is in...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App