Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: no ethernet controller, no internet connection

10 Sep 2010   #51


hi, sorry for waiting, i couldnt get that computer till now xD

motherboard is P35-DS3L, LAN is enabled in bios and i have active connection plugged in.

tomorrow i will reinstall windows again and now i'll try to do what you said once again (turn off, part ram and battery, wait 20 minutes)

and btw where is that "Allow the computer to turn off this device to save power" ?

edit1: after 1 hour or more i returned battery and ram, nothing changed, then i uninstalled ethernet, restarted computer, it fount ethernet (as it was before) but could not install driver...

edit2: i reinstalled windows 7, everything same, i see ethernet controller in device manager, i installed the right driver from site
Win7 32/64 Auto Installation Program (SID:1354639).
and it said it was installed successful, but it didnt, in device manager is stil not installed (?)

edit3: i bought lan pcie card, so the problem is "fixed"

My System SpecsSystem Spec
19 Mar 2011   #52
hanggar 97

windos 7 ultimate

Dear Wasteful
I have the exact same problem as you mention above
I've googling around and try all any tips that lead me
and I have decided that all is the same (maybe they were just a copy-paste blogger)
reformat OS, upgrade BIOS, plug the power, system check, off the RAM, battery I've even tearing apart all my hardware from the casing and still cannot solve the problem.

finally I think about to buy LAN PCIE Card as well. I believe the onboard automatically turn off as I plug the card? (CMIIW)
Could you share what LAN card you have bought? many thanks
My System SpecsSystem Spec
21 Mar 2011   #53

Windows 7 Professional 32 bit
same problem

I had the exact same thing happen to my D620. I turned it on one day it was lagging like hell so I did a hard reboot. When I turned it back on, everything was fine, but the ethernet port just disappeared from the whole computer. I've tried all sorts of things with drivers and the device manager, but the port has never been recognized since that incident. Just like hanggar and a bunch of other people on here. Done all sorts of bizarre fixes recommended by google. Meddled with BIOS, pulled the ram, I killed the power. The only thing I don't really want to do is reformat the whole computer, especially since nothing tells me that's going to solve the problem. No idea what to do for it. I'd love to see a thread for a proper solution to this issue since clearly we're not alone.
My System SpecsSystem Spec

01 Apr 2011   #54

Windows 7 Pro

So i fixed this issue on my system... by rolling back a windows update that updated the driver for my PCI upstream switch port under system devices.. just searched trhough all my devices in device manager and found the ones that were dated the time i did the update and rolled them back and this was the one that fixed it
My System SpecsSystem Spec
30 Sep 2011   #55

windows 7 ultimate 32 bit

sir i have tried all these option to start my ethernet cable but still when i install the realtek ethernet controller to my pc it is showing that "deep sleep mode is........"
the recent thing is i have got a new modem from the intrnet connection provider after that i cant use ethernet .... is it the modem is fail or anything else coz the ethrnet light is still blinking in modem when i connect it to computer....
what shoud i do....
My System SpecsSystem Spec

 no ethernet controller, no internet connection

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Unable to connect with my internet connection through Wifi or Ethernet
Hi folks, the machine is Samsung NP300e5a, installed with windows7 64bit. Unable to connect with my internet connection by any means, wifi or ethernet. One of the senior member of this forum sent me a link of drivers. I uploaded all the drivers again and again. The laptop has no error message in...
Network & Sharing
No Internet Connection/Ethernet Port Lights are not working
Hello, My gaming tower is showing no network connection and I cannot connect to the internet at all. I have tested my ethernet wires and internet connection on my laptop, they are working fine. My lights in my ethernet plugin are not coming on at all on the towerr. I read that by using the CMD...
Network & Sharing
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
Unidentified Network, No Internet Access on Ethernet Connection
I just returned home from college, and am unable to connect my computer (Windows 7 Home Premium 64-bit, custom build) to the home network via ethernet. My computer attempts to identify the network for a while, then gives me the yellow error triangle that usually indicates the modem (Toshiba...
Network & Sharing
Bridge internet connection over ethernet from wifi
My desktop is connected to a wifi network and I need to bridge to another via ethernet. I have started by selecting each network and I bridge the 2 connections, creating a bridge, but the other computer still doesn't have internet connection. Is this possible (I would think so) and if so, what...
Network & Sharing
unable to connect to internet or find connection, ethernet, please help!
i installed windows 7 beta version 7057 today with 7048 which i had before and 7057 i am having a problem connecting to the internet (or finding a connection at all) the desktop computer is dual booted with xp, and is hooked up via ethernet to my router if i boot into xp, internet works...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:14.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App