Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Internet lag - yes I searched forums first

28 Nov 2011   #1
Belgian Blue

Windows 7 Home Premium 32bit
 
 
Windows 7 Internet lag - yes I searched forums first

When I searched for this exact problem, I found a lot of threads, but none which could explain the problem (and I found very few people on those threads were helped with the answers there either, most answers blaming it on external things). I'm convinced the problem is with Windows 7, since the router/modem and all peripherals are the exact same for this computer as my old computer. The whole computer is much improved over the old one. I first noticed the problem after my old motrherboard gave up, and I was given a laptop to use while they put together my new system. The laptop ran windows 7 and the internet lagged. At that point I didn't think much of it, while more modern than my comp, it was still a dated laptop and I figured that was the problem. But the problem persisted with my new computer. The only difference so far being that I'm running windows 7 over windows Vista.

Its the only computer in the house as well.

The problem is visible in online games and communication programs like MSN live, where a lag will suddenly occur, sometimes lasting well over half a minute. Its quite disturbing that my old computer could handle these simple tasks so well, and this greatly superior system can't, solely because its running windows 7.

I hope someone can think of what exactly in the software is causing this and there is an easy solution (something i can turn off).

Any help much appreciated ...


My System SpecsSystem Spec
.

28 Nov 2011   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Belgian Blue View Post
When I searched for this exact problem, I found a lot of threads, but none which could explain the problem (and I found very few people on those threads were helped with the answers there either, most answers blaming it on external things). I'm convinced the problem is with Windows 7, since the router/modem and all peripherals are the exact same for this computer as my old computer. The whole computer is much improved over the old one. I first noticed the problem after my old motrherboard gave up, and I was given a laptop to use while they put together my new system. The laptop ran windows 7 and the internet lagged. At that point I didn't think much of it, while more modern than my comp, it was still a dated laptop and I figured that was the problem. But the problem persisted with my new computer. The only difference so far being that I'm running windows 7 over windows Vista.

Its the only computer in the house as well.

The problem is visible in online games and communication programs like MSN live, where a lag will suddenly occur, sometimes lasting well over half a minute. Its quite disturbing that my old computer could handle these simple tasks so well, and this greatly superior system can't, solely because its running windows 7.

I hope someone can think of what exactly in the software is causing this and there is an easy solution (something i can turn off).

Any help much appreciated ...
A couple of things come to mind

1-Drivers. Run this latency checker to see if a corrupt (or conflicted) driver is at fault


DPC Latency Checker


2- Homegroup

Homegroup uses IPv6 which some legacy hardware has a problem with. If you are running homegroup, you are using IPv6. To check to see if this is the problem you can create a new network connection using Workgroup (which uses IPv4). If it cures the problem you can disable IPv6 and delete homegroup.
My System SpecsSystem Spec
28 Nov 2011   #3
MrGenius

Windows 7 Professional 64bit
 
 

First things first - what are the complete specs on your new computer? Also, what kind of network connection are you using? Get that for us and post a snapshot of your speedtest.net results, and we'll go from there.
My System SpecsSystem Spec
.


28 Nov 2011   #4
M1GU31

Windows 10 64bit
 
 

make sure your video drivers are installed is it intel graphics,nvdia or ati graphics . is it onboard graphics or a video card also is it a laptop or desktop? Also have you installed the propper drivers for network card?
My System SpecsSystem Spec
Reply

 Windows 7 Internet lag - yes I searched forums first




Thread Tools





Similar help and support threads
Thread Forum
High CPU when I do anything, searched for months with no solution.
I have no idea why its happening or how to fix the problem I am having. My computer majority of the time sits at or very close to 100% CPU usage to the point of not being able to do anything. I have had this problem for months but lately it has gotten worse. It will run low CPU until I do...
Performance & Maintenance
avoid a folder from being searched
i want to avoid the contents of a folder named 'locker' to be shown in search results..!! how can i do that??
General Discussion
Searched folder ../ up one directory?
So the "Up One Level" button has been gone for quite some time now, replaced by the "Smart Address Bar" we have all gotten use to it more or less (or the keyboard junkies just resorted to the 'Up One Level" shortcut; +) and conceded to some of it's advantages. But where this system fails...
General Discussion
The internet and Seven Forums are wonderful things!
You know, I think I (we) get jaded sometimes. We have access to all kinds of information, and can see things all over the world. It's become blasť. But I, a guy sitting at his PC in Calfornia, just helped a guy in Aruba fix a PC problem, and made him very happy. How great is that to be afforded...
Chillout Room
Windows 7 won't install, Searched and searched for help
I am trying to install Windows 7 on my Vista Ultimate PC. I have installed these OS thousands of times and never had problems. I have also installed 7 on one of my gaming PC's. When I try to install it on my other computer the install process go's normal, it reboots the first time however...
Installation & Setup
Windows wont detect mic, searched everywhere
Just installed windows 7 x64 and it wont even detect my mic. Show disabled devices is checked, searched all over the web. It's a creative Fatality mic and I don't think it has any drivers. PLEASE HELP
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:06.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App