Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Access is denied" - "Unable to display current owner"

05 Dec 2011   #1
Dingeling

Windows 7
 
 
"Access is denied" - "Unable to display current owner"

Hi,

I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder.

When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied".

The same happens when logged in with the system administrator account.

When I right-click the folder and choose Properties > Security, the Current owner field shows "Unable to display current owner." And it won't allow either of the listed administrator accounts to take ownership.

When I choose Properties > Security > Advanced > Owner, the Current owner field also shows "Unable to display current owner." And it won't allow me to Edit it either.

I've tried opening the Command Prompt as the administrator, and deleting the folder, but it won't allow me to do that either.

Any ideas on how to forcefully take ownership and/or delete this folder?


My System SpecsSystem Spec
.
06 Dec 2011   #2
Sub Styler

Windows 7 Ultimate x64
 
 

Check in the file security tab that there isn't a deny entry for the user group "everybody"
My System SpecsSystem Spec
06 Dec 2011   #3
Dingeling

Windows 7
 
 

Thanks for your reply Sub Styler.

The problem has actually already resolved itself, because after rebooting my system the iPod folder had simply disappeared.

I was able to recreate the problem though:
When I unistall iTunes the iPod folder remains, and is unaccessible. If I then try to reinstall iTunes without first rebooting my system the installation fails, because it can't overwrite the iPod folder. But if after uninstalling iTunes I do first reboot, then the iPod folder disappears and the new install works fine.

Apparently there must be an issue with refreshing the system's File Allocation Table (FAT) or something, which makes it think the folder is still there, when it has actually been deleted. Loggin out and back in doesn't help. Only after a complete reboot does the FAT (or registry or whatever) get refreshed.
My System SpecsSystem Spec
.

Reply

 "Access is denied" - "Unable to display current owner"




Thread Tools




Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
Error assigning ownership "Unable to set new owner on.. Access denied"
Error assigning ownership "Unable to set new owner on.. Access denied" Hi, I've a question about assigning ownership. I'm logged in as user "Steph". As Steph, I made a new folder "Documents_Steph". Because she made the folder, she's owner of this folder. Then I tried as Steph to...
General Discussion
Win 7 - Bootmgr has 2 "current" OS in "display order"...how to fix??
:cry: Here is a copy of bcdedit /enum As you can see {bootmgr) has (2) "current" files in "display order" How can I delete (1) so no "dual" option shows on boot. Selecting either during boot loads fine. THX ========================================================================= ...
General Discussion
!!UAC!! "File Access Denied" Even with admin, as owner, and permission
First off, I wasn't sure where the best place to post this would be, since UAC is supposed to be a security feature of windows 7 I figured the security section would be best. My apologies if I posted this in the wrong section. OK to the problem... Trying to simply copy/paste a game dll file...
System Security
Error assigning ownership "Unable to set new owner on.. Access denied"
Hi, I've a question about assigning ownership. I'm logged in as user "Steph". As Steph, I made a new folder "Documents_Steph". Because she made the folder, she's owner of this folder. Then I tried as Steph to assign ownership to a different user "User01". But then I got the message...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App