Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Internet Access on wireless network


14 Dec 2011   #1

Windows 7 Home Basic x32
 
 
No Internet Access on wireless network

I'm usin HP 630 laptop with Win 7 Home Basic OS, and I have trouble connecting to a wireless network, in fact I can connect to a network but I dont have internet access, I'm using TP-LINK (TD-W8901GB (Annex B)) router.
Does anyone know how to fix this?


My System SpecsSystem Spec
.

14 Dec 2011   #2
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Hi Max123,

You may refresh your wireless profiles stored by deleting all of them, then try again to reconnect to your own SSID make sure to type in the correct network encryption.
An option is to manually add SSID:
How to Connect to Hidden Wireless Networks | 7 Tutorials

Test your connection after. If that didn't help at all please provide an ipconfig /all output.
Click on the Start Menu search box area type cmd, right click on cmd see at the top, and click on Run as Administrator. From the command prompt (black screen), Copy and Paste these ipconfig /all >c:\ipconfig.txt . Please attach the .txt file to be found in your Local Disk 'C' on your next post.
My System SpecsSystem Spec
15 Dec 2011   #3

Windows 7 Home Basic x32
 
 

That didnt worked for me.
Here you go a txt file you wanted, its in attachments!
Thanks for helping.


Attached Files
File Type: txt ipconfig.txt (6.3 KB, 796 views)
My System SpecsSystem Spec
.


15 Dec 2011   #4
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Is your wired connection working?

Is is possible to get another ipconfig /all output from a working computer for comparison?
My System SpecsSystem Spec
16 Dec 2011   #5

Windows 7 Home Basic x32
 
 

Yes, my boardband connection is working on a PC, and laptop, but I cant make wireless internet access on my laptop...
I will send you now ipconfig from my PC, im using win XP OS on it... I hope it will help!
Thanks again.


Attached Files
File Type: txt ipconfigPC.txt (1.4 KB, 197 views)
My System SpecsSystem Spec
16 Dec 2011   #6

Windows 7 Home Premium 32 bit
 
 

@Max123, please go through the modem manual on setting up the wireless network.

In the LAN IP Setup page you should be able to check a settiing "use Router as DHCP Server" That should assign an IP address to your laptop to connect to the internet.
My System SpecsSystem Spec
16 Dec 2011   #7
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Just to verify, this output is from the problematic computer, however you are not able to wireless connect.
Quote:
Description . . . . . . . . . . . : Atheros AR9285 802.11b/g/n WiFi Adapter
Physical Address. . . . . . . . . : 74-DE-2B-06-61-9D
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 10.101.155.203(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.224.0
Lease Obtained. . . . . . . . . . : Thursday, December 15, 2011 6:08:15 PM
Lease Expires . . . . . . . . . . : Thursday, December 22, 2011 6:08:15 PM
Default Gateway . . . . . . . . . : 10.101.128.1
DHCP Server . . . . . . . . . . . : 10.120.1.166
DNS Servers . . . . . . . . . . . : 10.120.1.6
10.120.1.7
NetBIOS over Tcpip. . . . . . . . : Enabled
This output from a working computer has a totally different subnet from the non-working computer. Where did you connect this to? From the same Router or Modem?
Quote:
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VIA Compatable Fast Ethernet Adapter
Physical Address. . . . . . . . . : 00-13-8F-59-55-8A
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
My System SpecsSystem Spec
21 Dec 2011   #8

Windows 7 Home Basic x32
 
 

Yes... I connected my laptop, and PC to same modem/router... Is that sirious problem? How to solve that?
My System SpecsSystem Spec
21 Dec 2011   #9
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

The 192.168.X.X is a Private IP and should be correct, however it is showing that it's assigned a Fixed IP. The output from the problematic computer has DHCP enabled.

I wonder if you're connected to a different Wi-Fi connection (perhaps from your neighbor) and not from your own SSID? Do you have another WAP (Wireless Access Point) in your home?

Can you try changing the Wireless setting to a Static IP on the problematic computer?
Please follow this guide on how to do this, make sure to choose the Wireless setting and not the LAN.
Assign the following Addresses manually. If 192.168.1.5 is being used, change it to the next one which is a 6, 7 or 8.

IP Address. . . . . . . . . . . . : 192.168.1.5
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1

Please give us an update.
My System SpecsSystem Spec
21 Dec 2011   #10

Windows 7 Enterprise x64 SP1 Version 6.1 Build 7601
 
 

Hi,
10 easy steps to solve your problem:

1. Restart router and wait cca. 5 mins while router boot's up again
2. delete network profile on your comp
3. uninstall wireless adapter driver
4. reinsert wireless adapter (using wireless button or USB key)
5. install original driver for your wireless adapter
6 reboot your computer
7. in network and sharing center>manage adapter settings right click on your adapter icon and apply setting from 2xg's post or use these settings:
*********************************
IP Address. . . . . . . 192.168.1.200
Subnet Mask . . . . . 255.255.255.0
Default Gateway . . .192.168.1.1
DNS Servers:
Primary: 4.2.2.2
Secondary: 192.168.1.1
*********************************
8. shut down your protection components (AV,Firewall...)
5. manualy create network profile in network and sharing center>setup new conneciton or network>manualy connect to wireless network.
9. connect
10. turn back on your protections components (AV,Firewall...)

now should work just fine

if you're still having problems after all then:
1. shut down your protection components (AV,Firewall...)
2. troubleshoot network using network troubleshooter
3. turn back on your protections components (AV,Firewall...)

cheers!
codekiddy
My System SpecsSystem Spec
Reply

 No Internet Access on wireless network




Thread Tools



Similar help and support threads for2: No Internet Access on wireless network
Thread Forum
Suddenly Wireless Network says No Internet Access Network & Sharing
Wireless Network Connected but No Internet Access Network & Sharing
Connected to Wireless Network, But No Internet Access Network & Sharing
No internet access on wireless network Network & Sharing
No Internet Access on wireless network (TP Link) Network & Sharing
Wireless Network "No Internet Access" problem Network & Sharing
Connected to wireless network but cant access internet Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33