Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help! windows7 not recognizing LAN Adapter/controller


26 Dec 2011   #1

Windows 7 Pro x64
 
 
Help! windows7 not recognizing LAN Adapter/controller

Hey all,
I've been running windows 7 pro 64 bit for just under a year now. Couple days ago the computer was on just sitting idle while i was around the house, then i noticed this message pop-up the windows firewall was not active and if i wanted to activate it, ever since then i have not been able to get the computer to recognize any sort of internet connection. Im on a wired connection to a wireless router (D-Link Xtreme-N Dual Band Gigbit), all other computers connected to the router work fine.

there is a red cross in the little network icon in the taskbar.

If I click that icon, it says “No connections available”

If I click troubleshoot, it says “Problems found - There might be a problem with the driver for the local area connection adapter”

If I look in the device manager, there IS an entry for “Network Adapters”, in fact there are two:
1) Realtek PCIe GBE family controller (which i recognize as the one from my motherboard Asus P7P55D-E Pro
2) WAN Miniport (PPPOE) [i have no idea where this comes from, but it has a yellow exclamation sign above it]

I have uninstalled 1) from the device manager and let windows re-install it on reboot, i tried installing drivers from the CD the mobo came with, i tried going on another computer and getting updated drivers from the Realtek website, none of them worked.

if i try to uninstall the WAN miniport it does not disappear??

If I look in BIOS the contorller is there and ON.

Reboot, swapping ethernet cables, restarting router, scanning for viruses/malware with MSE, Webroot Complete, Malwarebytes finds nothing.
If I rollback to an earlier restore point, it doesn’t help.

The only thing i can remember that happened before the loss of connection was an update to TuneUp Utilities 2012 and Webroot Secure Anywhere 2012, both of which i've since uninstalled to see if it was one of those, but still nothing. Also completely disabling Windows Firewall doesn't help either.

Searching around the net has yeilded little help, I'm so frustrated, any help would be appreciated. Is the miniport the problem?

My System SpecsSystem Spec
.

27 Dec 2011   #2
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Welcome to Seven Forums,

Have you also tried a different patch network cable? or move it to a different LAN Port of your router?

If you have a separate Modem, have you tried plugging it straight to the Modem bypassing the router?

If that didn't help at all please provide an ipconfig /all output while your computer is connected to the router.
Click on the Start Menu search box area type cmd, right click on cmd see at the top, and click on Run as Administrator. From the command prompt (black screen), Copy and Paste these ipconfig /all >c:\ipconfig.txt . Please attach the .txt file to be found in your Local Disk 'C' on your next post.
My System SpecsSystem Spec
Reply

 Help! windows7 not recognizing LAN Adapter/controller




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33