Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unstable internet connection when changing from cable to wireless

20 Jan 2012   #1
Rigel

Windows 7 Home Premium x64
 
 
Unstable internet connection when changing from cable to wireless

Hi

I have this problem with my laptop. If i am using a cable to connect to the internet and then unplug it and switch to wireless connection, the internet connection gets unstable. The thing is it says it is connected to the right wireless connection AND it claims to have internet connection. - And i do - for a few minutes.. If i deactivate/activate the wireless internet i am able to surf around for a few minutes again, but then it does the same thing again - shows up as having internet connection but im unable to connect to it..

Strangest thing is that i am sometimes able to connect to the internet ONLY if another computer is using the wireless internet too.. It still shows up as recieving a nice signal with internet access even though i cant connect to the internet..

The same problem also occurs sometimes when im switching from one wireless connection (at home etc) to another (work etc)..

I've had this problem for a few months now.. Comming to think of it i might have had this problem ever since i got my laptop.. Rebooting my computer fixes it every time, but it's not a permanent solution.. Im running original Windows 7 Home Premium x64 which came with the laptop.. Also im not using static ip or anything like that - switching to static ip doesn't do the trick.. Running ipconfig /all command from cmd also shows me as connected to the right router.. The problem occurs every time i switch between cable and wireless and not only at my home or work but also at friends..
I'm not sure if i need to leave any more details, if i've left anything out just let me know.. Hope you guys can help me out, thanks in advance


Edit:
Also im sorry if this is a thread comming up here a lot.. I've been searching for a solution to this problem for a long time, but i don't really know what to search for or how to narrow it down, so i decided to try my luck out here


My System SpecsSystem Spec
.

20 Jan 2012   #2
Qdos

 

It's almost certainly the settings on your WiFi adapter, unless you are in a really congested WiFi zone or your WiFi signal is very weak.

Step one; Open Control Panel, then Device Manager, look for Network Adapters, expand the list to show your ethernet and WiFi adapters. Right click on the WiFi adapter. Choose properties, and look under in particular the Advanced and the Power Management tabs. Turn off "allow this device to be turned off when not in use" under Power Management. In the advanced tab I cannot predict what your options will be as it's adapter specific - and in 90% of cases these adapters are set at failsafe values instead of optimal values.

Step two; Google the optimised settings for your adapter, or refer to the user documentation, and change anything which is handicapping it.

If problems aren't solved at this stage look in your Router or Access Point's settings. Try different channels. See whether the router (and adapter) are set to B,G,N protocols and adjust as necessary.

Should this not solve the problem then post back
My System SpecsSystem Spec
21 Jan 2012   #3
Rigel

Windows 7 Home Premium x64
 
 

Hi Qdos, thanks for the fast reply! I apllied the settings last night but it didn't solve the problem when i got home this morning But i did notice something else.. When typing the ipconfig /all command i am now no longer connected to the router - even though it says so if i click Properties in the connection settings (It says i'm connected to the router but with no internet acces this time).. But when i get another laptop to connect to the wireless it automatically fixes my connection too. This is my home network and getting another laptop to connect to the wireless internet has always fixed my connection too. Can this be router-related at my home network? I am starting to believe this is a 2 part problem - my home network which can be fixed with another laptop connecting AND rebooting - and other networks (home, friends) which i can only fix by rebooting.
My System SpecsSystem Spec
.


Reply

 Unstable internet connection when changing from cable to wireless




Thread Tools





Similar help and support threads
Thread Forum
Internet browsing connection unstable.
Sorry, theres possibly a topic for this but Im losing my internet browsers at every 5 minutes. So by the time I search in the forum and find something, my internet is gone... :( So here’s my problem: Im running Win7 32. Since few months now, I lose my browsers. My internet connection is ok...
Browsers & Mail
Can connect to the network, Unstable internet connection
Hi, I'm having problems with my internet connection. I can connect to the internet, but it seems to disconnect every second or so. I first thought the network adapter drivers were corrupted, but even after reinstalling it didnt help at all. I forgot to add this, if I run the cable to my wireless...
Network & Sharing
internet connection help unstable youtube stream help
hi my internet connection is bad when streaming youtube videos the stream is not constant it is always goes from slow to fast and never stays fast but on my dads it stays stable and fast it is something with my setting is there any tweaks to fix this
Network & Sharing
Unstable Internet Connection?
Hey guys , Just installed windows 7 last week, notice my internet keeps going on and offline, its not my internet or network router, cuz my laptop is working fine, I tried disabling and re-enabling , doesn't seem to help, I have to reboot my pc every time. Do you guys think this is driver...
Network & Sharing
Cable connection but no internet
My laptop's plugged to the system but it says constantly no internet,reset the router...done that over and over. When I try plugging another laptop to the system it's fully functional,intenet access as usual. so..any ideas as to what should do? This is what is displayed on the laptop...
Network & Sharing
Wireless connection unstable and constant dropping in signal quality
I have had the WRT160N for about a year now, and it seems to be working fine until about 2 weeks ago. I did not change anything on my notebook nor on the router setup. The only thing that i can think of is that I have recently purchased a diNovo Mini keyboard from logitech. But i dont think...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App