Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: internet connection in virtual machine

18 Aug 2009   #1

Windows 7
 
 
internet connection in virtual machine

Hi everybody!

I'm new here, and I have one problem that I can't solve.
I've installed Microsoft virtual 2007 Pc on my laptop that's running on windows 7. In Virtual PC I installed Windows 2k3 server enterprise edition. Network controller settings forit is NAT, and In 2k3 server I don't have Internet connection. Before while I was running XP it worked perfectly. I suspect on firewall in win 7, but I don't know how to edit it to allow virtual PC go to internet... does anyone knows the answer?
thank you!


My System SpecsSystem Spec
.

18 Aug 2009   #2

 
 

Quote   Quote: Originally Posted by domac385 View Post
Hi everybody!

I'm new here, and I have one problem that I can't solve.
I've installed Microsoft virtual 2007 Pc on my laptop that's running on windows 7. In Virtual PC I installed Windows 2k3 server enterprise edition. Network controller settings forit is NAT, and In 2k3 server I don't have Internet connection. Before while I was running XP it worked perfectly. I suspect on firewall in win 7, but I don't know how to edit it to allow virtual PC go to internet... does anyone knows the answer?
thank you!
Hi domac. Welcome to Windows Seven Forums! I was new here once also so we have that in common!

Hopefully, this tutorial on Windows 7 Firewall will give you the info you are looking for. If not, please let us know!

Robert
My System SpecsSystem Spec
22 Aug 2009   #3

Windows 7
 
 

thnx for the effort and answering but it's not the problem in win 7's firewall... in it, Virtual PC is allowed... any other ideas?
I manually configured network settings on 2k3 server... static IP address, default gateway is my router, DNS server address is also my router IP address, and alternate DNS server is my ISP's DNS server.
I have no more ideas what could be wrong with it...
My System SpecsSystem Spec
.


22 Aug 2009   #4

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

Hello, Domac and welcome to the SevenForums.

Let's begin with upgrading your Virtual PC. Uninstall Virtual PC 2007, then download and install the latest version, designed to work with Windows 7. Remember to reboot after uninstall, before installing the new version.

Remember to backup your existing virtual drives by copying all the .vhd, .vmc, .vsv and .vmcx files to a secure place.

You can download latest Virtual PC here. Come back when you have installed the new one and we'll continue.

Kari
My System SpecsSystem Spec
22 Aug 2009   #5

Windows 7
 
 

I've solved it... the thing was I needed to restart virtual machine to take effect change I made for networking... by default it's Local only, and I've changed it to NAT. I didn't reboot after that...
thanks folks
My System SpecsSystem Spec
22 Aug 2009   #6

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

Quote   Quote: Originally Posted by domac385 View Post
I've solved it... the thing was I needed to restart virtual machine to take effect change I made for networking... by default it's Local only, and I've changed it to NAT. I didn't reboot after that...
thanks folks
Nice to hear you solved your issue. I recommend though to upgrade your Virtual PC.

Kari
My System SpecsSystem Spec
22 Aug 2009   #7

XP_Pro, W7_7201, W7RC.vhd, SciLinux5.3, Fedora12, Fedora9_2x, OpenSolaris_09-06
 
 

Quote   Quote: Originally Posted by Kari View Post
Nice to hear you solved your issue. I recommend though to upgrade your Virtual PC.

Kari
Kari,

Your 'upgrade' link goes to the SevenForums home-page...

i.e.:
Quote:
You can download latest Virtual PC here. Come back when you have installed the new one and we'll continue.
My System SpecsSystem Spec
22 Aug 2009   #8

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro with Media Center
 
 

Quote   Quote: Originally Posted by ChuckR View Post
Kari,
Your 'upgrade' link goes to the SevenForums home-page...

i.e. Windows 7 Forums

Fixed. Thanks for noticing.

Kari
My System SpecsSystem Spec
22 Aug 2009   #9

XP_Pro, W7_7201, W7RC.vhd, SciLinux5.3, Fedora12, Fedora9_2x, OpenSolaris_09-06
 
 

Quote   Quote: Originally Posted by Kari View Post

Fixed. Thanks for noticing.

Kari
No problemma.
My System SpecsSystem Spec
Reply

 internet connection in virtual machine




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:44 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33