Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network Driver Adapter is missing after restart


15 Feb 2012   #1

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Network Driver Adapter is missing after restart

This is an on again off again problem over the past month and is getting worse.

To start, I have Broadcom network driver and a desktop with hardwired internet connection (Comcast). A Dell computer running Windows 7 64 bit.

When I start my computer (nearly everyday now, but not in the beginning) I can't connect to the internet. I get the message that my network driver adapter is missing.

I used to do a system restore to get it to work.

Then that started failing, so I reloaded the driver and that worked for a while.

Now, I sometimes have to try several restore points (even one that worked yesterday and doesn't today) to get one that will connect to the internet. Sometimes reloading the driver doesn't work anymore either.

My computer is about 4 months old and my system spec have been uploaded here.

Any other ideas? From what I have read on the forums I think maybe I should buy a new Network Interface Card but I am not sure that is the right answer.

My System SpecsSystem Spec
.

15 Feb 2012   #2

Windows 7 Ultimate SP1 64-Bit
 
 

Welcome to Windows Seven Forums.

You say your computer is only 4 months old. Have you spoken to Dell with a view to getting the network card replaced free of charge while you're still in the warranty period?
My System SpecsSystem Spec
15 Feb 2012   #3

Win7 H.Prem. 32bit+SP1
 
 

You might have to clean the inside of your pc or the mobo battery needs replacing or the NIC is not seated correctly.
Did you get the Broadcom driver from Dell support site.
My System SpecsSystem Spec
.


15 Feb 2012   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I actually have a techie friend helping me try to solve this problem and was just coming here looking for new suggestions.

Seavixen32, I have a feeling if I contact Dell they will try to tell me it is a software problem.

Roderunner, I actually downloaded the newest version from the Broadcom site (it is newer than the one on the Dell site).
My System SpecsSystem Spec
15 Feb 2012   #5

Windows 7 Ultimate SP1 64-Bit
 
 

Quote   Quote: Originally Posted by sburton1313 View Post
Seavixen32, I have a feeling if I contact Dell they will try to tell me it is a software problem.
How can you say unless you try? I recently had a RAM problem and was sent replacement RAM sticks without any quibble on Dell's part.
My System SpecsSystem Spec
16 Feb 2012   #6

windows 7 64 bit
 
 

I know this sounds odd, but, I've had the same problem and the resolution seems to be to let the computer warm up.
I live in Florida and I only have this problem when the room the computer is in is cold. Once it warms up it's fine.
The cold snap lasted about three days and then its over 60 degrees in the room and it works fine.
I tried all the suggested fixes and nothing worked. Other users have had the motherboard and Broadcom NIC replaced
and still have had the problem. Just track the temperature and see what you find.
Steve W.
My System SpecsSystem Spec
25 Feb 2012   #7

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

switcs, Can you tell me how you solved your problems since it seems this may be mine? What I mean is when it was too cold did you wait for the machine to warm up and suddenly it connected again, or did you have to restart the machine, etc.
My System SpecsSystem Spec
25 Feb 2012   #8

windows 7 64 bit
 
 

It seems I needed to restart, once it found it missing it wouldn't find it again unless it re-booted.
It hasn't happened on mine in about a month now that it's warmer here.
My System SpecsSystem Spec
08 Mar 2012   #9

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Dell replaced my motherboard for me. Evidently the adapter is integrated into the motherboard now? Anyway, so far so good! Thanks for all your help.
My System SpecsSystem Spec
Reply

 Network Driver Adapter is missing after restart




Thread Tools



Similar help and support threads for2: Network Driver Adapter is missing after restart
Thread Forum
Missing drivers for network adapter? Drivers
Network Adapter Driver is missing, cant connect to internet. Network & Sharing
Solved network adapter missing Network & Sharing
Solved Network adapter missing. Drivers
USB network adapter causing pc to restart slow, please help. Hardware & Devices
Missing Network Adapter? Please help! Network & Sharing
Network adapter is missing Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:34 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33