Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Extremely slow browsing and downloading when connected to public WiFis

10 Mar 2012   #1
mlapse

Windows 7 Home Premium 64bit
 
 
Extremely slow browsing and downloading when connected to public WiFis

Hi

Recently I've been experiencing some painfully slow internet browsing and downloading speeds on my Sony Vaio VPCSE, it's basically not possible to use internet because of this. These problems first occurred about a week ago and came from nowhere. So far I've tried to connect to three different public WiFis and it seems like there's something wrong with the network card or internet settings on my computer as these problems show up regardless of wifi.

I have been browsing the web for a solution to this and tried quite a few different things in order to get it fixed but so far nothing has helped.

I have not had the possibility to connect to anything else than public WiFis in the past week so I don't know whether the problems would persist if I were to connect to a private/home network.

I would appreciate any help in order to fix this! Thanks


My System SpecsSystem Spec
10 Mar 2012   #2
Zepher

Windows 7 Ultimate 64bit
 
 

you need to connect to a known good wifi or use a different device at the ones you have used to see if the problem is with the wifi or your laptop.
My System SpecsSystem Spec
11 Mar 2012   #3
mlapse

Windows 7 Home Premium 64bit
 
 

I've tried a few wifis, the critical one is the university wifi which I'm gonna need to have access to. I know it's supposed to work fine as others have not had these issues and I also checked with the computer support at uni, it seems like there's something wrong with the laptop/settings (but they weren't able to fix it for me). Don't have Internet at home atm, we'll get it in a few days hopefully so then I can try to connect to that as well
My System SpecsSystem Spec
11 Mar 2012   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by mlapse View Post
Hi

Recently I've been experiencing some painfully slow internet browsing and downloading speeds on my Sony Vaio VPCSE, it's basically not possible to use internet because of this. These problems first occurred about a week ago and came from nowhere. So far I've tried to connect to three different public WiFis and it seems like there's something wrong with the network card or internet settings on my computer as these problems show up regardless of wifi.

I have been browsing the web for a solution to this and tried quite a few different things in order to get it fixed but so far nothing has helped.

I have not had the possibility to connect to anything else than public WiFis in the past week so I don't know whether the problems would persist if I were to connect to a private/home network.

I would appreciate any help in order to fix this! Thanks
Lets try flushing DNS cache and renewing your IP.

Flush the DNS cache and restore MS's Hosts file ...
Copy and paste these lines in Note pad.

@Echo on
pushd\windows\system32\drivers\etc
attrib -h -s -r hosts
echo 127.0.0.1 localhost>HOSTS
attrib +r +h +s hosts
popd
ipconfig /release
ipconfig /renew
ipconfig /flushdns
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 1
del %0

Save as flush.bat to your desktop. Right click on the flush.bat file to run it as Administrator.

Your computer will reboot itself.
My System SpecsSystem Spec
11 Mar 2012   #5
mlapse

Windows 7 Home Premium 64bit
 
 

Ok thanks, I tried running the file but unfortunately it didn't fix the problem
My System SpecsSystem Spec
29 Mar 2012   #6
kamiquaze

Windows 7 Home Premium, 64 Bit
 
 

Hi,

I have exactly the same problem in Windows 7. I also use a new sony VAIO. I realized this behavior with the Sony factory settings using wifi with differeent browsers and still have the issue. The OS itself is quick, I can work within Windows without having any problems, but as soon as I open a browser Opera or IE both are veriy slow and do not react for minutes. The misterious thing is that after waiting for about 10 minutes browsing becomes normal in both browsers.I've never seen such a strange behavior...

What I can surely say is that it is not a hardware problem because I'm writing this with the VAIO notebook using Linux. It must be a software/driver issue but Windows is up to date and drivers are also up to date since Sony distibutes them by their "Vaio care software". I have a lot of computers with many different Windows and Linux versions but never had this kind of problem.

Any kind of idea is appreciated.
My System SpecsSystem Spec
29 Mar 2012   #7
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Another more likely problem is that the Sony wireless connection manager is probably hindering the Windows 7 wireless connection manager.

In this case it's best to uninstall the Sony wireless connection manager in add/remove programs so that your machine will only use the Windows 7 version.

You should also delete or remove any and all of the built in bloat ware that came preinstalled on your Sony laptop, including and especially any A/V software that came preinstalled on your system.

It also may help to define your wireless connection settings in the Wireless Connection Manager set up page.
My System SpecsSystem Spec
Reply

 Extremely slow browsing and downloading when connected to public WiFis




Thread Tools





Similar help and support threads
Thread Forum
connected to a public network with a limited connection
hi there, suddenly on my hp desktop i couldn't access the internet so i troubleshooted the connection and it always says " investigate router or broadband modem issues " and asks me to reset the router i did it so many times but its not effective and it always says im connected to an unidentified...
Network & Sharing
Extremely slow network file browsing over VPN
Hi, I'm connected to my work network using a PPTP VPN connection. The browsing of files on the remote server is extremely slow in W7. I have another computer that has Windows XP on it, and there it's fast as always. I read about the Remote Differential Compression, but disabling that didn't...
Network & Sharing
why does Windows Firewall say Public Networks Connected?
Why does it say "Connected" next to "Public Networks" in my Windows Firewall page when in fact my computer does not show it is connected to any network at all? Why is Windows Firewall telling me I am connected but all the other relevant notifications in my computer say that I am not connected? ...
Network & Sharing
DNS problems after connected to public network
Hi! I've got the following problem on my Lenovo ThinkPad SL510 running Windows 7 Enterprise x64: When running my PC in my home network everything works fine. I can ping IPs on my network and i can ping their hostnames. However, when I have been logged in into the wifi network at my school...
Network & Sharing
Boot time extremely slow when external hd connected
Hi,I have windows 7 installed, and the boot up time was under 1 min, i noticed when i connected my external hard drive it will go through the normal bootup checks and then i get a black screen with a white curser that blinks in the top left corner of the screen.It says on this blank screen section...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App