Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Speed slow after clean install windows 7 connected with LAN

13 Mar 2012   #1
bradywadywoo

Windows 7 Ultimate 64Bit
 
 
Internet Speed slow after clean install windows 7 connected with LAN

My internet speed has really decreased since I installed windows 7 I have realised that my internet is so much more slow than usual. I'm prepared to upload screen shots of anything required I have tried doing a search for an update for my ATHEROS PCI-E ethernet device and it came back as sayin it was up to date.

Thanks in advance,
Bradywadywoo


My System SpecsSystem Spec
.

13 Mar 2012   #2
Katherinez212

Windows 7
 
 

Well this is the basic problem, you should delete all the history, because in history you never realized that some defected files are there...and other thing is try to check, through change your internet connection.
My System SpecsSystem Spec
13 Mar 2012   #3
bradywadywoo

Windows 7 Ultimate 64Bit
 
 

When I first opened up the browser though I noticed I had slower than usually internet connection and wouldn't the first time be the fastest since there is no internet connection I am also experiencing slow internet with not just browser but programs as well.

Thanks
My System SpecsSystem Spec
.


14 Mar 2012   #4
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Hi Bradywadywoo,

What's your computer's specs, Windows 7 requires more RAM?

You may also disable unnecessary Startup Apps, click on the Start button and type msconfig press enter, locate Startup tab and uncheck unnecessary Apps. Check the Services Tab as well and disable services that are not needed, careful though...
http://www.optimizingpc.com/windows7..._services.html
My System SpecsSystem Spec
Reply

 Internet Speed slow after clean install windows 7 connected with LAN




Thread Tools





Similar help and support threads
Thread Forum
Windows 7 internet speed slow on wireless, but fast on wired
I have two Windows 7 Laptops that connect to a Motorola SURFboard eXtreme cable modem SB6121. Suddenlink (cable provider) recently upgraded our network which gives 50 MPS speeds or more. I can only get 50 MPS when I disable wireless on my laptop and connect with a direct cable. Otherwise I get 20...
Network & Sharing
Desktop WIFI Internet Issue - Connected, but Slow/Dropped Internet
I've been battling this particular issue for a couple of weeks now without much success. I have a custom built desktop where my WIFI connection will deteriorate to the point where internet (and gaming over Steam, etc...) will be either painfully slow or unable to load pages at all. Windows claims...
Network & Sharing
Windows 7 very slow after a clean install
Hi there I am very new to this forum so I do not know If this thread has been opened before. Recently, I did a clean install because my laptop started playing up (tried to download windows updates over and over again and it got very slow) and whenever I start my laptop it takes 15-30 40...
General Discussion
After a clean install.. my internet is extremely slow.
On Thursday I decided I was going to do a clean install of windows 7. I initially had windows home, but installed windows 7 pro this time. I created a backup on my external and proceeded to do a clean install. When the install was finished. I installed the motherboard drivers, then the video...
Network & Sharing
Very slow internet speed in Windows 7
Hi guys, 2 Days ago I upgraded my PC and moved from XP to Windows 7 Enterprise x64. Everything was going smooth as butter, untill it was moment to use my internet. When I try to download something I get 50-60kb/s dl speed, 100 at max, while in XP my normal dl speed was around 5mb/s. I've...
Network & Sharing
Internet Speed Slow After RC Install
Hi, I have been a BETA tester for windows 7 since the first BETA was released. Before installing RC V.7100 my speed was fine, Since installing, i have had many connection problems, 1 or 2 connection drops in the past week and Very slow speeds from 40-60KBps. Normally my internet speeds range from...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App