Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network Adapter Not Shown in Network and Sharing Center


23 Aug 2009   #1

Win7
 
 
Network Adapter Not Shown in Network and Sharing Center

I have a linksys usb600n (v2) using the Windows 7 driver from linksys. It installs and is displayed correctly in Device Manger - BUT it doesn't appear in the Network and Sharing Center as an adapter. This same device and driver were previously working just fine in this system - but I rebuilt the OS (clean install) after testing a number of security products out.

The initial install went fine - no problems that I remember - just plug in the adapter and install the drivers obtained from Linksys (Ver 3.00.01.0). I tried the same thing on the re-build and it looks fine until I go into the Network Center and can't set up wireless networking since the adapter does not appear.

SIW shows TWO (2) linksys USB adapters under Hardware/Network Adapters, but does not show the network adapters in the Network Information section.

Any ideas?

My System SpecsSystem Spec
.

24 Aug 2009   #2

 
 

Quote   Quote: Originally Posted by dhartmann4030 View Post
I have a linksys usb600n (v2) using the Windows 7 driver from linksys. It installs and is displayed correctly in Device Manger - BUT it doesn't appear in the Network and Sharing Center as an adapter. This same device and driver were previously working just fine in this system - but I rebuilt the OS (clean install) after testing a number of security products out.

The initial install went fine - no problems that I remember - just plug in the adapter and install the drivers obtained from Linksys (Ver 3.00.01.0). I tried the same thing on the re-build and it looks fine until I go into the Network Center and can't set up wireless networking since the adapter does not appear.

SIW shows TWO (2) linksys USB adapters under Hardware/Network Adapters, but does not show the network adapters in the Network Information section.

Any ideas?
Hi dhartmann. Welcome to Windows Seven Forums!

It would seem that your computer is confused!! I would suggest, while the usb adapter is plugged in, you remove all drivers in "Device manager". Then unplug the usb adapter and reboot the computer. After Windows has loaded, check "Device manager" again for any remnants of usb adapter drivers. If it is clean, plug the adapter in again so that the usb driver can install again but this time with only one instance. That should un-confuse your computer and allow the adapter to appear in network adapters again.

Let us know if this provides a solution or if we need to try something else?

Robert
My System SpecsSystem Spec
27 Aug 2009   #3

Win7
 
 

Thanks for the suggestion. I have tried that and it still shows the two devices in device manager after I delete them/reboot/re-install. I've also tried three other methods to get the linksys adapter working. First I found a note somewhere with instructions on a regedit process to delete any related registry entries, the Windows 7 drivers on another clean install of Windows 7 RC1, and the Vista x64 drivers on a clean install. All 3 failed.

I have been able to get an older "G" wireless adapter working so I do have the box up and useful. I've also noticed the Linksys seems to have pulled those drivers from the website, so I'm going to blame them at this point. The only thing I can't explain is why they worked the first time. I'll try again when the GA version of Windows 7 comes out.

thanks again.
My System SpecsSystem Spec
.


27 Aug 2009   #4

 
 

Quote   Quote: Originally Posted by dhartmann4030 View Post
Thanks for the suggestion. I have tried that and it still shows the two devices in device manager after I delete them/reboot/re-install.
I would say you should only have one device visible in the device manager, and that is the source of this issue.

Yes, I agree and am also waiting for the retail 7 to release. 7 has performed so well for me since January that I forget the RC is still in Beta mode. I am looking forward to the retail release to solve some of these issues.

Cheers!

Robert
My System SpecsSystem Spec
Reply

 Network Adapter Not Shown in Network and Sharing Center




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:34 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33