Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Homegroup no longer working - confused!


21 Mar 2012   #1

Microsoft Windows 7 Ultimate 64-bit SP1
 
 
Homegroup no longer working - confused!

I am running a Windows 7 64-bit desktop on a home network connected to 2 other desktops (one with the same OS as mine, the other with Win 7 32-bit) as well as 2 other laptops through a wireless router. My homegroup was working perfectly with all 5 computers until this morning.

I attempted to connect from my 64-bit system to the 32-bit desktop (as I do on a daily basis), however, I could no longer access any of the shared folders and Windows said on both computers that there was no homegroup set up. This is strange since we have been using the homegroup successfully for many months.

I ran the homegroup troubleshooter on both computers and synched the clocks as suggested to no avail.

I attempted to create a new homegroup on both computers but neither homegroup could see each other - each computer kept wanting to create a new homegroup. I subsequently left the newly created homegroups and rebooted both computers. I also reset both wireless cards and the router.

After searching on forums for an answer, I realised that one of my homegroup services had been stopped on my 64-bit machine, so I started that service again and rebooted.

Now when I log onto my 64-bit computer (named Jane for argument's sake) and attempt look at my homegroup settings, it says Jane-PC has created a homegroup on this network (see screenshot). Since I am Jane, this is weird; although it says I have created a homegroup, I can neither join, leave or enter the correct password for this homegroup. I have tried to enter the old as well as the new homegroup passwords. I hope this makes sense!

I am stuck, as now Jane-PC and all of my other computers can see the new homegroup but none of us can join it!

Is there any way of completely removing all records of a homegroup and starting again? e.g. in regedit?




Attached Thumbnails
Homegroup no longer working - confused!-homegroup.jpg  
My System SpecsSystem Spec
.

22 Mar 2012   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Once you get into the problem of "can't leave the Home group" you need to perform the fix below.


The fix for this problem seems to be Deleting the file idstore.sst under C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking

You may need to do this on each of your homegroup machines.


Once everything at peer Networking Grouping is running you may also need to do this...

Start the Task Manager
Click on the service Tab
Find the "HomeGroupProvider"
and then stop the service.


You may need to go back into services and enable Peernetworking again after the fix. Don't forget to restart all machines making the adjustments.

After this you should be able to create a new Home group and will be able to join the new Home group from your other networked machines.
My System SpecsSystem Spec
22 Mar 2012   #3

Windows 7 Ultimate SP1 64-Bit
 
 

As far as I'm aware, if every computer leaves the homegroup it no longer exists.

In essence, you could do just that and create a new homegroup on your main computer with a fresh home group password before getting your other computers to join the new homegroup.
My System SpecsSystem Spec
.


24 Mar 2012   #4

Microsoft Windows 7 Ultimate 64-bit SP1
 
 

Thanks for your replies and suggestions!
My HomeGroup is back up and running now I removed the idstore.sst files on my computers and realised one of the HomeGroup services had been stopped (not sure why). I restarted the service, rebooted and all of a sudden I could create a new HomeGroup.
My System SpecsSystem Spec
24 Mar 2012   #5

Windows 7 Ultimate SP1 64-Bit
 
 

You're very welcome.

Pleased to see you're up and running again and thanks for the update.

The solution may help others with a similar problem.
My System SpecsSystem Spec
25 Mar 2012   #6

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by imoani View Post
Thanks for your replies and suggestions!
My HomeGroup is back up and running now I removed the idstore.sst files on my computers and realised one of the HomeGroup services had been stopped (not sure why). I restarted the service, rebooted and all of a sudden I could create a new HomeGroup.
Yes that's just another little Windows 7 bug and many people have had in the past.

Unless that idstore.sst file is gone it's impossible to create or leave the Home group.

I'm glad that deleting that terrible file fixed it for you.
My System SpecsSystem Spec
Reply

 Homegroup no longer working - confused!




Thread Tools



Similar help and support threads for2: Homegroup no longer working - confused!
Thread Forum
Solved Photoviewer no longer working Music, Pictures & Video
start button not working.help the confused :D Hardware & Devices
computer that created HOMEGROUP is no longer working! Network & Sharing
Solved Really need help, PC no longer working. BSOD Help and Support
Homegroup no longer working... Network & Sharing
Firewire no longer working in Win 7 Drivers
Netbook no longer appears on Homegroup Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33