Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Tray Icon for Network always showing a red X?


24 Mar 2012   #1

Windows 7 Home Premium x64
 
 
Tray Icon for Network always showing a red X?

Hello, I am new to SevenForums

Anyway so up until the beginning of the month my networking tray icon was working fine, showing the bars that show for WiFi and stuff... but now it just shows the LAN connection icon with a red "X" on top of it...

System Specs

Windows 7 Home Premium x64 SP1
6GB of RAM
AMD E-350 Processor 1.60 GHz



Attached Images
 
My System SpecsSystem Spec
.

24 Mar 2012   #2

Windows 7 Ult, Windows 8.1 Pro,
 
 

Lets try flushing DNS cache and renewing your IP.

Flush the DNS cache and restore MS's Hosts file ...
Copy and paste these lines in Note pad.

@Echo on
pushd\windows\system32\drivers\etc
attrib -h -s -r hosts
echo 127.0.0.1 localhost>HOSTS
attrib +r +h +s hosts
popd
ipconfig /release
ipconfig /renew
ipconfig /flushdns
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 1
del %0

Save as flush.bat to your desktop. Right click on the flush.bat file to run it as Administrator.

Your computer will reboot itself.
My System SpecsSystem Spec
24 Mar 2012   #3

Windows 7 Home Premium x64
 
 

I tried this but it kind of didn't work...


When Windows starts connecting to the network the icon will show properly but as soon as it's done it will just go back to the "X" this does half fix the issue

here's the network connections control pannel thing screenie


Attached Thumbnails
Tray Icon for Network always showing a red X?-capture1.png  
My System SpecsSystem Spec
.


25 Mar 2012   #4

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by pltnfish View Post
I tried this but it kind of didn't work...


When Windows starts connecting to the network the icon will show properly but as soon as it's done it will just go back to the "X" this does half fix the issue

here's the network connections control pannel thing screenie
You should right click on the LAN connection far left and disable it also. I believe the X is showing you that the LAN cable is disconnected.
My System SpecsSystem Spec
25 Mar 2012   #5

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by chev65 View Post
Quote   Quote: Originally Posted by pltnfish View Post
*snip*
You should right click on the LAN connection far left and disable it also. I believe the X is showing you that the LAN cable is disconnected.

That didn't work... it did the same thing as before: when connecting it'll show the icon correctly, when it's done it'll go back to the LAN Disconnected icon
My System SpecsSystem Spec
25 Mar 2012   #6

Windows 7 Ult, Windows 8.1 Pro,
 
 

Have you tried looking in your Device Manager to see if there are any yellow marks on any of your other network adaptors?
My System SpecsSystem Spec
25 Mar 2012   #7

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by chev65 View Post
Have you tried looking in your Device Manager to see if there are any yellow marks on any of your other network adaptors?
I just went in there, I found a couple of VMWARE drivers
My System SpecsSystem Spec
25 Mar 2012   #8
Arc

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64 Bit SP 1
 
 

See if the thread Solution: Wrong wireless network icon displayed helps you anyhow .
My System SpecsSystem Spec
25 Mar 2012   #9

Windows 7 Home Premium x64
 
 

That didn't work
My System SpecsSystem Spec
25 Mar 2012   #10

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by pltnfish View Post
Quote   Quote: Originally Posted by chev65 View Post
Have you tried looking in your Device Manager to see if there are any yellow marks on any of your other network adaptors?
I just went in there, I found a couple of VMWARE drivers
Are you using virtual machine ware on this machine?

You should try removing the VM drivers with the yellow marks.
My System SpecsSystem Spec
Reply

 Tray Icon for Network always showing a red X?




Thread Tools



Similar help and support threads for2: Tray Icon for Network always showing a red X?
Thread Forum
Solved Deleting my own network connections listings (sys tray network icon) Network & Sharing
Correct Network Tray Icon - Requires Network and Sharing Center Open?? Network & Sharing
Solved Wrong Network Icon in system tray Network & Sharing
No pop-up when clicking system tray network icon? Network & Sharing
Question on network icon in system tray Network & Sharing
Network Tray Icon has a yellow triangle. Network & Sharing
Network icon missing from system tray Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:58 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33