Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: VirtualBoxs host-only adapter and "MSBROWSE"

05 Apr 2012   #1
beginner99

Windows Home Premium 64bit
 
 
VirtualBoxs host-only adapter and "MSBROWSE"

Dear All,

I have a Win 7 install on my Desktop. This PC has some shares containing video files I watch on my TV using the WDTV Live media player. This worked until I installed VirtualBox on this Desktop. In that case, the shares are never visible to the WDTV Live. I then found this

Troubleshooting Windows File Sharing.... - Western Digital Community

thread about Windows networking and discovered that my desktop with the shares does not have the ..__MSBROWSE__. listed by the nbtstat -a <computerName> command. VirtualBox installs a host-only network adapater used for shared folders between host and Guest OS. Disabling this adapter fixes the issue:

Fix Slow Windows Networking Problems When VirtualBox is Installed | Scottie

Hope you are still following. What I would like is a working network and shared folders. Is there a way to "force" ..__MSBROWSE__.? What setting in the host-only adapter could affect this?


My System SpecsSystem Spec
05 Apr 2012   #2
Ztruker

Windows 8 Core X64
 
 

What happens if you change it to Bridged?
My System SpecsSystem Spec
06 Apr 2012   #3
beginner99

Windows Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Ztruker View Post
What happens if you change it to Bridged?
The VMs thereself are bridged. The issue is this happens even if virtualbox is not running. Virtualbox installs a network adapter and that adapter is causing the issue. I have to disable it but then sharing folders between guest and host doesn't work anymore.
My System SpecsSystem Spec
06 Apr 2012   #4
Ztruker

Windows 8 Core X64
 
 

Which computer does have teh ..__MSBROWSE__.?
My System SpecsSystem Spec
10 Apr 2012   #5
beginner99

Windows Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Ztruker View Post
Which computer does have teh ..__MSBROWSE__.?
My desktop. There is no other computer in the network. WD TV Live is a dedicated "box" for media playback. However if I enabled the network adapter installed by virtual box, then my desktop is not "__MSBROWSE_" and sinc eits the only win 7 pc probably there is now __MSBROWSE_ at all in the whole network.

What I dont understand is why this additonal adapter "kills" "__MSBROWSE_"
My System SpecsSystem Spec
10 Apr 2012   #6
Ztruker

Windows 8 Core X64
 
 

My System SpecsSystem Spec
11 Apr 2012   #7
beginner99

Windows Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Ztruker View Post
Thats the link I posted in my opener, However it would be preferable to have that adapter running and a usable home network...
My System SpecsSystem Spec
11 Apr 2012   #8
Ztruker

Windows 8 Core X64
 
 

What did net view /domain show you? Were there one or two listed.
Did you work through the entire set of instructions in the first link you posted?
My System SpecsSystem Spec
Reply

 VirtualBoxs host-only adapter and "MSBROWSE"




Thread Tools





Similar help and support threads
Thread Forum
"Intel USB 3.0 eXtensible Host Cont. Driver" Crash during installation
Iím downgrading a ASUS N550LF-CN100H from windows 8 to windows 7 Pro x64. But when I try to install the driver "Intel(R) USB 3.0 eXtensible Host Controller Driver" the system crash. I have installed the latest version of the BIOS (2.12) and changed some settings (for W7). - Boot -> Lunch CSM...
Drivers
malicious? "Host process for windows tasks" in notification area icons
When I view my notification area icons, I see an entry for "host process for windows tasks". I believe it is related to either rundll32 or task host, both of which are all in their legitimate folders. is there any reason why this would be here? It is set to show only notifications. What...
General Discussion
"Local Area Connection" missing in "Change adapter Settings".. Plz hlp
I have to set up a Broadband connection. But Local Area connection icon is missing. Someone told "drivers" could be missing... I installed few. But the problem is as it was.. please guide me in this regards.. Thank you Screen shots Attached
Network & Sharing
"Wireless Adapter Not Found!" - Internet Adapter Problem
Hi, I bought the D-Link Xtreme N Dual Band USB Adapter (Model: DWA-160) and installed the drivers and such, and my computer detects the actual USB Adapter fine, but the software that came with the device doesn't, and gives me the message "Wireless Adapter Not Found!"... It does say that it's...
Hardware & Devices
Eject hardware showing "Windows host process"
My external HD will not eject. In Vista it ejects fine. I west to customize the tray icons and saw this. The eject button listed as "Windows Host Process" What is up with this and is this why it will not eject? I have never seen this before and wonder if it's correct or a bug. I went back a few...
Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:04.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App