Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: X11 forwarding not working w/ Putty & Xming under Windows 7

11 Apr 2012   #1

Windows 7 Ultimate sp1 x64
 
 
X11 forwarding not working w/ Putty & Xming under Windows 7

I am using putty to connect to linux servers from my Windows 7 Ultimate machine (recently upgraded from XP). I know that SSH is configured properly on the linux machines because X11 forwarding works properly when connecting from my XP machine. Putty and Xming on my Windows 7 machine are configured exactly as they are on the XP machine, however, X11 forwarding does not function on the Windows 7 machine. I have confirmed that Xming is listening on port 6000 on the Windows 7 machine via "netstat -a". Both putty and Xming are the same versions as on the XP machine. I have removed all antivirus software and the windows firewall is currently disabled. Both the XP and Windows 7 machines are connecting through the same router and there are no additional devices (eg. switches, etc) between them. Does anyone have any suggestion as to what may be causing X11 forwarding to fail from my Windows 7 machine?

My System SpecsSystem Spec
.

11 Apr 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

This link should have the information you need to get this working. Has to do with LAN manager authentication and NTLM security and disabling the encryption. Most of this is required to get Windows 7 working with older servers. You can ignore the part about disabling IPv6.

password protected network share
My System SpecsSystem Spec
17 Jan 2013   #3

Windows 7 Enterprise SP1 (64bit)
 
 
The link worked for me.

I was having the X11 Forwarding not working with my newly obtained laptop running Win 7 64bit. This thread proved to be the cure for my issue.

Thank you!
My System SpecsSystem Spec
.


17 Jan 2013   #4

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

Thanks for replying Nelson. I'll have to mark this as solved now.

These same settings are still creating problems accessing NAS box's and old servers on Windows 8 machines.

I've posted these settings twice just this week and they worked both times.
My System SpecsSystem Spec
17 Jan 2013   #5

Windows 7 Enterprise SP1 (64bit)
 
 
Pass it along too

I passed along this thread to Colin Harrison so that he might make a reference to it in the Xming Troubles section.
My System SpecsSystem Spec
Reply

 X11 forwarding not working w/ Putty & Xming under Windows 7





Thread Tools



Similar help and support threads for2: X11 forwarding not working w/ Putty & Xming under Windows 7
Thread Forum
Port Forwarding Not Working Network & Sharing
Solved Port forwarding not working... Network & Sharing
port-forwarding not working Network & Sharing
Port forwarding still working ? curious why ? Network & Sharing
Putty and Windows 7 Home Premium 64-bit Error. General Discussion
How to disable email forwarding - obvious solution not working Browsers & Mail
Xming/XDMCP Blocked by Windows 7 Firewall Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:57 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33