Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7 keeps losing the Internet

29 Aug 2009   #1
Benway

xp/Windows 7
 
 
W7 keeps losing the Internet

Hey all,
I've been running W7 since beta (now using the RTM) and every few reboots or coming back from sleep mode, it loses connectivity to the Internet. Very frustrating. It usually takes one or two hard reboots (or even unplugging and leaving the computer sit) to get it back. No rhyme or reason. I'm dual booting, so I can boot right over to XP and things are normal. Never had this issue with the XP boot, just W7. This problem happened with the other builds as well.

Troubleshooting in W7 never finds anything (no surprise there), resetting connection doesn't work either. Connection is rock solid when I have it, it's just on reboot or coming back from sleep mode when the problem happens.

Why this just happens randomly is beyond me. Any ideas? It's keeping me from using w7 full time and I sure won't purchase it when it's this flakey.

-b


My System SpecsSystem Spec
.
29 Aug 2009   #2
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by Benway View Post
Hey all,
I've been running W7 since beta (now using the RTM) and every few reboots or coming back from sleep mode, it loses connectivity to the Internet. Very frustrating. It usually takes one or two hard reboots (or even unplugging and leaving the computer sit) to get it back. No rhyme or reason. I'm dual booting, so I can boot right over to XP and things are normal. Never had this issue with the XP boot, just W7. This problem happened with the other builds as well.

Troubleshooting in W7 never finds anything (no surprise there), resetting connection doesn't work either. Connection is rock solid when I have it, it's just on reboot or coming back from sleep mode when the problem happens.

Why this just happens randomly is beyond me. Any ideas? It's keeping me from using w7 full time and I sure won't purchase it when it's this flakey.

-b
One quick thing you can do is to uncheck IPv6 in the network card settings.
This often does the trick.
You have to realize however, that this will break the Homegroup function.
Meaning you will have to setup network shares like it is done in XP and Vista, which imho is safer and easier.

If it doesn't help, post back.

good luck
My System SpecsSystem Spec
30 Aug 2009   #3
Benway

xp/Windows 7
 
 

Anyone know what's causing this flaky connectivity and why it's only sometimes?
My System SpecsSystem Spec
.

27 Oct 2009   #4
skatman

W7 ultimate and Vista home premium
 
 
W7 does not connect to the Internet on startup

Hi Benway,
I'm having exactly the same problem. I'm also dual-booting, but with Vista which has IPv6 enabled. With Vista evertything just works without a problem. I have a Thomson TG782 modem on ADSL2+. I would also like to get to the bottom of this problem.
Cheers sk
My System SpecsSystem Spec
Reply

 W7 keeps losing the Internet




Thread Tools





Similar help and support threads
Thread Forum
Losing my internet connection
Hi.Im having problem with my internet.Im using wired connection but without router/modem.It's a usb internet flash drive.The internet provider is from Bulgaria MaxTelecom.My problem is that when i connect the usb in my pc it connect perfectly until i try to open web site in the browser.When i open...
Network & Sharing
Keep losing my internet connection.
For some reason I get disconnected for no apparent reason, turning the modem off and on or a restart usually fixes the problem for a few moments, I use www.dpreview a lot, is it possible the fault is there? I have run disk check, disc clean, defragged and all the other obvious solutions but to no...
Network & Sharing
Losing internet connectivity
I have a HP laptop which I use on a family Talk Talk WiFi network just within the house. My internet connection works fine all day until approximately 16:50 then drops out for the rest of the evening. Other users in the house have no problems. Any ideas please. David Crofts
Network & Sharing
Losing Internet Connection
I have two computers w/Windows 7 Enterprise 64-bit that are exactly alike with the exception of the TV tuner cards. The one w/one Hauppauge WinTV-HVR-2250 card runs perfectly. Both running wired connections, with a new N150 router The system with the internet issue has an ASUS E35M1-M PRO AMD...
Network & Sharing
Losing connection to internet
Hey guys, this is driving me nuts. I have a Marvel Yukon ethernet controller, which is a wired connection only a few feet from socket. For some reason I lose connection at random times? I need to reboot to fix this. In event viewer there is the following Yukonw7 Event 101 Driver status 1 I...
Network & Sharing
Losing Internet Connection
i have an annoying problem. i'm suffering from intermittent internet disconnection. it happened regularly with vista ultimate and it just happened on win 7. i have a mobile broadband modem connected to a xp sp3 box. the laptop connects via a netgear wireless router.win 7 has been able to fix the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App