Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unidentified Public Network & Invalid IP Address

31 Aug 2009   #1
KyleLevell

Windows 7
 
 
Unidentified Public Network & Invalid IP Address

Hello. I have been using Windows 7 for about a month now and two days ago i started to have network problems.

I cannot connect to the internet or my network and keep getting messages saying that the network cable is unplugged when it is not. After a while i was able to get a different message and the computer connects to an unidentified network and when i troubleshoot this it tells me i have an invalid IP address.

I know the problem has got nothing to do with the hardware or my internet. I have tried 2 other router's & another modem with different ethenet cables with no luck but my network/internet is working fine on my laptop which is also Windows 7.


My System SpecsSystem Spec
.
31 Aug 2009   #2
logicearth

Windows 10 Pro (x64)
 
 

What about switching out the NIC on the PC? Have you tried that?
My System SpecsSystem Spec
31 Aug 2009   #3
KyleLevell

Windows 7
 
 

No i have not tried this as i don't have a second one. But i have uninstalled the drivers and re-installed them with no luck.
My System SpecsSystem Spec
.

31 Aug 2009   #4
Crypto

Windows 7 Professional, Windows XP
 
 

May be your NIC is dead ? As you tried external devices which Should Word and if they failed that means your internal thing(NIC) may have the problem.
My System SpecsSystem Spec
31 Aug 2009   #5
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Clear your DNS cache, see if that helps.

Open a command prompt....from the Start menu, select Run > In the box/"open field", enter cmd.exe
enter ipconfig /flushdns press 'enter'
My System SpecsSystem Spec
31 Aug 2009   #6
fseal

Windows 7 x64 Ultimate
 
 

Did you recently install adobe photoshop or CS?

Adobe products install a service called Bonjour that on W7 messes with the DNS in such a way as to create invalid entries in your gateway list causing this exact problem.

There is an article/thread on here about how to remove it. Sorry I don't have the info at my fingertips atm...

[Edit] Ooops, this doesn't sound the same actually, Never mind!

(Here is the thread anyway)

http://www.sevenforums.com/network-i...d-network.html
My System SpecsSystem Spec
31 Aug 2009   #7
KyleLevell

Windows 7
 
 

It started working about 30 minutes ago but stopped working again after about 10 minutes so dunno wether it can be the NIC.

I have tried Clearing my Cache to with no luck.

I actually installed Adobe Photoshop & Dreamweaver about a week ago but i think i unselected Bonjour to be installed with it and i cannot find it in my services list either.
My System SpecsSystem Spec
31 Aug 2009   #8
KyleLevell

Windows 7
 
 

I did IPCONFIG/ ALL in CMD and this is what it told me.

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Kyle-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
Physical Address. . . . . . . . . : 00-12-3F-75-DC-0F
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{9D965381-3014-4C61-8EDD-5014E98C1EC9}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\Windows\system32>
My System SpecsSystem Spec
31 Aug 2009   #9
zigzag3143

Win 8 Release candidate 8400
 
 

KL

You know if thats all of what ipconfig gave you then all three sections are off. What method do you use to connect wired, or wifi?

You are missing this section
Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : hvc.rr.com
Description . . . . . . . . . . . : Dell Wireless 1390 WLAN Mini-Card
Physical Address. . . . . . . . . : 00-1A-92-42-2D-90
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::c596:d81a:74a:c43f%13(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Monday, August 31, 2009 7:31:55 AM
Lease Expires . . . . . . . . . . : Tuesday, September 01, 2009 7:31:53 AM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 218110610
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-11-D4-4A-07-00-15-C5-76-D6-03

Ken
My System SpecsSystem Spec
31 Aug 2009   #10
KyleLevell

Windows 7
 
 

My desktop computer is connected to my router which is connected to my modem and my laptop & xbox 360 connects wirelessly to the router.
My System SpecsSystem Spec
Reply

 Unidentified Public Network & Invalid IP Address




Thread Tools




Similar help and support threads
Thread Forum
Unidentified Public Network With No Internet Access Help!
Hey guys, I am new here and I saw how helpful you all were so I decided to ask for some help. Just today I got a new E4200 router and for some reason I can not connect to the internet. Although on my old router I could connect just fine The Network and Sharing Center Says that I am connected to...
Network & Sharing
Windows 7 HP unidentified network is public
I posted a reply on a similar topic but figured I'd start a new thread even though it seems this has been discussed a lot. I have a verizon wireless cell access point. I connect a w7hp pc to it and set it as a home network. I also have a nic in the same w7hp box connected to a local 10/100/1g...
Network & Sharing
unidentified network - public network Windows 7 64bit
Hello all, I have tried all the similar solutions to my problem but non eworks. I have just installed WIndows 7 Home 64bit. Wireless works (slooooooow). The cable from my Billion router/modem is recognised but does not work. In network and sharing centre I can see Wireless as Home...
Network & Sharing
Unidentified network - invalid IP configuration
As per a lot of other people on here, I'm having issues with connecting my desktop PC to my BigPond router. It will connect via wireless (have an installed D-Link DWA525 wireless card) but will not connect via LAN. I've changed the IP, DNS and Default gateways to the same as the other working...
Network & Sharing
please help! unidentified public network with invalid ip
Hello this is my first time posting a thread on a forum site but here we go lol I recently upgraded to windows 7 and everything was working perfect very impressed overall. I have cable internet through comcast. I had my modem plugged into a wireless router then my desktop was directly connected...
Network & Sharing
Unidentified network - invalid ip address
I'm setting up a new computer and having problems getting on the internet. The connection worked at first but was very slow. I changed Ethernet cables to see if that was the problem and now have nothing. The error that I am getting is: "Local Area Connection" doesn't have a valid IP...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:09.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App