Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Connected to router, but no internet access

26 May 2012   #1

Windows 7 Home Prem 64 bit
 
 
Connected to router, but no internet access

On my laptop, which is a Windows 7 64 bit HP Pavilion g6-1b79dx, I recently lost my my internet access. I can log into my router but can't access the internet. I have tried safemode with networking and also tried using a USB wireless network adapter. I am confident that it is not my router. I have about 6 other devices connected to the wireless network with no issues. I have also tried to connect to another network with no luck. I have tried uninstalled and getting the latest drivers.

If anyone can help, I would greatly appreciate it. Thanks in advance.



Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Emily-HP
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Broadcast
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physical Address. . . . . . . . . : D0-DF-9A-48-77-0E
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Ralink RT5390 802.11b/g/n WiFi Adapter
Physical Address. . . . . . . . . : D0-DF-9A-48-77-0F
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::cd2f:c565:6094:7014%16(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.14(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Saturday, May 26, 2012 8:54:30 AM
Lease Expires . . . . . . . . . . : Sunday, May 27, 2012 8:54:30 AM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 265346970
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-A4-4D-D0-D0-DF-9A-48-77-0F

DNS Servers . . . . . . . . . . . : 192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
Physical Address. . . . . . . . . : 78-E3-B5-54-40-1A
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{191BC30E-2027-49F8-8FCD-FDEF7776DF51}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\Windows\system32>

My System SpecsSystem Spec
.

26 May 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

According to your ipconfig you should be online. I'm guessing that the either winsock or the network stack is somehow messed up. If that is the case then resetting them should fix the problem.

Save the file below, unzip then click on the .exe and let the file run until your machine reboots. Report back and let me know what happens.


Attached Files
File Type: zip IPResetALL.zip (33.6 KB, 1300 views)
My System SpecsSystem Spec
26 May 2012   #3

Windows 7 Home Prem 64 bit
 
 

Thanks for the reply. I tried a windows 7 socket repair and still no luck. Since you said it looked like I should be connected, which I agreed with, I tried uninstalled Webroot. I rebooted and now it is working flawlessly. I am unsure as to why webroot was blocking me, I have been running it for over a year and no issues.
My System SpecsSystem Spec
.


26 May 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by spaumn View Post
Thanks for the reply. I tried a windows 7 socket repair and still no luck. Since you said it looked like I should be connected, which I agreed with, I tried uninstalled Webroot. I rebooted and now it is working flawlessly. I am unsure as to why webroot was blocking me, I have been running it for over a year and no issues.
The other day it was Hamachi blocking an internet connection, this weeks it's webroot, last month is was AVG. Some of these AV's will create rules out of the blue apparently that will just cut off internet access. It's pretty hard to keep up with them all.

Glad you have it working now.
My System SpecsSystem Spec
Reply

 Connected to router, but no internet access





Thread Tools



Similar help and support threads for2: Connected to router, but no internet access
Thread Forum
connected to wireless router no internet Network & Sharing
Wireless router is connected, no internet access, power surge? Network & Sharing
Laptop losses internet access, but says "connected" to wireless router Network & Sharing
Connected to router but not internet Network & Sharing
connected to router but no internet Network & Sharing
Connected to router but cannot connect to internet Network & Sharing
Connected to router but no internet access Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:45 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33