Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wi-Fi is working but LAN is not connecting to the internet.

01 Jun 2012   #11
TarekElsakka

Windows 7 Home Premium
 
 

It did not work, unfortunately.

Wi-Fi is working but LAN is not connecting to the internet.-6-1-2012-7-32-48-pm.jpg

Wi-Fi is working but LAN is not connecting to the internet.-6-1-2012-7-33-19-pm.jpg

I am beginning to think it may be because the LAN network is set to Public rather than HOME or Private. But I don't know.




My System SpecsSystem Spec
.
01 Jun 2012   #12
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

It looks like you are now getting an IP from your router for the LAN connection where you weren't before so it seems to be a step in the right direction. So something we did worked but the Unidentified public network is now the problem.

On the network connection page it looks like you have your wireless enabled but it's not enabled in your ipconfig/all?

Do you have anything from Apple installed like iTunes or Adobe Photo shop? There is a service called Bonjour which is famous for creating the extra public connection which is showing up as Unidentified Public network.

Can you check the IPv4 properties page and make sure that nothing is entered there and that it's set to use DHCP. It looks like you have an extra default gateway entered there for the DNS server. If you can do that and disconnect the wireless also.
My System SpecsSystem Spec
01 Jun 2012   #13
TarekElsakka

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by seavixen32 View Post
There are dozens of inbound and outbound rules, and I don't know what they do.
My System SpecsSystem Spec
.

01 Jun 2012   #14
TarekElsakka

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by chev65 View Post
It looks like you are now getting an IP from your router for the LAN connection where you weren't before. On the network connection page it looks like you have your wireless enabled.

Do you have anything from Apple installed like iTunes or Adobe Photo shop?
I have iTunes and Adobe (Photoshop, Elements, etc.) installed.
My System SpecsSystem Spec
01 Jun 2012   #15
TarekElsakka

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by chev65 View Post
It looks like you are now getting an IP from your router for the LAN connection where you weren't before so it seems to be a step in the right direction. So something we did worked but the Unidentified public network is now the problem.

On the network connection page it looks like you have your wireless enabled but it's not enabled in your ipconfig/all?

Do you have anything from Apple installed like iTunes or Adobe Photo shop? There is a service called Bonjour which is famous for creating the extra public connection which is showing up as Unidentified Public network.

Can you check the IPv4 properties page and make sure that nothing is entered there and that it's set to use DHCP. It looks like you have an extra default gateway entered there for the DNS server. If you can do that and disconnect the wireless also.
I checked. Nothing is entered in the IPv4 or the IPv6 properties pages and DHCP is enabled. There is also nothing under the gateway section.
My System SpecsSystem Spec
01 Jun 2012   #16
TarekElsakka

Windows 7 Home Premium
 
 

Thank you so much for your help guys but I give up. It just doesn't make any sense.

Wi-Fi is working but LAN is not connecting to the internet.-6-1-2012-7-58-29-pm.jpg

Wi-Fi is working but LAN is not connecting to the internet.-6-1-2012-7-58-50-pm.jpg


My System SpecsSystem Spec
01 Jun 2012   #17
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by TarekElsakka View Post
Quote   Quote: Originally Posted by chev65 View Post
It looks like you are now getting an IP from your router for the LAN connection where you weren't before. On the network connection page it looks like you have your wireless enabled.

Do you have anything from Apple installed like iTunes or Adobe Photo shop?
I have iTunes and Adobe (Photoshop, Elements, etc.) installed.
Ok then we have found the source of the problem. Please follow along and try not to get distracted. The firewall settings have absolutely nothing to do with this.

This is a very common problem which is caused by the now famous Apple Bonjour service, this is why I asked if you had iTunes or Photo shop installed.

To fix the Bonjour problem which installs with both iTunes and Photo shop do this...
To fix ...
Run MsConfig

Under the Services tab uncheck the service called "##Id_String1.6844[... and then a bunch of numbers]" by Apple

Reboot and problem solved.

To remove the Bonjour service completely.

1. Navigate to C:\Program Files\Bonjour
2. Rename the mdnsNSP.dll file in that folder to mdnsNSP.old
3. Restart your computer
4. Delete the Program Files\Bonjour folder
My System SpecsSystem Spec
01 Jun 2012   #18
TarekElsakka

Windows 7 Home Premium
 
 

Those are the only ones I see by Apple.

Wi-Fi is working but LAN is not connecting to the internet.-6-1-2012-8-11-26-pm.jpg

I'm guessing I should disable the Bonjour one?


My System SpecsSystem Spec
01 Jun 2012   #19
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by TarekElsakka View Post
Those are the only ones I see by Apple.

Attachment 214655

I'm guessing I should disable the Bonjour one?
Yes you should absolutely disable the Bonjour service then reboot the machine, and then uninstall the service then reboot the machine.

This should fix the problem straight away.
My System SpecsSystem Spec
01 Jun 2012   #20
TarekElsakka

Windows 7 Home Premium
 
 

I did that but unfortunately it did not.

It is still recognized as an Unidentified network (public network) with No Network Access.
My System SpecsSystem Spec
Reply

 Wi-Fi is working but LAN is not connecting to the internet.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Laptop connecting to internet but no internet access (DNS server)
My laptop connects to the local network, but it has no internet access. If I run troubleshooting it says that the DNS server isn't responding. It is not the internets fault, because my room mate net works fine. It's not the cables fault because I tried plugging it in both of my routers and in...
Network & Sharing
new installation not connecting to internet
ok so following on from this thread here: http://www.sevenforums.com/general-discussion/281228-laptop-stays-welcome-screen-only-cursor-visible-enla.html I was not getting anywhere while trying to get ti working. I couldn't waste any more time trying too get it booting correctly so I decided to...
Installation & Setup
IE Not Connecting to Internet
My IE 8 has stopped accessing the internet (running W7) and displays the message shown below when I try to connect. I have tried a few different sites and keep getting the same message. Firefoc connects no bother and another PC connected to the same router works fine in IE 8. I have the original...
Browsers & Mail
Pc not connecting to internet
Hello all, i have a problem with my internet connection. When i turn on my pc, it gets an ip-adress from my modem, but the connection to the internet does not work. Turning the network connection off and on again (see attachment) solves the problem, but only until the next time i turn my pc on....
Network & Sharing
Connecting a Pc to Internet using my own PC
Hi I`ve been connecting my 2nd PC to the internet using my first connection to the isp using a network On win xp it worked using the Network setup wizard I`m using an Nvidia nForce Network controller (in which my ISP connection is) and have a second Network card 3Com etherlink 10/100 ( which is...
Network & Sharing
Need help connecting to the internet...
Hello there everyone http://windows7forums.com/images/VB/smilies/smile.gif First off, my name is Gab and I just joined these forums ^^ I just got a quick question on how to get connected to the web using windows 7 which I just installed. Naturally, my motherboard wifi drivers didn't work to install...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:55.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App