Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cant connect to internet, but can to local network.


05 Jun 2012   #1

Windows 7 Home Premium x32
 
 
Cant connect to internet, but can to local network.

I can connect to my router and it shows that it has internet connection. I can access folders on my local network, but i cannot browse the internet. IE and Chrome do not work. Could someone please suggest something?
Thanks


My System SpecsSystem Spec
.

05 Jun 2012   #2
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

Welcome to Seven Forums,

You might want to try a Power Cycle.

Run the Network Troubleshooter tool from your Windows 7 computer.
Using the Network troubleshooter in Windows 7
My System SpecsSystem Spec
05 Jun 2012   #3

Windows 7 Home Premium x32
 
 

It's not the router, other computers work fine with it. Windows Troubleshooter can't find anything wrong.
My System SpecsSystem Spec
.


05 Jun 2012   #4

Windows 7 Professional SP1 64-bit
 
 

I would check for malware. On a working computer, download the installer for Malwarebytes, and download the offline update tool known as MBAM Rules (links provided below), and copy them to the problem computer. Install Malwarebytes, and update using the update tool. Do a full scan.

Malwarebytes : Free anti-malware, anti-virus and spyware removal download
http://data.mbamupdates.com/tools/mbam-rules.exe
My System SpecsSystem Spec
05 Jun 2012   #5
2xg
Microsoft MVP

Win7 & Win8 64bit
 
 

I understand that, but it might do a miracle.
Quote   Quote: Originally Posted by CalvT View Post
It's not the router, other computers work fine with it. Windows Troubleshooter can't find anything wrong.
Can you also post an ipconfig /all output for review?
My System SpecsSystem Spec
12 Jun 2012   #6

Windows 7 Home Premium x32
 
 

Sorry for taking so long in replying.
The ipconfig is as follows:


Configuraci¢n IP de Windows

Nombre de host. . . . . . . . . : Jacqueline-PC
Sufijo DNS principal . . . . . :
Tipo de nodo. . . . . . . . . . : h¡brido
Enrutamiento IP habilitado. . . : no
Proxy WINS habilitado . . . . . : no
Lista de b£squeda de sufijos DNS: tradelink.local

Adaptador de LAN inal*mbrica Conexi¢n de red inal*mbrica 2:

Sufijo DNS espec¡fico para la conexi¢n. . : tradelink.local
Descripci¢n . . . . . . . . . . . . . . . : Atheros AR9285 802.11b/g/n WiFi Adapter
Direcci¢n f¡sica. . . . . . . . . . . . . : E0-91-53-45-1C-37
DHCP habilitado . . . . . . . . . . . . . : s¡
Configuraci¢n autom*tica habilitada . . . : s¡
V¡nculo: direcci¢n IPv6 local. . . : fe80::8c3d:ab5a:6fe9:b210%16(Preferido)
Direcci¢n IPv4. . . . . . . . . . . . . . : 192.168.1.105(Preferido)
M*scara de subred . . . . . . . . . . . . : 255.255.255.0
Concesi¢n obtenida. . . . . . . . . . . . : martes, 12 de junio de 2012 01:13:50 p.m.
La concesi¢n expira . . . . . . . . . . . : jueves, 14 de junio de 2012 03:58:27 p.m.
Puerta de enlace predeterminada . . . . . : 192.168.1.1
Servidor DHCP . . . . . . . . . . . . . . : 192.168.1.5
IAID DHCPv6 . . . . . . . . . . . . . . . : 283152723
DUID de cliente DHCPv6. . . . . . . . . . : 00-01-00-01-16-03-B1-95-E0-69-95-BE-60-A0
Servidores DNS. . . . . . . . . . . . . . : 192.168.1.5
NetBIOS sobre TCP/IP. . . . . . . . . . . : habilitado

Thanks
My System SpecsSystem Spec
12 Jun 2012   #7

Windows 7 Ult, Windows 8.1 Pro,
 
 

According to the ipconfig you should be online.

Usually when it shows you online but the browsers don't seem to be working, the problem is usually winsock or the network stack is corrupted. To fix this problem, save the file below, unzip and run the file, your machine will reboot itself.


Attached Files
File Type: zip IPResetALL.zip (33.6 KB, 23 views)
My System SpecsSystem Spec
12 Jun 2012   #8

Windows 7 Home Premium x32
 
 

I tried this but it didn't work.
Thanks anyway...
My System SpecsSystem Spec
12 Jun 2012   #9

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by CalvT View Post
I tried this but it didn't work.
Thanks anyway...
In that case can you post a screen shot of the entire ipconfig/all, it will look like the picture below.

It looks like you might have a rogue adaptor creating a false default gateway.

Your partial ipconfig shows the DHCP server and the DNS server as 192.168.1.5, where your default gateway is showing up as 192.168.1.1, so something is not right here. Maybe there are two routers in this network or another network adaptor or program is causing the problem.


Attached Thumbnails
Cant connect to internet, but can to local network.-my-ipconfig.png  
My System SpecsSystem Spec
25 Jun 2012   #10

Windows 7 Home Premium x32
 
 

I finally solved this! In Internet Explorer - Internet Options - Connections - LAN Settings - The use a proxy server box was checked but with no address or port specified. I unchecked it and everything worked
My System SpecsSystem Spec
Reply

 Cant connect to internet, but can to local network.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:40 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33