Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 no internet connection at startup but works after pinging gateway

13 Jul 2012   #1
chrisgilli

Windows 7 Professional 32Bit
 
 
Win7 no internet connection at startup but works after pinging gateway

OK so i upgraded some of our PCs from a old machines running XP to a new DELL running Win7 Professional 32 Bit - I am on a wired LAN with a server and separate gateway/firewall PC

When I start my PC everything is just fine - connects to the network etc and I start receiving my e-mails from exchange BUT I get the little yellow exclamation on my network connection and the the 'No Internet' message

When I start a command box and ping the gateway I then have internet connection

I have to do this every time I shut down/re-start - this happens on the other Win7 PCs on the network - I also have a laptop running Win7 but this connects wirelessly and never has the issue

I have a guy across the road who is on a small network connected to us wirelessly - his machine will need to ping three or four times a day

Our IT guy gave up so i am looking for some clues as to where i might start looking - and why is this only with Windows 7 machines?

Thanks in advance




My System SpecsSystem Spec
.

13 Jul 2012   #2
UsernameIssues

W7 Pro SP1 64bit
 
 

Welcome to the Seven Forums!

Here is a link to more than you ever wanted to know about what W7 does to determine if it has an internet connection:
Appendix H: Network Connectivity Status Indicator and Resulting Internet Communication in Windows 7 and Windows Server 2008 R2

For your setup, it appears that none of the things that W7 tries gives it the return that it is expecting. This might be caused by the gateway/firewall that you are using. Your pinging seems to make W7 happy :-)

If I'm understanding your post correctly, everything works - it is just an annoyance that W7 indicates no internet connection when in fact the connection is fine. As a work around, you could have the ping occur automatically with each boot.

As far as the guy across the road connecting via wireless - it could be that his wireless card is set to sleep when not used - thus losing its connection. He could just run a constant ping:

ping google.com -t
My System SpecsSystem Spec
Reply

 Win7 no internet connection at startup but works after pinging gateway




Thread Tools





Similar help and support threads
Thread Forum
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
Change the default gateway to the internet to 3G connection
Hi all I am connected to a windows domain LAN and a 3G network adapter at the same time. Now by default, the Computer connects to the internet via the LAN. Now at times the internet via the LAN is VERY slow, so I would like to override it with the 3G connection, so that all internet traffic...
Network & Sharing
Internet Connection ONLY works consistently when pinging
I have been with 3 mobile for around four months and experienced excellent broadband through their Huawei e586 MyFi device with just one half day of dodgy service in that period. However, that has all changed over the past week or so. Every single day, I get about 10 minutes usage before a yellow...
Network & Sharing
Internet Connection Dropping- Default Gateway not Available
My internet connection keeps dropping, when I run the diagnostics it comes back showing the problem as the "default gateway is not available" and showing it being fixed, but then it will happen again a few minutes later. I have been Googling the issues in hopes of finding a solution but nothing I...
Network & Sharing
WLAN Internet connection issues, timeouts (WinXP works, Win7 not)
On my old netbook with Windows XP 32bit the WLAN works perfect. But I encounter connection issues on my new notebook with Windows 7 64bit. I'm connected to a router. Symptoms: playing games works pretty fine, despite some heavy lags now and then messenger (MSN, ICQ, IRC) work fine and stay...
Network & Sharing
Replay from IP(192.168.1.2) When pinging Gateway(192.168.1.1)
Hello, IP configuration is static, Gateway is 192.168.1.1 trying to ping it and get Replay from IP(192.168.1.2) and after some line nearly 6-7 lines getting replay from 10.0.0.39 few lines than "Request timed out" and so on and so on... I thought it was a problem of modem, i've...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App