Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Edimax EW-7711UAn (Ralink RT2870) won't connect to secured networks

18 Jul 2012   #1

Windows 7 Ultimate x64
 
 
Edimax EW-7711UAn (Ralink RT2870) won't connect to secured networks

Hello,

I have an Edimax EW-7711UAn (Ralink RT2870) usb wifi adapter. Both Edimax and Ralink provide ancient drivers and utility software for this product which can only be installed on Windows 7 x64 if you run the setup in XP Service Pack 2 compatibility mode. (well known issue, even though they state on their websites that their product is compatible with Windows 7 x64, and that they mention in change-logs that they've actually tweaked their antique software for windows vista and 7)


The problem is, that Edimax/Ralink have made it so that you cannot control this adapter unless you use their utility software (or at least it is running in the background). I'd be fine with this, but it seems to be keeping me from connecting to wireless networks which have any sort of password protection. ( and if I try to scan/connect via windows, the protected networks won't even show up)

Normally, this "brilliant" software would allow you to select a protected network and "Add to Profile", where you input the password and select the security protocol.
as seen in this picture:


In my Utility though, the "Add to Profile" button is greyed out whenever a protected network is selected. (if an open network is selected, it works)
I tried manually creating a profile, for my WPA/PSK network (2Dlink), but guess what, it won't let me choose the authentication methods:




Must also mention that the driver provided by windows for this adapter doesn't work. The adapter (network connection) can't be Enabled (it instantly disables itself). This is why I'm even bothering with the edimax drivers.

I dug around for 2 days installing various versions of the edimax drivers and utility software as well as the versions from ralink, but they all work the same (or don't work at all).

The utility is actively trying to block me from connecting to secure networks. I know this also because on one of the failed installations, the utility wouldn't communicate with the adapter, but it did allow me to create a WPA/PSK profile. I exported that profile, reinstalled the working driver/utility, and imported the profile. The utility automatically changed the imported profile to an Open network, instead of WPA/PSK. :|

So far I only got it to work in hotspot mode (where it acts as a router), because for this mode you must run a different utility, which looks to be implemented by different people and in a better, less primitive way.


I don't even care any more why it's greying out my options, I just want to know if there's any way I can get this adapter to work without that wretched utility software. Or should I just throw it out the window?

Thanks for bearing with me.

My System SpecsSystem Spec
.

Reply

 Edimax EW-7711UAn (Ralink RT2870) won't connect to secured networks




Thread Tools



Similar help and support threads for2: Edimax EW-7711UAn (Ralink RT2870) won't connect to secured networks
Thread Forum
Solved Secured wireless router, now Windows 7 laptop can't connect. Network & Sharing
Ralink RTS 5390 Wont connect to the internet Network & Sharing
Can see wireless networks but not connect Network & Sharing
Connect to two different networks at the same time Network & Sharing
Can't connect to Unsecured Networks. Network & Sharing
Win 7 (Pro) will not connect to wireless Networks Network & Sharing
RALINK RT2870 Wireless Driver Problem Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:51 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33